F2 = no BIOS screen

By Manikle
Jun 26, 2012
Post New Reply
  1. My son tried to install drivers and a new USB mouse.
    Immediately a message "something about a conflict" popped up and the keyboard became unresponsive.
    He tried rebooting, still keystrokes have no effect--so he can't log in to remove or reset the driver.
    F2 during startup doesn't take you to a BIOS screen, instead, it brings up "Windows Boot Manager"
    (We own 2 of the same model computer and F2 is the proper key for BIOS)
    F10 works normally
    Keyboard uses serial port.
    Would removing and reinstalling the CMOS battery be of any use?
    Please help.
  2. Manikle

    Manikle TS Rookie Topic Starter Posts: 39

    Believing that people who post questions on the internet should be courteous enough to post solutions or workarounds, when found, here it is:
    I bought a USB keyboard and both it and F2 now work.
    Problem is apparently either the serial port itself or the serial keyboard driver--probably the latter.
    I had tried 2 different keyboards earlier but both of those had been serial.
  3. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    Hi, This problem can happen when installing an operating system for the first time, not so much now with Windows, but it still does with Linux (on my spare PC).
    The problem then is that the keyboard is not read by the PC until the O/S is at the desktop, so BIOS key does not work.
    I keep an old MS 500 keyboard with the PS2 (half size DIN) plug so I can get 'at' the BIOS if needed.
  4. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    PS/2 != serial port. Anyway, many mainboards have a setting in BIOS for USB control, OS or BIOS. Setting it to "BIOS" should enable USB keyboard in that situation.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...