1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Garmin GPS USB driver problem

By fw2004 ยท 6 replies
Nov 11, 2013
Post New Reply
  1. Long story short -
    My Garmin GPS MAP 60CS will not communicate with Garmin MapSource City Select V7.0 on my system. The system is Windows 7 Ultimate SP1 X64.
    I have tried all USB ports with the same result. Either nothing happens when I first plug in and turn on the GPS device, or, if the 60CS has never been plugged into the particular USB port, I get the popup "Device driver software was not successfully installed"
    Whether or not I get this message, when I attempt to transfer data to/from the GPS device from MapSource, it is not automatically detected, and when I click the Find Device button, I get a popup with the message: No devices found...

    All other USB devices are functioning in all USB ports, so I know there is not a hardware problem.
    This GPS device was working properly at one time, and it works properly on another computer, which is running Windows XP SP3, so I know that the GPS is not defective.

    I attempted a system restore, thinking that the recent install of another USB device caused the problem, but this had no effect.
    I tried booting into another install of the same OS (I have dual-boot on the system), but it did not work there either - same error messages.
    Next, I re-installed Windows 7 Ultimate SP1 X64 in the 2nd boot of the dual-boot system, did not allow any Windows updates - and re-installed the Garmin MapSource City Select 7.0 software. Now the GPS device is able to transfer data to/from the PC.
    I believe this is evidence that something - Windows update, or other software install updated the Windows native USB driver, and doing this it cannot recognize the old USB device (the GPS MAP 60CS).
    Note that when installing MapSource software, I never allow the installation of the older Garmin USB drivers - I have read the warnings about this causing BSOD, and I have had this experience.
    When the 60CS is working properly, it is with the native Windows USB driver, not the Garmin driver.

    As for the still non-functional USB communication on the "primary" Windows install, I may just leave it alone, and just switch to the "second" boot when I want to use this device.
    But I would really like to know what is going on here.

    System specs:
    MSI P67A mobo
    Intel i5 2500 @ 3.4Ghz
    8GB DDR3 SDRAM @ 1600Mhz
    BFG NVidia GeForce 9800 GTX+ 512MB
    Total of 1.5TB HDD capacity on SATA
    Cooler Master 600W PSU

    Thanks for your help.
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    First, try running the DriveCleanup tool. If error occurs after replugging the device List any Problem devices
    • Make sure devices are connected and powered on
    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
    • On the other hand, if no devices are listed, tell me so
  3. fw2004

    fw2004 TS Booster Topic Starter Posts: 152

    After further investigation, it appears that the cause of the problem is Norton Internet Security ver When I installed it on the fresh Windows install, the Garmin device could no longer communicate with MapSource. The same error as I get in the original install. However, even when I disabled all Norton protection, the Garmin could not connect. Next, I re-opened Norton, and as expected, it informed me that my protection was off, so I clicked the button to automatically fix it. All protection was re-enabled, and a quick scan was done. Mysteriously, after this had been completed, the Garmin device was able to connect to MapSource again.

    Another piece of info: Occasionally when turning on the connected Garmin device, a BSOD occurs, with the grmusb.sys as the cause of the bugcheck. That is interesting, because I did not install the Garmin USB drivers when I installed MapSource, yet they are present in Windows\System32\drivers folder, and I find entries referring to them in the registry.

    Checking for problem devices, I find only one: PCI Simple communications controller. This is only the Intel Management Engine, which I do not need, so I don't install it.
    I'm going to run the Norton scan on the primary OS now, see whether maybe it will re-enable the Garmin to connect. I will update with the result of that process shortly.

  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Good detective work so far (y)

    Here's a couple other things you might look at:
    1. In Device Mgr, right click a device->Properties->Driver Tab click Driver Details button. You'll see which driver files the device is using, the provider, version and date

    2. Some of the driver files may be "filters". Driver files can be layered (like layers in a cake). There can be upper or lower filter files (like upper or lower layers in a cake). 3rd party filters can interfere with other 3rd party filters and the hardware layer of our "cake". You can also check Properties->Details and use the pull down tab. Look for Class Upper Filter and Class Lower Filter (we don't care about Device upper/lower filters). I'm guessing Norton adds a class upper filter to the disk device driver
  5. fw2004

    fw2004 TS Booster Topic Starter Posts: 152

    It wasn't even that complicated! This is something I should have thought of first off.
    I connected and turned on the GPS device. When the "not successfully installed" box popped up, I went to the Devices and Printers in CPL. I found the Unknown device. Right-click Troubleshoot.
    Message said no driver was installed. Tried to find one on the system - no good. Tried to find in Windows Update, but I had Windows Update disabled, so I enabled updating drivers from Windows Update. Searched for a minute - found the driver. Installed. GPS is now communicating with MapSource!
    Checked Driver details, as you said; found that newer versions of the two Garmin USB drivers (grmngen.sys, and grmnusb.sys, both dated 4/18/2012) were installed.

    What gets me is that the older versions (grmngen.sys is dated 5/12/2009, and grmnusb.sys is dated 5/8/2009) of the drivers are installed on the secondary (the fresh install) Windows 7, and seem to work - sort of. I guess that's why I get the BSOD on that install. I will now reboot into the second OS and update the driver. Thing is, when I try to update the driver in Device Manager, it never finds one. I'll see what happens if I go to Devices and Printers, and remove the device, then add new device. I will first remove the old drivers from the system, so it won't find them, and will be forced to go to Windows Update to get the newer ones.

    Now I have to document all of this, so next time it happens I will remember what to do.

  6. fw2004

    fw2004 TS Booster Topic Starter Posts: 152

    It's not over!
    Now I've got two installs of Windows 7 Ultimate x64. Both have SP1, but one has all of the Windows Updates, while the other does not.
    When I installed the Garmin USB drivers on the Windows with the updates, I got files dated 4/18/2012. But when I did the same on the Windows with only SP1, I got files dated 5/12/2009. I tried replacing the older files with the newer ones, but then MapSource could not find the GPS. After I swapped the older files back it worked again. So it looks like the version of the Garmin USB driver files downloaded from Windows Update depends on whether or not Windows itself has certain updates or not.

    I will eventually update both Windows installs to all important updates, and then try to update the older Garmin drivers to the newer ones. For now, the Garmin does work on both installs of Windows, but the older drivers seem to be buggy, occasionally causing the BSOD.

    The right thing to do here would be to upgrade both the GPS device and the Garmin mapping software, but I don't have the money for that, so I've got to stick with what I've got.
    I doubt that I would get any support from Garmin for the 60CS, since it's been obsolete for many years.

  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Hmmm.. Have you looked at the Garmin support page for your device HERE? The 2012 drivers are available for download there. There's also a firmware update. Are you running the most recent firmware??

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...