Gateway m520 AC connector

By jpcoe23 ยท 5 replies
Sep 5, 2006
  1. My P.O.S. gateway m520 which I bought about a year and a half ago has lost its power. I'm guessing it's the AC connecter pin on the back, as I've tried several different adapters. I've called a handful of different repair shops, some of the big national ones and some local ones, and they either don't want to touch it or they'll charge $300 to open it up. That's also how much it would cost to send it back to Gateway and there's no chance I'm giving them any more money. Does anyone have any suggestions that would help me out? I don't want to drop that kind of money on this machine because it's been nothing but problematic since day 1. I've considered disassembling it myself but that's proven to be more difficult than I had anticipated. I don't really care about the computer at this point, but if anyone has any suggestions I would greatly appreciate it. Thanks for your help.
  2. Rik

    Rik Banned Posts: 3,814

    When you say lost its power, what exactly happens? Do you get any lights? Any sounds? Or absolutely nothing at all?

    When you say several different adapters, what have you tried? Were they the correct voltage?
  3. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    replace the power supply.
    Very easy to do.
  4. jpcoe23

    jpcoe23 TS Rookie Topic Starter

    ive tried a targus adapter, an igo adapter, and another one that was tried at circuit city. my original gateway adapter would get super hot and the box on it started making a weird humming noise and i was told it was broken. thats when i got the targus worked for a few days, then it would plug in to the computer and the lights would fade out (both on the computer and on the adapter). then it stopped working all together. so i returned it and the geek squad person said targus products sucked, so i should get a different brand. best buy didnt have any other brands so i had to go else where. i went to radio shack and bought the igo which said it would work on my machine. it didnt. i think i left out that back when i had my original adapter i would have to wiggle it and hold it at different angles to get the connection to complete.

    so then i went to circuit city to see if they could repair it or if they had an adapter that worked. the guy there tried one of the other types of adapters and it didnt work.

    so if im leaving anything out let me know! thanks
  5. Rik

    Rik Banned Posts: 3,814

    Right, now we are getting somewhere, you said you had to wiggle it about to get it to work, its probably the power socket that's at fault then.
    The socket is probably soldered directly to a pcb (printed circuit board) in the laptop, the board itself could be cracked or the solder could be broken, if this is the case then you will have to get inside it and fix it or pay someone else to do it.
  6. jpcoe23

    jpcoe23 TS Rookie Topic Starter

    yeah, i figured i had to get inside there. thanks.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...