Getting SPL error when trying to print - Windows 8.1 Samsung M2020W

By ofiraz ยท 6 replies
Mar 30, 2015
Post New Reply
  1. Hi,

    When trying to print from a Windows 8.1 to a Samsung Xpress M2020W I only get an error on the printed page, as can be seen in the attached picture.

    My printer is connected over the WIFI network.

    Installed the latest drivers (both the standard and universal2), the latest firmware - without success.

    From other computers (Windows 8.1, Windows 7 and iPhone) I do succeed to print successfully over the WIFI network, and so I know it has to do on something in this very specific computer.

    Two differences between the problematic computer to the others:
    1. I used this computer to install the printer, with Samsung's software which also did the magic of configuring the WIFI on the printer.
    2. When looking on "Print server properties" for this printer, under the "Drivers" tab, the name of the driver is a little different and also I have only "Type 4 - user mode" while in all other computers I also have "Type 3 - user mode".

    Tried removing all drivers and let Windows set the drivers from its repository (as done in the other computers which succeeded to print), but no success.

    Also, although different symptoms that the following workaround will help -, but did not - as "Enable bidirectional support" is not checked and grayed out for my printer on the problematic computer. On my Windows 7 which succeeds to print, this option is enabled...

    I urgently need help :-(


    Attached Files:

  2. windows8

    windows8 TS Rookie

    Tried different routers, DMZ the printer IP, firmware upgrade, and everything else that can be done from my side.
  3. ofiraz

    ofiraz TS Rookie Topic Starter

    I don't get it, did you have the same problem that I have or do you suggest me to do the steps you've written?
  4. windows8

    windows8 TS Rookie

    I mean to say, you can try in different routers, may be you have router and ip issue!
  5. ofiraz

    ofiraz TS Rookie Topic Starter

    I believe that if that was the issue, the other computers would have a similar problem.
    What makes you think it is a networking issue?
  6. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    On the whole, I would start by totally deleting the printer from Windows, switch off and disconnect the printer, reboot the PC so it no longer 'knows' it has that printer anywhere at boot time.

    Read the manual to find out exactly how to install the printer again, sometimes it is important to load the driver first, or after switching the printer on, all sorts of different ways exist, and can have different results. Load the driver hopefully with exactly the same driver as the other PC's - you probably need to tell Windows where to find the printer driver, not let it make a choice itself.

    If no change, I would examine all the printer properties with a fine toothcomb. Compare every discoverable printer property from one of the working PC's and the one that does not work. Same with network properties. Clearly the bi-directional thing can cause the problem. Also try printing from a bog-standard unformatted notepad document. It could be something as simple as invalid page or margin size.
    Last edited: Apr 5, 2015
  7. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...