Glitch-Geforce 6200: Can't play games...

By Duron=worthless ยท 4 replies
Dec 24, 2005
  1.'s my story,

    I finally got around to buying/installing a "good" video card into my computer. I have a custom made X-tech Amd Duron 1200 computer(which by the way is only a 800 mhz computer being overclocked to 892) and i installed more memory into it about 2 weeks ago, it was the first step in my journey to upgrade. So yesterday i put in the Geforce 6200 into my only AGP slot. I got the latest drivers, made all my custom settings, and everything was working great so far...I finally popped in a game, Halo for the PC. The intalling went smoothly and the companies logos and intros went smoothly as well. Then when it got to the game menu, it got VERY weird. Red splashes were flying everywhere and it was just going crazy. I finally had to end task, then i started it up again. It just got worse, it eventually moved on to not even showing anything but a hardcore stobelight show. I thought it maybe to be the game and that's i tried putting in Farcry. Almost the same thing happened except at the beginning(after all the logos and recognitions went by) it just stuck to one screen. I could tell the game was still working and going because of the sound, but i just couldn't SEE ANYTHING. I was getting pretty malicious. I then installed Sims 2...and still...the same damn thing. Red bleeps, then temporary screen-freeze...i've tried many things: reinstalling drivers, messing with many settings, yelling, and then finally resorting to reinstalling Windows itself. So here i am, i'm stuck...i have reinstalled windows and ready to begin this fix. So please help me with this, i really don't feel like acting on guesses. Do i need another motherboard? Another processor?...please help.




    ECS K7SEM-3.0C Socket A/ Duron XP1200+/ A&V&L/MATX Motherboard



    SLOTS: 2PCI, 1AGP, 1AMR.
  2. hewybo

    hewybo TS Maniac Posts: 435


    I'm not a gamer, so wait for one to respond, but I don't think you've got enough processor, or RAM for those applications. You didn't mention your power supply, but maybe not enough there, either. Did you check the system requirements on the video card/games? Like I say, wait for somebody who knows more, but that's what it sounds like to me. :)
  3. Federelli

    Federelli TS Rookie Posts: 361

    Try falling back to some older drivers, download older driver versions, and see if that works.

    Nvidia is a disaster making drivers, people are always having to backtrack, anyway see if that helps.
  4. mastronaut

    mastronaut TS Enthusiast Posts: 168

    Was the G-force card brand new? If it is it may be defective.
    If you have another card laying around, check to see if it works in the same slot. If it's a used card it may be fried (unfortunately). Good luck!
  5. Duron=worthless

    Duron=worthless TS Rookie Topic Starter

    Well, everything else works perfectly...videos, images, only glitches up like that when i put in an intense game, like Farcry or Sims 2...Halo glitches as well but not as much as the others. Games like Age of Empires work just fine though...but i think it might be caused by how my motherboard AGP slot is only AGP 2x, and i think that my Geforce 6200 256 requires at least a i guess im gonna need a new motherboard. Thanks for the help though, any extra input will be thoroughly appreciated.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...