Grub Error 17.

By IBN ยท 4 replies
Sep 5, 2006
  1. Hi there people.

    I have recently installed Fedora C5 on my Intel Based sysem since SUSE and UBUNTU dont install for some reason.

    I have two SATA hard drives. On the first I have my windows os partitions and on the second I have several storage partition. I have installed FC5 on the second hard drive.

    When I boot i get the " Grub Error 17". I know FC5 is installed but I need to get the grub to let me dual boot.

    Thanx in advance.
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Something has happened to your hard drive or partitions and GRUB is confused.

    Did Fedora work properly after you installed it? What did you change?
  3. confused001

    confused001 TS Rookie Posts: 135

    Well, i think you got a problem with the grub program.
    Try installing lilo.
    If not, you should reinstall grub.
    I have had the same error, and i have heard that if you reinstall it, it might work again.

    Good luck.
  4. IBN

    IBN TS Guru Topic Starter Posts: 487

    Sorry for the delay guys. I ended up ditching Fedora and After re downloading the SUSE CDs, SUSE installed without a hitch. I wanted to install SuSE all along.
  5. YosefM

    YosefM TS Rookie Posts: 41

    Good choice :) Having run SuSE on various machines since '98, I have seen the Grub errors a few times. Almost always a reinstall has fixed it, but have had machines that needed the scsi linear profile, even though they were all IDE.

    Grub error 17 is related to invalid device. This likely means that RH wasn't loading the SATA drivers - I think SuSE might have done a better job of detection. Others have solved this with a /boot partition on an IDE drive, others have fixed it by putting /boot on the primary drive.

    ...Have a lot of fun.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...