Half Life 2 Episode 1 Crashes When Loading New Game

By alienuser09 · 6 replies
Mar 6, 2010
  1. The game starts up and goes as far as the main menu screen just fine. But when I attempt to start a new game, the "loading" screen comes up with the progression bar, gets a little over half way complete, then crashes with the following error: internal device driver error idirect3ddevice9:: present().

    I have the latest video drivers available as well as DX9.0c. After trying the Direct X web setup utility, a few of my DX files were updated and on the next Half Life 2 Ep1 attempt, I was able to see the opening sequence of a new game before it crashed with the same error. Ever since that one time, it crashes at the same point of the loading screen again.

    Granted, my computer is an old one by todays standards, but it plays Half Life 2 just fine with graphics pretty much maxed out so I figured it should be able to play episodes 1 and 2 ok as well.

    My computer:
    Alienware Area 51
    Pentium 4 3.2GHz with 1 Gig Ram
    Windows XP SP3
    ATI Radeon 9800XT 256MB
    Catalyst 10.2 Drivers
    Direct X 9.0c
  2. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    You are using the wrong Catalyst version. ATI dropped support of the 9800 series GPUs back in 2009 so the latest drivers are no longer appropriate for your card. I believe the last version that supported your card was Catalyst 9.3.
  3. alienuser09

    alienuser09 TS Rookie Topic Starter Posts: 20

    I knew I didn't have a good feeling when I updated those drivers!! The following is why I took the version 10.2 drivers. Just to make sure - this is NOT correct?

    ATI Catalyst™ Display Driver

    Version 10.2
    Operating System(s) Windows XP - Professional/Home

    AMD has moved a number of DX9 ATI Radeon™ graphics accelerators products to a legacy driver support structure. This change impacts Windows XP, Windows Vista, and Linux distributions. AMD has moved to a legacy software support structure for these graphics accelerator products in an effort to better focus development resources on future products.

    The following products have been moved to the legacy software support structure (including Mobile and All-in-Wonder Variants):

    ATI Radeon 9500 Series
    ATI Radeon 9550 Series
    ATI Radeon 9600 Series
    ATI Radeon 9700 Series
    ATI Radeon 9800 Series
    ATI Radeon X300 Series
    ATI Radeon X550 Series
    ATI Radeon X600 Series
    ATI Radeon X700 Series
    ATI Radeon X800 Series
    ATI Radeon X850 Series
    ATI Radeon X1050 Series
    ATI Radeon X1300 Series
    ATI Radeon X1550 Series
    ATI Radeon X1600 Series
    ATI Radeon X1650 Series
    ATI Radeon X1800 Series
    ATI Radeon X1900 Series
    ATI Radeon Xpress Series
    ATI Radeon X1200 Series
    ATI Radeon X1250 Series
    ATI Radeon X2100 Series

    AMD may periodically provide Windows XP and Windows Vista driver updates (for the products listed above) for critical fixes only. No new features will be provided in future driver updates. The Linux ATI Catalyst™ driver will only be supported in Linux distributions prior to February 2009 for the legacy products listed above.

    Any customers using a combination of a ATI Radeon™ HD 2000 Series, ATI Radeon™ HD 3000 Series, or ATI Radeon™ HD 4000 Series product with any of the legacy products listed above in a single PC system must use the ATI Catalyst 9.3 or earlier driver. All future ATI Catalyst™ releases made available past the ATI Catalyst™ 9.3 release will not include support for the legacy products listed above or any of the features associated with those legacy products.
  4. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    It's quite clear. Your 9800 series card is one of the legacy products listed that is not supported past Catalyst 9.3.
  5. alienuser09

    alienuser09 TS Rookie Topic Starter Posts: 20

    OK. Uninstalled 10.2 and installed Catalyst 9.3...unfortunately nothing changed. When I attempt to start a new game, I get the same error. Any other ideas would be greatly appreciated.
  6. alienuser09

    alienuser09 TS Rookie Topic Starter Posts: 20

    An update: Before trying to load a new game, I disabled HDR and changed the resolution to 800X600 - the game loaded and ran ok. Then I reenabled HDR and changed the resolution back to 1024X768 and all was well for the few minutes I was "testing". This is more of a work-around than a fix, but it looks like I'll be able to play the game now.
  7. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    Thanks for the followup and I'm glad you got it to work.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...