1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Hard drive problem

By dreck · 7 replies
Apr 26, 2005
  1. Hard drive problem

    I have a Magnetic Data Technologies 80gig, 7200rpm, ATA100, 8mb buf hard drive that I did have in my server pc.
    I installed linux on this drive in another pc. Now when I try to put this drive in my server I get ERROR reading disk.
    Weird thing is I can place this same drive in another pc and it works fine?
    I have this drive in the server as master, slave, and any other jumper combination it has.
    I have installed windows 2000 back on this drive from the other pc, but the server still gets error?
    Am I doing something wrong? Do I have a defective drive?

    My server pc is a SOYO SY-K7VEMPRO mobo with AMD Athlon 1800+
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    When do you get ERROR reading disk? Is it before booting or after the bootloader?
    Is the drive detected by the BIOS?
  3. dreck

    dreck Topic Starter

    The drive is detected by bios. The message comes right after the bootloader.
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    In that case the hard drive must have exactly the same location as it had on the original machine. If you installed Linux while the drive was the master on the secondary IDE channel then this is where it has to be now - the disk location is written into the bootloader config. You can change it one you get booted into Linux of course.

    You should be able to boot Linux properly using the bootloader command line and giving it the right disk/partition location.
  5. dreck

    dreck Topic Starter

    hmmm, well I reformated the drive?
    And now have windows 2000 pro installed.... And still get error?
  6. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Did you just simply format the existing partition? Because the MFT or FAT or whatever Linux calls theirs, may not have been changed.

    You may still have some kind of data in there causing the issue. In that case, you would have to re-write the boot sector and whatever else.

    Check the BIOS for any sort of settings that would affect hard drive bootability. Make sure that your drive is in the boot order. It might seem to be, but make sure it's named right and is, in fact, your drive.
  7. ßeetlejuice

    ßeetlejuice TS Rookie Posts: 30

    Win's format doesn't overwrite linux's "MBR"

    I had a similar problem with a 20Gb disk on which I had linux installed and wanted to use it for a Win2kpro environment again.
    Apearantly windows doesn't overwrite the "MBR", or whatever linux calls it, linux is using.
    It always started with the LiLo bootloader.
    Finally, I had mine fixed by first formatting the disk in a DOS environment bringing it to FAT16 and then went on with the installation of Win2kpro reformatting it during installation into NTFS.
    This procedure worked very well for me and left me with a perfect "no error messages" running disk and OS environment. :approve:
  8. IronDuke

    IronDuke TS Rookie Posts: 856

    Try fdisk /mbr
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...