Hard drive suddenly undetected by bios

By vampyr0 ยท 8 replies
Jun 30, 2008
  1. Hey all. I'm a newbie so please don't pounce on me for repeating a topic. I have read through similar ones here and on other sites and have gained no help or direction. Well, here goes.

    My problem is with a relatively old drive; a 20gb seagate. i removed it when cleaning the case and when i reconnected it, it could not be detected. The jumpers are correctly positioned and all cables are secure. In my cleaning I simply ran a hair dryer through the board and wiped the housings for the drive. I tested the system with a seagate 120gb and that is detected with no problems. the 20gb isn't detected by the bios or as a slave to the 120gb. There are no tell tale signs of a mechanical fault - no strange sounds or anything else out of the ordinary. my issue isn't so much replacing the drive(it is time 4 a system upgrade after all) as it is recovery of the past 3 weeks of work that has not been backed up! it would take me 3 weeks to get through it again. lol!

    please help guys!!

    i forgot to add, the drive is powering up normally. also, the system seems to take a long time to start up, almost as if it were trying to detect the drive.. but alas... still nothing..
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    You first need to verify whether or not Windows detects anything (sometimes it sees something on the usb port but doesn't know what it is)

    You need look in Device Manager to see if it lists any Unknown Devices. Be sure to expand the USB info in Device Manager when looking.

    Don't know if you're running XP or other (what are you running?) but here's a link about Unknown Devices under XP
  3. vampyr0

    vampyr0 TS Rookie Topic Starter

    Hi there LookinAround. I am running Windows XP Home Edition. I have just tried an external housing(can't quite remember the name for it) that connects internal drives via a usb port. I know that the casing works etc. XP still picks up nothing. Tried scanning for changes in the device manager as well as the add new hardware wizard - once again, nothing. There are no unknown devices and everything reports as working normally. Any other ideas will be much appreciated.
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    It may be just a coincidence, that you were cleaning the system when the drive failed. A 20GB hasn't been produced in quite a few years... I'm afraid that the drive's interface circuitry (printed circuit board) has failed, maybe because of static electricity generated when you were wiping the drive off
  5. vampyr0

    vampyr0 TS Rookie Topic Starter

    this is the thing though Tmagic, I didn't wipe the drive.. It makes so little sense to me. Is there any known way to get the drive running even for a few moments? Theres just a few files that I absolutely must try to save...
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    "In my cleaning I simply ran a hair dryer through the board and wiped the housings for the drive"...

    You wiped the support or mounting bracket for the hard drive? This could have caused a static discharge none the less, to the drive. Anyway, there is not much you can do besides pay a lot of money to a data recovery service. There is a freezer method for no spin up, and a board replacement for your trouble. This is what a data recovery service would do. They would replace the circuit board and get the data off. Be aware that the circuit board would have to be from the same model hard drive, somehow I wouldn't expect the recovery service to have any 20GB drives laying around
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    When all else fails (or even before that) is always good to try and Google info on a hardware model number and your problem (Can sometimes be a long shot but never hurts.) Also, look at mfr web site about support info.

    e.g. you 100% certain you know all the correct jumper settings and cable info? Want to compare what you got to all the Seagate specs? Find troubleshooting info for your drive on Seagate web site

    Not sure if it'll help, but does appear some places are still selling Seagate 20GB drive. You;ll need to check model numbers (you never indicated here)
  8. nickc

    nickc TechSpot Paladin Posts: 923   +11

    another good lesson here is to backup,this seems to only happen when something has not been backed up. I have been using computers sis DOS days and the only time I ever had big troubles was when I had not backed up important stuff. I have learned over the years on stuff like this to back up each days work.
  9. vampyr0

    vampyr0 TS Rookie Topic Starter

    Thanks for the input guys. The model number is ST320413A. tried seagate troubleshooting and googled the drive model before coming here. sorry for not mentioning it previously...

    nickc, I do backup regularly. this sstem belongs to my mother and for some reason she neglected to do the backup for 3 weeks. can u imagine my horror when she told me that she forgot to do it?

    lookinaround, I am 100% positive i've got everything set up correctly. checked cables and jumpers at least 12 times now..

    You guys have been alot of help. Thank you. If anyone stumbles across any other avenues I could look at, please let me know.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...