1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

HDD Failure /w strange symptoms

By phoenix9 ยท 8 replies
Dec 26, 2005
  1. Two days ago (Dec. 24) I walked over to my computer, turned on my monitor, and went to start working in Windows XP.. about three seconds later my mouse froze in the middle of my right (of 2) monitor. Well, having a wirless mouse I assumed that it was just battery failure so I tried replacing 'em, no dice. Tried keyboard, nope. Checked PS/2 ports, connections looked good. So, I jsut figured stupid windows and restarted.. When I restarted the computer sat at the POST screen for about a minute or so (it usually flashes right through) and then when it got to the point of the boot to load the OS it paused for about 5 minutes and said "Disk read error.. press Ctrl+Alt+Del to restart" ah oh.

    To eleminate other possible causes I booted from a knoppix disk (the same one I'm using now) and ran memtest86+ ... it returned no apparent RAM errors. Well since that ran ok it doesnt seem its the CPU either.

    Next I tried to isolate the apparent cause. I disconnected power and IDE to all my drives added them back one by one and noted time until it the boot failed from lack of OS, all ran normally (up through power on HDD, no IDE) but as soon as I connected IDE to the HDD it all slowed to a crawl. I opened up the CMOS and did re-detects on all the IDE drives (with all connected) each one ran fairly quickly except the HDD in question. I switched it to another IDE channel (if thats the right term, Primary Master to Secondary Master) but had the same problem. :mad:

    I didnt do antyhing yesterday because it was christmas

    Today I redid some of the previous checks (to see if the cooling had any effect) I also verified that the drive is still spinning .Then, I booted to this knoppix set-up. The boot took a very long time, especially hanging every time it was scanning IDE devices. Whats weird is that when it did finaly boot the fstab entry seems correct

    however a mount gives this error
    dmesg (cleared before the command) is attached

    running fdisk simply returns "Unable to open /dev/hda"

    Unfourtunatly there is a fairly large chunk of un-backed up data on the drive and I am hopeful that even though I'll need a new drive I can get this one read long enough to send the data to another network computer

    SPECS ON THE PC OVERALL (though I dont think many are relevant)
    Asus A7N8X Deluxe mobo
    AMD Athlon 1800+
    512 MB RAM (Kingston HyperX DDR I think, but not 100% sure)
    EVGA video card with Nvidia GeForce FX 5200 Ultra chipset

    lite-on 52x cd-rw
    lite-on 24x DVD-rom
    and the drive in question: Western Digital 80 GB IDE (model: WD8000JB-00ETA0 )

    any ideas on how to recover the un backed up data (or fix the drive if possible) would be much appreciated.

    Thanks in advance,

    ~Phoenix9 :: Donald Guy
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You want to run the WD hard drive diagnostics to see what exactly is wrong.

    Did you change IDE cables too?
  3. phoenix9

    phoenix9 TS Rookie Topic Starter

    for convience I ran a unix2dos on that file ... its attached

    and when i switched from primary master to secondary master It was on a different IDE cable

    ill try running that diagnostic if I can find it (and run it, as I'd assume its dos-based.. but I guess ill just have to get another copy of FreeDOS)
    [highlight]EDIT: I found the diagnostic and its bootable ... so no problem with that[/highlight]

    also while looking for the diagnostic.. i discovered there warrenty check form and its still under warrenty .. you think its worth getting a replacment or should I just buy a new drive? (given that its only 80 gigs?)
  4. phoenix9

    phoenix9 TS Rookie Topic Starter

    *sigh* diagnostic says Error 0159

    westerndigital.com says:
    Error code: 159
    Explination: SMART Error
    Description: Self Monitoring, Analysis, and Reporting Technology (SMART) Error returned during SMART Status/Self Test Command. The drive is defective. Replace.
    Status: Replace Drive

    And now for the stupid question: does this mean my data is screwed?
  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Well. Not necessarily. The fact that the drive fails the SMART test indicates that there's a problem with the electronics. If you can find another drive exactly like yours, then you can borrow the circuitry from the good drive and hopefully be able to access your data.
  6. Handyman

    Handyman TS Rookie

    *Well if you find a drive with exactly the same electronics then you could have a chance of repairing it.
    *You should also try Ontrack's Easy Recovery Professional. II've recovered data with that from hard drives that were beyond repair. t's worth giving it a shot.
    *Try disabling SMART in your bios.

    *Also, this might seem ridiculous but try to plug\unplug your IDE cable then boot. Try this about 20 times. You might have a pleasent surprise. Also you might want to leave your HDD in a cool (not sub-zero) place in your house for 2 days and then try reading from it again. During the 2 days pray intensively to the Disk Fairy.
  7. phoenix9

    phoenix9 TS Rookie Topic Starter

    well, all told I don't think my data is worth going through the trouble and cost to get another drive or get clean room recovery or such as its just a home computer. All it has that I wanted were my music, pictures, videos, and my school work from last year (particularly the source code from my various programming assignments) oh well, C'est la vie.

    Thanks for the help everybody. I figure Ill either just get a replacement disk (warrnty is still valid) or mabye get some SATA disks (possibly even try to set up a RAID 1 or 5 so this doesnt happen again)
  8. Ruder

    Ruder TS Rookie Posts: 98

    Repair the drive with a util such as mentioned above, or get a util that does a binary read. Translate the blocks to the area of your data, and use the tool to binary read / write to another drive.

    The error is a high block close to the core - where most errors start occurring when the heads go south. Your data should still be readable as it lies more to the middle.

    Or ... skip the effort and restore from backup - that is what most people have of their important info ...
  9. David Alexandru

    David Alexandru TS Rookie Posts: 24

    Are you using cable select to determine master/slave? If so set master/slave on the drives using the jumpers instead. It's somewhat common to have issues with cable select if the hard disks are from two different manufacturers.

    well...if it's not this.....there are some programes that could help you :
    Mach5 PopMonger Free
    Drive Health 2.0.30
    SIGuardian 1.7.335
    SIGuardian Lite 1.6
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...