Help Installing Windows 2000

By desdgl ยท 21 replies
Jul 13, 2004
  1. I have an older Dell laptop that i purchased from a friend. It has windows xp pro. after trying to install service pack 2, i found out that it was a blacklisted key. I have a full legal copy of w2k, but i am have trouble installing it on this laptop. The BIOS boots 1: Floppy Drive, 2: Internal HDD, and third NONE. I can't change any of these settings because they are locked by Dell. i also should tell you that I can only have either the floppy or cd-rom in at a time. I downloaded the windows 2000 floppy boot disks, but since the cd-rom isnt in, it cant dectet it and setup quits. The only other thing i could think of would be to use and USB cdrom drive, but i dont own one or really even want one. Am i stuck with this ilegal winxp or can i install win2k with out buying a USB drive? thanks in advance.
  2. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    I have never seen a Dell that has not had the option to change the boot priority.

    You have two options:
    1.) Change the boot sequence during in the BIOS setup
    2.) Select a temporary boot device (available on many Dells)

    You can enter the BIOS setup on most Dell computers by tapping the F2 key during the Dell logo. When you get there, you can usually press ALT + P to switch to different settings.

    If you can't figure it out or there appears to be some sort of problem , F12 usually brings up the boot menu where you can select a temporary boot device.

    Please keep in mind that your CDROM will have to be inside the computer for CDROM to show up in the boot menu or BIOS boot priority.
  3. desdgl

    desdgl TS Rookie Topic Starter Posts: 36

    I can use F2 to enter the BIOS, but almost all settings are locked because the ADMIN password is enabled and there is no way to disable it. I also tried pressing F12, but nothing happened. Is there anyway to reset my BIOS so that the settings are unlocked?
  4. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    OH... Admin password.

    That's a tough one. The boot menu (if there is one) is probably locked too.

    Laptops, in general, make it nearly impossible to remove BIOS passwords. While desktop PCs can be fixed by a simple "clear CMOS" function, laptops store passwords in a chip seperate from the CMOS. There's often no way to reset it.

    I have successfully built a Toshiba password removal dongle which would clear Toshiba passwords, but I'm unware of any such thing for Dells. I might look into the possibility of a password reset dongle if I were you though.

    There are also companies who will remove the password for a fee.

    USB CDROMs are usually not bootable. And since your computer is stuck in the Floppy / Internal HDD / None boot order, it won't boot from a USB device anyway.

    Give me a little bit and I will prepare a how to guide on installing Windows 2000 without a CDROM. Hopefully it will solve your problem. :)
  5. Rick

    Rick TechSpot Staff Posts: 4,572   +65

  6. desdgl

    desdgl TS Rookie Topic Starter Posts: 36

    Thank you for all the help, but I have one more question. I used the floppy drive to install ms-dos 6.22 on the HD. now I would like to know how to install a CD-ROM driver to the hard drive, so that it doesnt have to run from another floppy, this way once the driver is installed, i can boot the pc with the cd-rom drive in and run winnt.exe from the cd. will this work?
  7. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  8. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    most dell computors have a jumper on MOBO that disables bios password.
    not the cmos jumper
    what about there laptops?
  9. alphnumeric

    alphnumeric TS Rookie Posts: 173

  10. alphnumeric

    alphnumeric TS Rookie Posts: 173

    Not sure if this will work on your laptop, but I have used it on a desktop PC to clear an unknown bios password. Killcmos will clear your cmos and remove the requirement to have to enter a password to enter the bios. It's not a virus but your anti-virus may flag it as one, mine did.:eek: I ran it from a boot floppy and it worked as advertised.:D
  11. Goalie

    Goalie TS Booster Posts: 616

    Just outta curiosity, and I woulda thought obvious...

    Have you tried contacting your friend, and having them either give you the password (possbilities) or have them meet you and try them themselves, then disabling the password?

    recently discovered Toshiba's hardware lock password, pretty neat- seperate from the bios password, required to boot the machine. Handy little devil, I better hope like heck it never corrupts though..
  12. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Unfortunately, KillCMOS will not remove a password on laptops unless they are very, very old.
    The password information is no longer stored in the CMOS. There may be exceptions out there - But all the big brands I'm familiar with do not.
  13. alphnumeric

    alphnumeric TS Rookie Posts: 173

    Yah, I though that might be the case. I didn't think there would be any harm trying anyway.;)
  14. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    It would reset the CMOS, which might make the computer bootable from a CDROM if it is the default option. That might be interesting to try at least.
  15. sanitarium

    sanitarium TS Rookie

    hey i have the same problem except i already have a usb cd rom.
    but it did not come with a normal cd rom, i think it will only work with a usb one. i loaded xp onto it with the boot disks and a usb cdrom, but im afraid 2k doesnt recognize usb cdroms. any alternate routes or anything for installing 2k?
    the laptop is a toshiba 3440ct portege.
  16. tropicalcb

    tropicalcb TS Rookie

    re-format & cd-rom not recognised

    .... dont no if ur still out there rick....I have been trying to re-format & reload w2kpro for days & came across this thread; d/loaded a 98se boot-disk, formattedC: /s etc & did the dos edits as u wrote & I still can't switch to the cd-rom to access i386 & use my w2kpro cd's.... its a HPppavilion n3215 n/book with 6gb toshiba hdd ... after 98se floppy boot & b4 format c: /s it says DRIVE E:=Driver MSCD001 unit0 ... so I was thinking mayb i should sub E: for D: in ur dos edit section of the instructions?? if I leave ur instructions exactly as they were in ur post I'm told D: & E: r invalid file paths?......cb
  17. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    When booting from a W98 floppy, it creates a virtual drive for the W98 helpfiles (with one harddisk-partition C, probably D=virtual), the CD would thus be E.
    Get a 2.5" to 3.5" adapter, take the laptop HD out, put in a normal PC, create a big partition up front and a small one (2GB) at the end. Format C: /s and format D: both in FAT32.

    Careful! Those would be the C and D for in the laptop! They will temporarily have other drive-letters!

    Copy your W2K files to the small partition. Put the HD back in the laptop and boot to the harddisk. Then install W2K from the small partition.
  18. tropicalcb

    tropicalcb TS Rookie

    TRying 2 load

    ..... thanks mate, but 2 many logistical problems with that one.....just went back over my notes & these r the responses after following rick's instructions as I said:
    at C:\>D:\i386\winnt.exe ... igot ~~ CDR101:not ready reading Drive D

    so I then cd C:\>E:i386\winnt.exe ... & got Invalid Drive specification

    now this has happened once b4 wen I re-formatted after the original 5gb hitachi HDD was changed to the Tosh 6gb ... same thing..used the 98se boot floppy etc & got 2 the same spot as I am now ... I then loaded some tools onto the 98se boot-up disk after talking to someone about the problem, but unfortunately didnt make complete notes on how the problem was solved....wot i do remember is there was a dos screen somewhere in the sequence which had ??? ~~~ something like~~~ ?R:=Driver_Tomatounit0 any clues on where that is or am I only dreamin? ... it was a simple fix & got me to the point where I could either load the 4 x w2kpro floppies or cd to the cdrom...can't remember but I'll b makin notes this time 4 sure!!
  19. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Have you tried changing the boot-sequence in the BIOS?
    A W2K-CD should be bootable.
    Or use the 4 W2K-floppies first, and then switch to the CD
  20. tropicalcb

    tropicalcb TS Rookie

    ~~ cdrom nogo

    ~~~~~ yeah tried that a few different go .. the cdrom light comes on etc & it tries 2 but no go anywhere ... its only a 4yo notebook & i think most made in last 5-6 yrs will boot from wotever's in.... the 4 x w2k floppy set from r wot i used 2yrs ago ...but I think I started with a 96se bootdisk like this time...somewhere in there was a change/option wot got the cd going & stuffed if I can remember. anyway this time those 4 x floppies dont seem to work...mayb I download the set again & try it.
    ....the tomato bit didnt ring any bells??
    thanks again & cheers....cb
  21. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    If you get the bootfloppy for W98SE-OEM from, start from floppy with CD-rom support. Then run setup from the CD.

    There is some all-purpose CD-driver with a name like banana, not tomato. Either one will do anyway.
  22. tropicalcb

    tropicalcb TS Rookie

    re 98se floppy

    mate, ive d/loaded more boot-disks these last few days than i can poke a stick at!! ... but I will get a new box in the morning & do that one again .... these bloody floppies r such an anachronistic medium - and we thought they were hi-tech wen they replaced 5 1/4"!! but then again a 100mb HDD was REAL hi-tech!!!
    ... I'm thinking the 4 x disk w2kpro set I have is dust-ridden so mayb I got over this issue last time with them - wen they worked!!....will keep u posted.
    .... cheers & thanks again 4 ur suggestions ............ cb
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...