Help with Sandisk U3 cruzer micro usb 512MB

By Sal-117
Nov 24, 2006
  1. Well, I'm new and this is my first post on Techspot, so please bear with me...
    My problem is that whenever I plug this cruzer, it reads fine and I can see it in the my computer window, then the U3 software loads up and says "an error occured while initializing U3 launchpad: drive is unavailable or unformatted. Launchpad will close now, please format the drive, disconnect the device and try again." I tried but windows cannot complete the format for some reason...I've tried using kill_disk to erase the drive so I can then format it, but It closes up with an error report afterwards...every recovery software I've used keeps saying "bad sectors" and such...My last hope was to use the HP USB Disk storage format tool, and it finds the disk and starts, but then displays a message saying:"device media is write protected" anyone know how I can bypass this? or have any ways of solving this problem?or some software I haven't tried? please help ASAP!
  2. Sal-117

    Sal-117 TS Rookie Topic Starter

    Umm...Okay, just a little update...I managed to rid myself of that stupid U3 software on the flash that write protection crap is reads the drive as (E:) but when I try to open it it says"please insert a disk into drive E:." when I try to format now it says..."no disk in drive E:. Plase insert a disk and then try again." Any suggestions?
  3. LNCPapa

    LNCPapa TS Special Forces Posts: 4,276   +461

    Looking at your machine specs I see two hard drives (probably C: and D:) and I assume you have at least one optical drive (probably E:). If this info is correct then open up your disk management tool while the device is plugged in and assign it a different drive letter.
  4. lfuertes

    lfuertes TS Rookie

    hello all in the group
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...