How can I determine which USB ports are 2.0? I didn't think I had any but..

By mikeyd ยท 16 replies
Oct 17, 2009
  1. Astra32 says I need to install some usb drivers for 2.0??

    My computer is a compaq presario 6027us, I don't think it has usb 2.0 ... unless one of my pci cards (one of which also needs drivers apparently) is actually usb 2.0, but it doesn't look like a usb port, yeah neither of my pci cards (which I don't know what they are) are usb 2.0 I don't believe.

    Processor: Intel Pentium 4 2000 MHz
    CPU Clock: 1994.2 MHz (20.0 x 99.7 MHz QDR)
    Level 1 Cache: 8kB+12k uOp (data+instr.)
    Level 2 Cache: 512 kB
    System Name: Compaq 6027US
    Motherboard Vendor: Compaq Computer Corporation
    Board Model: Compaq 07E8h
    BIOS Version: Compaq BIOS
    Chipset Name: Intel 845G/GL/GV (Brookdale-G/GL/GV)
    Chipset Vendor: Intel Corporation
    Chipset: 82845G/GL/GV Brookdale Host-Hub Interface Bridge (A1-step)
    Southbridge Vendor: Intel Corporation
    Southbridge: 82801DB/DBL (ICH4/ICH4-L) LPC Interface Bridge

    The report is truncated in the DEMO version
    [End of Report]

    ^oh they cut out the rest of the report because I have the free version, I'll have to type it out hold on ...

    OK, So Before I click on the device in the report it lists this particular usb device as:

    82801DB/DBL USB 2.0 EHCI Controller (ICH4/ICH4-L A1 step)

    ^So I'm trying to figure out which usb ports they are claiming are 2.0 ?

    So I click on it for the details:

    Driver Status: Drivers for this device are not installed (28)

    Device Class: Unknown

    Device Descripton: Universal Serial Bus (usb) controller

    Device location: PCI bus 0, device 29, function 7

    All the USB devices above the device which has no drivers and claims to be 2.0, list like this:

    82801DB/DBL USB EHCI Controller #1 (ICH4/ICH4-L A1 step)
    82801DB/DBL USB EHCI Controller #2 (ICH4/ICH4-L A1 step)
    82801DB/DBL USB EHCI Controller #3 (ICH4/ICH4-L A1 step)
    82801DB/DBL USB 2.0 EHCI Controller (ICH4/ICH4-L A1 step) <----this is the only one that says it needs drivers installed.

    When I click one of the ones listed that does not say 2.0 and has a number after the controller, it says the drivers are installed properly, here's how it reads:

    Driver status: the device is working properly

    Manufacuter: standard usb host controller

    Device Description: Standard Universal PCI to USB Host Controller

    Device Class: USB

    Device Location: PCI bus 0, device 29, function 2

    ^(and function 1, and function 0, respectively for the other USB devices that have drivers listed as installed)

    -The one that has a problem say it's a "Universal Serial Bus (usb) controller" where as the ones with drivers installed say "Standard Universal PCI to USB Host Controller" ?

    I Don't get it

    Now, there's also a PCI device that doesn't have drivers:

    Drivers status: The drivers for this device are not installed (28)

    Device Description: Ethernet Controller

    Device Class: Unknown

    Device Bus: PCI 5, device 8, function 0

    ^^^is this one of my PCI CARDS ? I just bought this computer so I'm not sure what are taking up the PCI slots, there's 3 total and 1 free, I would like to remove the items I'm not using from the PCI slots as well, and understand how I can utilize just one of the PCI busses for my new ATI or nVidia soundcard I will be installing, but perhaps this should I should start another thread for that.

    Are PCI busses the same as IRQ's ? or, what I mean is should I set my soundcard to have it's own PCI BUS number as well as it's own IRQ number ?

    thanks a great deal, trying to learn
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1) If you go to the HP website, click on support, click for Download drivers and enter your make/model you get to the driver page for your computer here. Download the USB 2.0 driver from their site

    2) As to exactly which ports are connected to that controller... it'll be trial and error. If you connect a USB 2.0 device (like an external USB disk) to a non-USB 2.0 you'll get a little pop up message telling you "This device could run faster... etc.". So just try out all your ports once the driver is installed
  3. mikeyd

    mikeyd TS Rookie Topic Starter

    i get that message already, on both front ports, then i shut off the message cos it got annoying, and now i'm changing my wireless adapter to the back usb ports and turning back on the warning message about usb errors so see if i get it on the back.

    I'm confused now, was the message just telling me that i could get faster performance with a usb 2.0 port ? ...or was the (28) message just telling me that i need the 2.0 drivers ?

    Because device manager is telling me I need to install drivers for 1 or 2 of the usb ports (not sure how they're grouped) and Astra32 is telling me I have a usb 2.0 port(s) that need a driver installed.

  4. mikeyd

    mikeyd TS Rookie Topic Starter

    But this computer came out in 2002, did they even have usb 2.0 back then ?
  5. mikeyd

    mikeyd TS Rookie Topic Starter

    i installed the drivers (or had device manager install them automatically) AND NOW the message now only appears on the two front ports (28) and sometimes the message days "hardware not detected" or "problem with hardware" something like that AND now 2 ports on the back do NOT work at all and the other 2 ports on the back work PERFECTLY with no error messages ???


    But under device manager, all the ports are working correctly with proper drivers installed, nothing has a question mark anymore (except the ethernet controller which I don't use).

    I did the troubleshoot for usb ports and went all the way through to the end it told me my two ports in the back must be bad since the other ports atleast recognize that the wireless device is plugged in...I have no idea why I'm still getting the error messages on the front and not the other 2 back usb ports, other then maybe the front ports are USB 1.1 ?? and the back are 2.0 ??...but these ports are all the original ports that came with the computer, did compaq make presario's with 1.1 and 2.0 usb ports ?

  6. mikeyd

    mikeyd TS Rookie Topic Starter

    I shut down and turned it back on twice, still the same deal.

    Does anyone think I should do the process of erasing all the devices and drivers and having windows re-install them ? ... is that what I do ? What is that process ?

    thanks for any responses
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Let;s start here...

    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post

    Use USBView to see the hierarchical connection between device/port/controller. Plug a device in each port then look at USBView.
  8. mikeyd

    mikeyd TS Rookie Topic Starter


    I checked problem devices, and the only one is the ethernet controller and the problem is there is no drivers installed.

    Help me understand my usb devices, what's the difference between the "standard Universal PCI to USB host controller", and the "USB Root Hub" ?...I have a total of 6 USB ports, but this seems to show either just 4 (or 8 if Root Hub's are counted as ports) ???

    what am i missing ?

    I will try that program later and report back, thanks...need sleep, worked all night. and thanks again

    Intel(R) 82801DB/DBM USB 2.0 Enhanced Host Controller - 24CD PCI\VEN_8086&DEV_24CD&SUBSYS_00B80E11&REV_01\3&61AAA01&0&EF
    Standard Universal PCI to USB Host Controller PCI\VEN_8086&DEV_24C2&SUBSYS_00B80E11&REV_01\3&61AAA01&0&E8
    Standard Universal PCI to USB Host Controller PCI\VEN_8086&DEV_24C4&SUBSYS_00B80E11&REV_01\3&61AAA01&0&E9
    Standard Universal PCI to USB Host Controller PCI\VEN_8086&DEV_24C7&SUBSYS_00B80E11&REV_01\3&61AAA01&0&EA
    TRENDnet TEW-424UB 54M USB Dongle USB\VID_0BDA&PID_8189\0014D145B95E
    USB Root Hub USB\ROOT_HUB\4&DF72750&0
    USB Root Hub USB\ROOT_HUB\4&1563B891&0
    USB Root Hub USB\ROOT_HUB\4&26CF9642&0
    USB Root Hub USB\ROOT_HUB20\4&CD830A0&0
  9. mikeyd

    mikeyd TS Rookie Topic Starter

    I also wonder how the drivers are installed for the device in my other pci slot, i have no idea what it is, a modem perhaps ? wow, i'm ignorant it seems, but there seems maybe to be a built in modem from what i can tell, so why would the other pci slot have a modem in it ???...I should just take it out and see what dissapears i suppose
  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Your motherboard has 4 USB controllers
    > Intel(R) 82801DB/DBM USB 2.0 Enhanced Host Controller is your USB 2.0 controller
    > The others are USB 1.x controllers

    USB devices connect to hubs (not directly to controllers). So each controller has a "Root hub". (Root hubs are always internal hubs) USBView will show which Root hub connects to which controller.

    > If you see a "Generic Hub" those are external hubs, i.e. if you buy a USB hub and connect it to your computer it appears as a Generic Hub
    > Some USB devices only provide a single USB function (e.g. a USB mouse).
    > However some USB devices can provide more then one USB function (e.g. a USB transceiver). USB devices that can provide more then one USB function will appear as "USB Composite Device
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Now go get some sleep and can talk more later :)
  12. mikeyd

    mikeyd TS Rookie Topic Starter

    well that's very weird.

    The USBview gives me 4 different Controllers root hubs, The first 3 say "Standard Universal PCI to USB controller", each has a roothub and below each of these root hubs it shows 2 ports.

    Now, Below those 3 controllers/roothubs (and total of 6 ports grouped in 2's) There is another Controller labeled: "Intel(R) 82801DB/DBM USB 2.0 ENHANCED HOST CONTROLLER"

    This controller has a roothub and a total of 6 ports.

    When i plug my wireless usb receiver into the back 2 ports that work, it shows them under the Enhanced Controller ports 1 and 2...the other two ports on the back do not show anything is plugged in when i plug in the wireless adapter...and in the FRONT something screwy happens, when i plug into the top port, it always shows it as being in port #6 under the Enhanced Controller, when i plug into the bottom port on the front, it either shows it under the last Standard Controller port #1, OR under the Enhanced Controller port #5, but never both at the same time!


    also, the two front ports give the message "this device can perform faster with high speed 2.0 ports" where as the ports on the back don't give this message, or so it seems.

    but I don't understand how if i plug and unplug and replug on the bottom-front usb port, USBview switches it back and forth between the standard and enhanced controller each time i unplug and replug..!
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1) Wow! I can't explain (and never seen that before). I always thought (and seen) the external port is bound to a specific port on a Root Hub

    2) It is common to see many extra internal ports then you have external ports (i beleive some internal ports just aren't used and others may be used for internal devices)

    3) Now this should be consistent... All the ports on the one Enhanced Controller should all be USB 2.0. So when you connect a hi-speed device (e.g. your network adapter) to non-Enhanced controller port you always get the "can run faster warning" but you see no warning when on 2.0 controller port, yes?

    4) As to the ports in back where nothing shows, maybe they don't work?? or does any other usb device ever show up?

    5) And that port in front really switches back and forth???? that's a big mystery to me too!
  14. mikeyd

    mikeyd TS Rookie Topic Starter

    Thanks for all your help!!!

    yes it's strange isn't it!!! I can't figure it out, could it be the driver is not installed properly, or could it be that the enhanced usb driver I installed is working but really shouldn't be installed, therefore it is telling me i have an enhanced controller ? ... weird, but atleast the two back ports that work, work perfectly and DON'T give me the message...however, I still have my doubts as to whether they are indeed USB 2.0...I really didn't think I had any USB 2.0...and wouldn't they put them the 2.0 on the front ports rather then the back in that case ?

    In fact, isn't it extremely rare for a computer to have host ports of both types (1.1 and 2.0) on a computer where no extra ports have been installed ?

    I think you could be right about extra ports shown perhaps being unused (could be added late) or for the mouse and keyboard etc...but It shows nothing else is attached actually so doesn't that rule out that it could be the ports for the mouse/keyboard ?

    thanks again, and any other suggestions that anyone else has would be great.
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Most interesting!!

    I read your post, was thinking about your mysteries (in particular: seeing a device on the same port switch back/forth between controllers). And had a thought for an experiment

    1) Your computer absolutely supports USB 2.0. That fact is supported by:
    > You have a controller named an Enhanced Controller (by definition, that's USB 2.0)
    > Each time your device connects to the Enhanced Controller, you don't get the "can work faster" message

    2) Thought a bit more about the "external port" should be bound to a specific controller idea.. and then realized that must be wrong! And here's how i proved it
    > I opened Device Manager, rt click my Enhanced Controller and disabled it
    > Interesting point being what happens next to each USB device that was connect to the USB 2.0 Enhanced controller:
    > Would they all stop functioning since their controller was disabled???
    > No! Upon disabling the 2.0 Controller, Windows "re-detected" each USB device and gave me the "found new hardware" message and re-connected each device to a USB 1.x controller!!

    At minimum, this tells me that the external port is NOT bound to a controller port but Windows can (at least for some if not all external ports) choose which controller to connect a port to!

    Still doesn't yet explain why the back/forth connection to 1.x/2.0 controller you see on the front ports but certainly proves what you're seeing is, in fact, physically consistent with what's possible!
  16. mikeyd

    mikeyd TS Rookie Topic Starter

    since i have nothing important on this computer should I try a fresh re-install and see if it fixes the 2 ports not working and see if the other issues with it switching back and forth gets straightened out ?

    Or would reinstalling xp likely have no effect ?

  17. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    It's a tough call. I'd say the odds are greater that reinstalling won't make a difference.. but not so much greater that it's not worth trying (if you're so inclined).

    But, if you want to test to find out i'd recommend
    > "cloning" your hard drive and save it on external storage (e.g. USB drive) (you could use EASUS disk copy freeware)
    > Then you can simply reinstall just Windows alone and test to see if it makes a difference
    > If no difference, simply restore the clone copy so no need to have to manually reinstall everything back to a working state
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...