HP Photosmart B290a Wireless Connection

By att42weber ยท 7 replies
Jan 31, 2010
  1. purchased printer 1-26 & with 3 hrs. unable to establish wireless. son computer savy attempted for almost 2 hrs. unsuccessful. called att to verify all numbers. called HP they said had to be defective cd or att. att technician came to house & worked for almost 2 hrs. unable to enter the necessary routing IP etc. into the printer. got new cd from dealer. still no success. 1-30 dealer exchanged printer & i purchased their dealer essentials support package. told they would be able to do setup connected via internet. almost 2 hrs later he also gave up. he said the signal is there & strong. No one can find the way to enter the necessary information into the printer. i now have second printer packed & ready to return unless someone thinks they really have an answer. while printer works great with USB, i purchased to get wireless.
  2. pepsi1

    pepsi1 TS Rookie

    Check the net for compatibility issues between the computer router/DSL/modem, and bridge on your printer. If they are the same make/brand the issues should be minor. Once you are sure the bridge on the printer and the computer router are compatible, start looking into the settings (security) of the router to allow this device to connect to your network. Routers vary so much between brands it is difficult to be anymore specific. If your modem is password protected, then there should be a means in the setup procedure to allow specific devices to connect---a check box usually.
  3. roma4uk

    roma4uk TS Rookie

    Hi att42weber
    I have a HP B209a same problem as you.
    Spent 2 Hours on phone,
    Had a replacement unit sent still no good.
    My printer cant locate any networks,my comp's can get 4+.
    I can use Phones and 3 comp'son my network.
    Good luck with HP.
  4. tipstir

    tipstir TS Ambassador Posts: 2,472   +126

    Oh these type wireless printers, can be a real pain in the neck. I don't have this model but I have Lexmark Pro 205 Wireless all-in-one plus fax phone. It doesn't have hardwire connection. The software from Lexmark is pretty smart, but if one tiny piece of the puzzle is missing or screwed up the unit will not connect to the wireless network. then the unit keeps on flashing red I get errors saying unable to connect to wireless network or it's not found. (Most likely the wireless network has dropped the connection)

    What brand and model router are you using? The might be your issue. Can you force the printer to connect via WPS instead of typing in a static IP address into the printer?

    So you wireless router is setup up with: 802.11g/n
    SSID (name setup)
    encryption: WPA2 AES
    Wireless Channel set to Auto

    Move the router or place the printer in question in the same room and test it that way. It seems you have tried everything and so has HP and it still doesn't work. Then get back your money and buy another brand. My Lexmark looks like yours

    Have you power cycle the printer, wireless router, or PC?

    Finally got my stable and working.. I had to change out my wireless router and get rid of DD-WRT AP. One PC is connected to these all-in-one wireless printer by USB to configure it. It should only take less than 5-10 minutes. Once it connects you unplug the USB cable and the unit runs on it's own. I now use a 50mW high power wireless router and 50mW repeater where the main wireless can't reach. All such wireless errors are gone.
  5. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    Recommend disable encryption in the router and attempting the connection & settings from the printer w/o encryption.
    This way, you can verify everything except the SSID and its key.

    Once connected, then add encryption to the router and repeat the printer setup.

    I have set specific pairs of router+printer fail every encryption style except WEP,
    which suggests the printer and router BOTH need firmware updates.
  6. tipstir

    tipstir TS Ambassador Posts: 2,472   +126

    The problem with doing that is by default encryption is active in these wireless setup utilities. I don't see an issue running the WPA2 AES if you already have that setup and running on wireless gear their shouldn't be a problem setting up the wireless all-in-one.
  7. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    yes it should not be an issue, but in fact, I've fixed several AIO printers using this technique.
    *MANY* devices have incompatible WPA and espectially WPA2 software -- which should also not be true.

    This leads to new firmware being written (if the manufacturer is on the ball) and the suggestion to find and update it
  8. tipstir

    tipstir TS Ambassador Posts: 2,472   +126

    Well you would think if the OP did update the firmware for the device in question. Just have to wait on OP answer.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...