Huge problem with office XP 2002

By Maidenrules ยท 4 replies
May 30, 2009
  1. ........I did something really dumb and now I'm in a quandry so here it goes.....
    I was trying to free up space on my hard drive and thought it would be a great idea to delete some programs that I never use. So I went to Add/delete programs. One of the programs I deleted was MS office XP 2002. I had NO idea that excel, word, powerpoint, and publisher were all inside of office !!! When I realized my mistake, I did a system restore, but the damage had already been done. When I tried to open up word, or any of the other programs, I recieved the " Patch package could not be opened" message. I googled that, and it was recommended by MS that I download and use the Windows installer clean-up utility, which was supposed to remove all traces of the program so that I could re-install it. So I did that. BUT, when I tried re-installing with the office disk, I got the following...." error 1402 setup cannot open the registry key HKEY_local_machines\software\classes\giffile\shell\open\ddeexec. I went to regedit and went to find that registy entry so that I could see if I needed to change the permissions, but.....that registry entry does not exist !!!....
    ...So, after googling that and going through endless threads looking for an answer to this problem, I could find no help. I think my final strategy is that I need to actually "write" or create this registry entry that Office wants to open. Does anyone have any answer to this? thanks
  2. irkhairuddin

    irkhairuddin TS Rookie

    hope this can help :)

    hmm, i think u should use CCleaner (can be found in www(dot)filehippo(dot)com.
    Then, try to running this apps. Also u can try to use registry cleaner / defragmenter to remove unnecessary registry / sorts the registry in windows. Ok.. Good luck.
  3. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Alternatively, you might well have a restore point from just before you deleted office 2002, so just roll back to then
  4. Maidenrules

    Maidenrules TS Rookie Topic Starter

    I have ccleaner and I already loaded the registry backup info from 2 days before I made the changes, and I did a system restore to the point just before also, and still the problem persists. So I don't know what to do
  5. captaincranky

    captaincranky TechSpot Addict Posts: 13,013   +2,536

    First you could try deleting the entire program folder for Office (C:/ program files) If there are data files such as letters or whatnot, move them to a safe place, best would be to an external drive

    Didn't work? It might be time to try a repair reinstall of Windows.

    Boot from the Windows CD and follow the prompts to "repair Windows". You'll need to press "r" at some point.

    DO NOT, Under any circumstances choose format and install, You'll loose everything on the drive.

    This would be a good time to back up all your files, BEFORE you try a repair!

    With a repair install. (if done correctly), you shouldn't even have to update, and any program files will not be touched.

    If this is a store bought machine, you.ll need to use the factory supplied restore discs. Here again only as long as a "non-destructive restore" option is offered.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...