1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

I lost half my disk space (120GB) and can't get it back.

By GeekWannaBe ยท 12 replies
Feb 22, 2006
  1. I'm hoping I can get some assistance. It was definitely user error. I know just enough to be dangerous and that's usually my problem. (Hey what if I delete this? Ugh!)

    Operating system: XP Pro
    Harddrive: Maxter 250GB, Seagate Barricuda (20GB) two of them.
    Processor: AMD Athlon XP 1600+ 1.40GHz Processor
    MotherBoard: MSI K7t266 Pro2-RU Via Kt266A Athlon/Duron
    Skt A DDR ATX MB

    Background:I had a raid configuration with two (20GB) Seatgate drives but one drive crashed. I could no longer use windows because they were my operating system and my Maxtor (250GB) was my Data drive. (I don't know much about the raid set up).

    Not understanding how the raid works, I simply reinstalled windows on my 250GB drive and ignored the raid hard drives, but when I re-installed everything I really didn't like having my operating system on the same drive letter as my data, so I downloaded Partition Commander 9 and created a new partition. I really didn't know what I was doing and it wasn't really the way I wanted it, but it worked.

    While rebuilding my PC I lost some software and ending up searching for one or two things on the internet (cracks, regkeys etc, yes I know shame on me). While doing this I ended up with a nasty trojan virus that destroyed my computer, yeah I know I probably deserved it.

    When I rebuilt my machine again I really only wanted a 50GB drive (partition excuse me if I screw up terminology) and the other 180+GB to be my data drive.

    I tried using Partition Magic but got some batch errors while trying to do things. I don't know if I had a bad version of software(the network guy at work said he didn't have all the licenses for this utility disk he gave me)or it was because the data partition was damaged. I was trying to resize my data partition from 130GB to 180GB, 50GB on my c: drive, and about 50GB unused.

    Partition Magic crapped out on the resize, then I tried to switch that big partition from FAT32 to NTSF (that was probably stupid right?) I think I f-bombed things pretty bad and gave up on Partition Magic.

    THen I used another program I think HD Management or something, and I saw a screwed up partition (f: 120GB), my regular C: drive of 50GB, and other 50-60GB of unused space. I have all my data backed up on another PC (from the first reinstall) so I figured why not delete the big partition and start over.

    Well I spent all night deleting the screwed up partition (120GB), and this morning instead of seeing 180GB of unused space, I only have the original 50GB C: drive and 50GB of unused space. The other 120GB never game back!

    I opened up a couple different partition manager type programs and they don't see the missing partition space, nor does my PC in windows XP. I seem to have lost 120GB in hard drive space and no application or utility can see it!

    I don't want to reinstall everything AGAIN, but is that my only hope? Reformat and start over again? Did I permanently shrink my hard drive? I know I screwed up, but there must be some way to get that space back.

    Sorry if this post was long winded, I just wanted to be detailed.
  2. GeekWannaBe

    GeekWannaBe TS Rookie Topic Starter

    Problem much deeper

    I think I really screwed up this time.

    I decided to re-install windows. So I boot up on the windows XP CD, and I blow away the C: drive and restart the install.

    When I come back now I have a raw drive with 130GB and it's prompting me to add partitions and format etc.

    I'm STILL missing the original 120GB!!!

    I want to just start all over from scratch, but XP still ONLY SEES HALF MY HARD DRIVE!

    Any ideas? I'm totally lost at this point.
  3. GeekWannaBe

    GeekWannaBe TS Rookie Topic Starter

    I haven't given up yet.

    I found the maxtor CD which came with the Harddrive. I used that to create my partitions. I created a 50GB and 200GB partition and figured everything was OK.

    But when I tried to load the operating system on the drive, it only saw 20GB.

    I did have the RAID configured drives still connected. So yesterday I removed both drives from the computer and I deleted the array in the "loading" screen.

    Now the computer complains about "No arrays defined" but I can press "ESC" and continue through.

    I installed the operating system with SP 2 and still no luck. I can't find the other partitions, all XP sees is 20GB.

    I opened up Partition Magic and it only sees the C:\ partition with the OS, it's only 20GB.

    Am I continuously missing a step? Am I going in circles missing some key element every time I re-install XP?

    Obviously I'm doing something wrong, because at this point, I only have 20GB left out of the original 250GB drive and there's no data on the drive except XP.
  4. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    if you can dwnld the seagate boot disc utility
    boot from that and try to wipe the drive or write 0's to drive
    there is probubly stuff on drive that can't be accessed under the OS install
    you may want to check your bios boot options also completly remove the raid array from there
    do search on raid
    I think there are 5 main types of setup ?? could be mistaken maybe more
    raid levels
  5. GeekWannaBe

    GeekWannaBe TS Rookie Topic Starter

    Thanks for your response.

    I have the Raid zero configuration (I've also heard it called striped), but it's non-redudant and was for performance.

    Everytime I turn on the machine it still complains about not seeing the raid array, even though I deleted it in the "raid Configuration" screen.

    I don't see where the RAID is set up within the BIOS screen, I made sure the bootup 1st looks at the Maxtor(IDE-0) and the 2nd and 3rd look at the CDROM and floppy. I USED to have the primary bootup as the Fasttrack(RAID) but changed it, now the Fasttrack isn't even an option anymore.

    Right now I'm putting zero's in the 250GB maxtor because I dont have the seagate's set up yet. (I'll try the Seagate's as well).

    I just noticed the BIOS was only seeing 20GB on this maxtor drive, so I'm wondering if maybe the problem is in the BIOS itself. The motherboard is 4 years old, so maybe I need to upgrade/flash/firmware the motherboard?

    I've heard that's a risky proposition, it could screw up my motherboard and then I'm completely hosed so I'm not sure if that's a good route to go...

    Do you think a motherboard firmware upgrade is a good idea? I also have the option within the BIOS to "set the BIOS to default."

    I haven't tried that yet either.

    Thanks again for your response.
  6. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    I had to set up my raid by loading up the RAID 0 drivers that came with the motherboard when installing windows. I also had to enter it in the BIOS, but the drivers also had to be loaded.
  7. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,729   +409

    I had a problem where I wasn't getting all of my 200 gig to show up even after a clean install of XPSP2. I posted about it here, and nodsu replied:
  8. GeekWannaBe

    GeekWannaBe TS Rookie Topic Starter

    THank you for your replies, they've been helpful in troubleshooting this issue.

    I put zero's in the entire 250GB drive and the Seagate drive to no avail. I didn't check the registry key since I deleted my latest XP install, I'll have to check that once I attempt another XP install.

    I didn't find the RAID drivers, but for now I can bypass the annoying message.

    My latest theory is there is something wrong with the harddrive. I reset the defaults in the BIOS and even pulled the jumper off the motherboard and put it back on to reset it.

    I also unplugged the 250GB drive and plugged in a completely different 80GB drive (at work they let me borrow it for a minute). The BIOS and system recognized the 80GB drive. This leads me to believe the BIOS and motherboard are OK, but something is screwed up with the Maxtor drive itself.

    I reset the Maxtor to 2 partitions, one at 50GB the other at 200GB. Even if it's screwed up with seeing LARGE drives, it should have seen the 50GB partition. Especially when I can attach an 80GB drive and the system recognized the size.

    Besides the Maxtor utility disk (which I've been using) is there any utility out there that can investigate and identifu a problem with this disk?

    Is it possible to contact Maxtor and troubleshoot with them? The drive is maybe a year or two old. I don't have the receipt or anything like proof of purchase.

    One other thing I could try, is I could take my son's computer and pull out the 250GB drive and see what happens when I plug it into this computer. But I'm nervous to do that because ALL my data is saved on that PC, and I don't want to mess up my only computer that's workin in the house. Also my home network is configured on that PC, so if it goes down, doesn't my home network go down?

    I use the home network for my wife and I's work laptops that we bring home and work on stuff at home.
  9. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,729   +409

    I would definately get XP back on there. Start it off with a partition less than 120 gigs and leave the rest alone for now. Then check that registry key, it didn't exist on mine for some unexplained reason. So I had to add it, its a DWORD. If its not there, and you don't know how to add it, either google or post back. So it is entirely possible yours was missing or set incorrectly too. Then once you get the registry thing fixed, reboot, then go into computer management and disk management and create a new partition with the rest of your space (or however you want to).

    I seriously doubt there is something wrong with your drive. If your BIOS sees it as its real size, and I'm right about your drive being OK, then the only thing left is Windows. Just to be sure though the following link has some things that can help you.

    Drive diagnostic utilities compendium

    You can talk with Maxtor, they will want to know the serial number on the drive. From there they will tell you if its under warranty. If it is it doesn't matter whether or not you have a reciept. But before you call them, I'd put XP on and take a look in the registry. (its HKEY_Local_Machine, if you don't see HKLM). If the registry is good, then run those diagnostics on the drive, then post back here or call Maxtor. If you don't do that stuff first Maxtor will probably tell you to and then call back.
  10. GeekWannaBe

    GeekWannaBe TS Rookie Topic Starter

    Thanks again, I will put XP back on there and check out the registry info. At this point the BIOS is NOT seeing the correct amount on the drive, it only sees 20GB. Somewhere along the way while I was experimenting I lost most of my drive, although I haven't updated my thread title.

    I'm going to check out that link for more help.

    I looked up the serial number on the Maxtor website, and it's out of warranty so I'm not sure if they'll ignore me or not.

    I don't know if I've damaged this drive or not. The MaxtorPower max utility sees the full 250GB, but the OS, the BIOS, the diskmanagement screen within XP, and any hardware management program ONLY SEE 20GB.

    Besides loading XP and checking out the registry info, I'll check the disk utility link you sent and I'll see if there are any other tools to diagnose the drive.
  11. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,729   +409

    Go back and look all through your BIOS, you may have accidentally disabled large disk support. You can probably find your motherboard manual online somewhere if you have lost it.
  12. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    If you have the 2 drives connected to the raid ide channels it may auto try to config for that place them on the other main ide2 channel
    or maybe you tried that
    I did notice once on an older raid setup I had the raid utility was a little flakey
    can also try to reset cmos to defaults via jumper ,then go into bios and reset to optimum defaults
  13. GeekWannaBe

    GeekWannaBe TS Rookie Topic Starter

    Thanks for all your help, the combination of suggestions really helped troubleshoot and resolve this issue.

    There was apparantly something in that 250GB drive telling everything it was only 20GB. In one of the maxtor utilities it asked "set hard drive size" and there the size was less than the Native LBA value. I tried to change it several times, but no luck.

    I had already disabled the RAID, but then I had to goto the BIOS and turn off recognizing the drive, then on the motherboard took the harddrive and switched IDE slots with the CDROM.

    Then went into the CDROM Maxtor utility and set the Native LBA value, as a secondary drive, the BIOS recognized it. For whatever reason, as a secondary drive the BIOS could see the harddrive no problem. The native LBA value stuck. I switched the Harddrive back to being the primary master and was able to install XP. XP only recognized 130GB but I recognized that as a different common limitation problem that most people have.

    Updated the SP2, and even hooked the RAID back up. Maxtor was also helpful with email suggestions even though my drive had expired warranty.

    Thanks again for your help.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...