i8042prt.sys not being loaded in Safe Mode

By erlast
Apr 23, 2006
  1. Hi all,
    I have a Gateway running XP Home SP2. Long story made short, the registry recently became corrupted. The system won’t boot, even in Safe Mode. I began to recover it with the process described in MS KB article 307545. In essence, boot up using the recovery console, backup “corrupted” registry files, copy over registry files from the WINNT\Repair directory, boot up in Safe Mode, and then copy over files from a previous restore checkpoint. I got as far as copying over the files from the WINNT\Repair directory. When I try to come up in Safe Mode neither the keyboard nor the mouse will work. The boot log showed that i8042prt.sys was not getting loaded. The system originally came loaded with SP1. Thinking that the registry files in WINNT\Repair were most likely based on SP1 I backed up i8042prt.sys, kbdclass.sys, mouclass.sys, and termdd.sys. I then extracted these same files from the install CD that came with the system. It was a long shot, especially since the Safe Mode splash screen stated that it was SP2. The boot log still shows that i8042prt.sys is not getting loaded. The other four files are getting loaded.

    I’ve tried different keyboards and mice. I’ve tried keyboard only w/ no mouse.

    I am desperately trying to avoid the “ultimate” solution, i.e. reformat & re-install. This PC came from a business partner who pre-loaded some proprietary software on it. It would be a royal pain to get this software re-loaded.

    Any and all help is greatly appreciated. I apologize if this is in the wrong forum. It was a tough call between here and the Drivers forum
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...