IDE cabling problem?

By michaelr ยท 9 replies
Feb 22, 2008
  1. Hi,

    I'm the kind of one-step-up-from-noob that knows just enough to get into trouble, and not enough to get out of it.

    A few years back I graduated from upgrading to building my own system (and not very well apparently). It is based on an Intel D865PERL MB and has 2 HDs, 2 CDs and a floppy.

    The 2 HDs share an 80 strand cable as master and slave (designated C & F) and the 2 CDs share another (designated D & E). I immediately ran into a problem with the CDs not working. In trying to pinpoint the problem I eventually removed one of the HDs from the HD cable and attached one of the CDs in its place. The CD then worked. I figured the problem was with the CD cable, bought a new one and got it to work (sort of - one CD then worked, the other still didn't, but I put off playing with the problem on hold, since I wasn't copying between them, didn't need to use both at once, and was fed up with the protracted down time).

    The other day i went to install a new program and the CD that had been working now wasn't. No other program or data CDs work either.

    I took a working CD drive out of my wife's comp and installed it. no luck.

    I changed the cable. no luck.

    I googled the problem and checked various forums (inclusing this one) for similar problems and followed the routine advice (unistall using device manager and then let the plug & play system resintall them, update drivers, etc.) no luck.

    Both CD drives show up as working properly in device manager properties, but they just won't read the data off the disks. When I insert a disk, it spins, I get the reading CD spinning disk cursor icon in windows (XP prof), but it never gets to autorun. In my computer, opening the drive shows no files.

    I'm out of ideas. Any suggestings for getting the drive(s) working would be greatly appreciated.
  2. CCT

    CCT TS Evangelist Posts: 2,653   +6

  3. Matthew

    Matthew TechSpot Staff Posts: 5,332   +101

    You're absolutely 100% positive you have pin 1 to pin 1 on every single IDE connector in that system? CD1 to CD2 to motherboard?

    You have configured the jumper settings on the back of the drives properly to run as Master/Slave?

    Make sure the device is recognized and enabled in the BIOS.

    Pages 38, 72 and 77 your motherboard manual may be of use to you.
  4. michaelr

    michaelr TS Rookie Topic Starter

    Thanks CCT and Zenosincks for taking the time to reply.

    CCT: Forgive me for being thick, but I don't see the connection between the posted solution and my problem. I haven't removed a CD/DVD recording program and I'm not getting any error messages along the lines of those posted. The CD drives just won't read, much less write. Opening the master drive with a CD in it in my computer panel shows an empty space. Trying to open the slave drive with a CD in it gets me the message to please insert a CD into drive E. But both drives spin as if attempting to execute an autorun when I insert CD's in them.


    1) I am as positive as someone as relatively ignorant as me can be that I have the plugs alligned properly. All the plastic 'rails' around the male sockets on both the MB and the drives have cut outs in the middle on 'top.' The female cable plugs have plastic raised areas that fit into the cutouts. I assume that the cut-outs and corresponding raised areas are there to insure proper allignment of the pins and I'm not at all sure the cables would fit if I tried to turn them the other way around.

    2) I have the jumpers set for master on the one taking the black (end) plug and slave for the grey (middle) one, as per my understanding of how 80 strand cables work). I didn't mention this before, but I have already tried setting both to CS, unplugging the master and setting the old slave to master (thus without a slave), unplugging the slave and just leaving the master hooked up (also without a slave. None of these various tries produced a working result.

    3) My Bios sees the 2 CD drives.

    The main panel of the drive config page reads as follows:

    SATA port 0 - not detected
    SATA port 1 - not detected
    PATA primary master - (HD1 model #)
    PATA primary slave - (HD2)
    PATA secondary master (CD1 model #)
    PATA secondary slave (CD2)

    The rights side panel reads as follows:

    Disabled: All IDE resources disabled

    Legacy: Up to 2 IDE channels enabled for OS requiring legacy IDE operation

    Enhanced: All SATA and PATA resources enabled

    4) I checked the CD manual on my wife's comp and looked at the pages you suggested. Again, I may be missing something obvious, but i don't see a solution there.
  5. CCT

    CCT TS Evangelist Posts: 2,653   +6

    In a world where English seems to be a second language even for those raised speaking it - ah well:

    "You can no longer access the CD drive or the DVD drive, or "

    OR implies a choice, an alternative, either or, if not this then maybe that, etc.
  6. Matthew

    Matthew TechSpot Staff Posts: 5,332   +101

    Just a shot in the dark here but is the "ATA/IDE Configuration" option set to "Enhanced"?


    Guess I kind of left that open, but try setting it to "Enhanced" if it isn't and post back with your results.
  7. michaelr

    michaelr TS Rookie Topic Starter

    Thanks again CCT and Zenosincks for continuing to chew on the problem.

    CCT: Tried cleaning up the registry using method 1 (guided help) in the link. no luck.

    Zenosincks: It has always been set to enhanced and still is.
  8. Matthew

    Matthew TechSpot Staff Posts: 5,332   +101

    Try attaching your HDD's cable into the IDE interface spot on the motherboard that your optical drives are currently using and vice versa with your optical drives and see what kind of a response you get.

    Mind posting the model numbers of both of your optical drives?
  9. alphnumeric

    alphnumeric TS Rookie Posts: 173

    Can you try one or both of those optical drives in another PC to be sure they both work? It's already been mentioned but make sure you have the correct connectors in the correct order. If you get the cable back wards, master connector connected to the motherboard, it will mess up the master slave detection. Been there done that. ;)
  10. Ph30nIX

    Ph30nIX TS Rookie Posts: 243

    Set it to legacy mode. I.e Sata is turned off, maybe causing some type of conflict.

    As said before, check your ide cable. One end is designed to go into the m/b and ONLY the m/b, not a drive. Normally the drive connectors are closer together.

    Also, disconnect everything except your main hard disk. Boot from it and make sure it works. Next connect your cd drive to the SAME IDE channel and see what happens.

    If you can get it working, swap the cd to its own channel so its just one hdd and one cd drive. And go from there, trial and error as many combos as you can.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...