idechndr.sys problem

By Stunner_101 · 7 replies
Mar 31, 2007
  1. Hi all thanks for youre time,
    im having a reocurring problem with this PC thats here with me, have read a few threads but they seem to be of no help as i have tried to do as they say.

    Original error message:

    STOP 0X00000004

    idechndr.sys Address F947EB3B base at F9479000, DATESTAMP 3D99eac3

    This PC is a acer desktop, running XP Home 256MB ram, 40GB HDD with sp2 updates in place. The problem im having is that i cant get it to boot into safe mode? to either rollback the "idechndr.sys" driver or make any changes to the PC at all. Have tried booting to safe mode but it just hangs and does nothing over the time period of 2 hours(Lol!), have tried booting into other options "Safe Mode" with command prompt etc..with no luck there either.
    Tried a sys recovery that did not work as it did nothing after selecting the "1 c:\" option which then asks for a admin pass which is not needed.

    Can add more info if needed but i think you get the story

    If anyone has come across this particular problem, please holla back as i'd like to get this PC back to its master before i drop kick its 256MB running sorry _ss out the door. =). Thanks
  2. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Can you attach your Minidumps and post?
  3. Stunner_101

    Stunner_101 TS Rookie Topic Starter

    Hope this is what you need
  4. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    All three dumps point to the IdeChnDr.sys which is of the Intel Application Accelerator.

    This file is part of the Intel® Application Accelerator, which was a hard disk performance enhancing driver for certain Intel chipsets. The problems may also be related to bad sectiors on the disk, which could explain the specific location of your problem, though this is probably just another symptom of the problem with an out of date driver.

    1. Run a harddrive diagnostics tool.

    2. More impotantly see if Intel has an update for their application accelerator.
  5. Stunner_101

    Stunner_101 TS Rookie Topic Starter

    cool i better try that as im only new to the trouble shooting game, thanks again Route44
  6. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    You're welcome and I am certainly still new at trouble shooting, but researching is your friend. :) I kept coming across the Intel chipsets and the Intel Application Accelarator file. You may want to Google these terms yourself as well as IdeChnDr.sys

    Let us know how it works out.
  7. Stunner_101

    Stunner_101 TS Rookie Topic Starter

    Hi hows things, well i tried almost everything(everything that i know about PC's) to get this PC up and running without having to do a reload which was my main goal here. Apparently i had corrupt system files says a friend. With the reload of windows i've sorted it out, all i had to do from there was update all the drivers from the acer website. I dont understand why Acer would not give the buyer a recovery CD? even though they have a recovery partition which i now have deleted to gain some more HDD space. Would have been nice to know i could have fixed it without the reload but hey its fixed now thats all that matters i suppose. Once again thank you all heaps(Route44..), for the rapid response to my dilemma =). See y'all next error message.Taranaki Boy
  8. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Thanks for the updated response. I learned something from what you did. It was drivers after all. Glad it is fixed! Good stuff.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...