I'm lost all help appreciated

By ntco394
Mar 10, 2009
  1. About a week ago i was playing farcry II and my computer totally shut down on me.

    When i tried to re start the computer i got nothing at all almost like it was dead, so i tried replacing the PSU with a new 700w one now the fans and mobo starts up but wont go past that, all that comes on is a red light on the tower which stays on untill i turn it off again.....

    Has anyone got any idea's or suggestions to what it could be.

    My system spec is :

    Intel core 2duo 2.4ghz
    4 gb ram
    400 gb HD
    Nvidia geforce 8600 gt
    700w ezcool psu
    Thermalake sonictower cpu cooling.
  2. LinkedKube

    LinkedKube TechSpot Project Baby Posts: 3,485   +45

    Sounds like a motherboard issue to me. Do you have another pc to test hardware?
  3. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    When you start the system do you get any beeps at all? This is called the POST (Power On Self Test); 1 beep is good, no beeps is bad, some beeps shows hope but depending on how many.
  4. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    why replace stuff if you do not know its the problem? Did you test it with a PSU tool and multimeter?

    Have you tested the RAM?

    Did you check the cooling?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...