1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Installing/uninstalling access denied, possibly UAC related

By Modifyinc · 5 replies
Jan 17, 2012
Post New Reply
  1. I had Windows 7 installed and working great for months on this PC. I decided to try Windows Home Server 2011 and dual booted both. I have uninstalled and removed WHS2011 after the trial period expired and went back to my Windows 7.

    Everything seemed fine until I noticed I couldn't uninstall applications, and the ones that did seem to uninstall were actually still installed and working.

    This is the message: File "C:program Files (x86)\XXXXXX\unins000.dat" could not be opened. Cannot uninstall. Error code 5: Access Denied

    Any other uninstall seems to complete without error, but as mentioned earlier, the applications are still installed and working, nothing is actually uninstalled. It seems the unins000.dat is the only one thus far that gives the error code 5: Access Denied. Didn’t realize so many programs used the unins000.dat file for uninstalling.

    On a positive note, I was able to uninstall a program that used the MS Installer without issue, if that helps.

    I assume the WHS 2011 made some changes to my Windows 7 file system even though it was installed on a completely separate disk. I didn't share anything from this drive with WHS 2011.

    I have compared the security permissions to those on my other Windows 7, and I can't seem to find anything different.

    Anything I open from the quick launch bar pops up a security warning and asks if I want to open the file and reminds me that files from the internet are dangerous. Also if I right click, and select properties, I have an additional tab under Advanced, named Unblock that I can unblock the file. If I open Firefox from my Start Menu, it opens without a security warning, yet if I move Firefox to my quick launch bar, and try to open it, I still get that silly security warning pop up.

    When I downloaded MS Essentials and tried to install, I get this error:
    Unable to find a volume for file extraction, please verify you have proper permissions.

    Enabling UAC seems to fix these issues, (not the Security warning pop up though) but only for the time that UAC is enabled. If I turn it off, which I prefer, then same install/uninstall issues again.

    I have tried the sfc /scannow

    Also tried: secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

    Anyone have any suggestions on how to rectify this issue?

  2. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    Yes, these are symptoms of UAC from a limited user account.

    To uninstall properly,
    find the UNINSTALL program for your application, right-click->runas
    and enter the admin password

    To use the Add/Remove control panel,
    get a command prompt and enter RUNAS /USER:yourAdminLoginID CONTROL
    and run Add/Remove from there.
  3. Modifyinc

    Modifyinc TS Rookie Topic Starter

    Thanks, but I'm familiar with these options. I'm curious how I get all this back to normal without depending on UAC anymore. My account is a administrator account.
  4. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    Then all you need to do is change your login to an Admin Account - -
    and that will then expose you to allowing any webpage or email virus to infect your system.
    After all, the whole point of running UAC is to keep the user at the lowest permissions to avoid system infections.

    This change (UAC) and the much better firewall are the major reasons for using Win/7 imo.
  5. Modifyinc

    Modifyinc TS Rookie Topic Starter

    I am logged in using an account with administrator privileges as I previously mentioned.

    I'm aware of the reasons to have UAC enabled, but I'm more interested at the moment in figuring out why my system is not working properly with it turned off as it has always been. Installing WHS 2011 did something to all my connected media drives, changing permissions and such. I've got most of them squared away, and working properly, but this system drive seems to be a bit more stubborn. I'm just happy that I can still use it with UAC enabled, though I would still like the option to turn it off and my PC still perform normally.

  6. jmjsquared

    jmjsquared TS Booster Posts: 145

    Perhaps this Microsoft's FixIt (x64) will help: http://support.microsoft.com/mats/Program_Install_and_Uninstall

    •Removes bad registry key on 64 bit operating systems.
    •Windows registry keys that control the upgrade (patching) data that become corrupted.
    •Resolves problems that prevent new programs from being installed.
    •Resolves problems that prevent programs from being completely uninstalled and blocking new installations and updates.
    •Use this troubleshooter for an uninstall only if the program fails to uninstall using the windows add/remove programs feature.​

    And while I understand your choice re UAC, it really is not a case of "tomāto or tomǎto." IMO, there appears to be some obscure inter-relatedness between the design of Windows 7's new boot-process , UAC and your specific issue. Perhaps it is wisest to concede to the annoyances of UAC in its less aggressive setting and figure this out at your leisure.

    What specific steps did you take to remedy what specific issues?

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...