Internet connects but doesn't work on WiFi, ethernet works fine

My PC with windows 7 is the only computer with issues in the house. Ethernet works perfectly but wifi doesn't even when I don't have the ethernet hooked up. The wifi says it is connected but browsers, steam, and Itunes don't work. I have Bitdefender A/V and already tried uninstalling it, no change. I also uninstalled steam and Itunes with still no change. I even uninstalled and reinstalled the drivers for the wireless adapter. I tried looking and I don't recall downloading or installing anything around the time the problem started. Before I try replacing the adapter itself, I was hoping for help here since I saw a very similar problem in another thread.
  • Thread Starter Thread Starter
  • #2
If there is any more info I can give to help you help me, please let me know.


Posts: 42   +5
Ok are you vertain that your wifi adapter is compatible with your router? Such as and N router and a N wireless adapter? If you have ethernet connected it may override the wireless. Do you have a bios setting that you need to enable wireless networking for your motherboard. What kind of wireless adapter is it?


Posts: 32   +9
Hey JT. Is there another wireless pc or phone that you can use to check your network with, to see if it detects your network and allows you to get on the Net?. The router might be bad and just broadcasting your SSID signal but no internet signal allowing you to connect.
Has this pc ever connected to your current network wirelessly?
Is your connection to your wi-fi network saying local only when the cursor is over your wireless connection icon?
  • Thread Starter Thread Starter
  • #5
This computer was connecting wirelessly to the same router I am using now, so the router and adapter are compatible. Other computers can still connect without issue, only this one is having the problem. I didn't change any BIOS settings so I also don't think that would be the issue. When I try to connect to the network, it says "connected" with a strong signal strength and under network and sharing says it is connected to internet, it just wont let me actually use the internet for anything... :/ Thanks for the replies guys, I appreciate the help!


Posts: 6,430   +186
I'd double check the network password is correct.

If still seems a problem, temporarily turn off password on wifi to see if it the adapter can connect when no password required


Posts: 32   +9
When you state that the other machines connect without issue, I assume you mean other wireless pc's and not just those on Ethernet,correct?
Which browser are you using and what message do you get?
Have you tried using a second browser if you have one installed?
Have you scanned for a possible virus/malware/rootkit infection?
What about a System Restore to a point before you noticed this problem?
I didn't see it mentioned, but like LookinAround alluded to,is your router secured?

Assuming your other devices are connecting wirelessly,you can try what I did with this issue some years back when I couldn't connect wirelessly:
I uninstalled the wireless adapter in Device Manager, powered down, unplugged the power, and removed the battery and just left if for a few hours.On power up,Windows detected my wireless adapter and installed the drivers. It saw my network,connected,and I never looked back and it never happed again.
  • Thread Starter Thread Starter
  • #8
- My router is secured and my network password is definitely correct.
- And yes, I meant other wireless devices can connect wirelessly.
- I have tried Mozilla, Chrome, and IE, I don't get any messages, instead it just doesn't load the page. It doesn't even say it cannot connect, its just a white page.
- I used Bitdefender a/v to scan for anything and nothing was found. My computer will not allow me to do a system restore that far back. I'm not sure why but there are only 3 dates and all of them are after the problem arose.
- I am not sure how it works but I don't think my computer automatically detects my wireless adapter. I have the driver disk that came with the adapter though and have been using that.


Posts: 32   +9
Ok, so your router is ok,and nd you get a "connected" notification, but just a white screen wih all 3 browsers. I would say,try what I described earlier:

Uninstall the wireless adapter in Device Manager, power down, unplug the power, and remove the battery, and just leave the pc for a few hours.Power up, allow it to detect your adapter and network, then try to connect to your network .If no progress and the settings mentioned by the other responders are set, I would say the wireless adapter has gone bad. You could also try using one of those wireless USB adapters as a test.
  • Thread Starter Thread Starter
  • #11
Hey, thanks for all the replies guys. I fixed the problem. I put in the command "ipconfig" and saw "media disconnected" all over the place, so I searched for that. I found an article that had me put in some commands and the problem was solved. I still don't know what the problem was exactly but its gone lol


Posts: 32   +9
Good that it's working, could you provide a link to what you found that resolved the issue for you?
I have a similar problem to J Theros in that I have previously maintained a wireless connection and can now only surf using a wired ethernet connection, however my problem remains unsolved by his solution and is dissimilar in that when there is no ethernet there is no internet.

This all started in October(?) when the cmos battery for the bios settings quit, after I replaced that all of the wondrous wireless internet ceased to be.

I have since uninstalled/reinstalled drivers been through the bios and just recently tried the command prompts I have also searched media disconnected and found that some people are posting elsewhere a description that looks like this:

Ethernet adapter Local Area Connection:

Media state ................................: Media disconnected

Wireless LAN adapter Wireless Network Connection:

Media state ................................: Media disconnected

Tunnel adapter
Media state ................................: Media disconnected

Tunnel adapter Local Area Connection* 12:
Media State................................:Media disconnected

I cut out alot of "unnecessary" bits as my main point is that when I "ipconfig" on my PC I do not have a heading for wireless LAN adapter wireless connection but the laptop, which is connected wirelessly to the internet, has that heading and is connected to our ISP that way ( I should probably mention that the lap top runs windows 7 and the PC is running windows vista)

I am at a loss. please let me know what other information you may need.
Hi there,

I have a problem similar to the one at the bottom of page. Our wifi internet was working fine for everyones laptops in our house up until recently, but now wifi is not working, the network shows up but wont let us put in a password and says 'connection timeout occured' when we try.
However, when ethernet cable is directly plugged in it works fine.
Also, our phone has stopped working (probably at the same time, we hardly use landline), it is plugged in but has no dial tone. This leads me to believe its the actual phone line, but if that was true then why does the ethernet still work? Strange...
I've already called up for assistance but they want to make sure its not faulty hardware before they send someone out. Any ideas whats the problem?

Possibly the ADSL connector?


Posts: 32   +9
I was trying to think when I replied to this post, then noticed it is from a year ago. Melly, since you have DSL and have Internet but no phone, I would check the connection where it enters the house and at any connection points. Does the line going to the phone have a DSL filter on the line?. If it does and the connections seem to be tight, try another filter if you have one. The filter only goes on the line that connects to a phone and/or fax. How is your wired connection connected, from a combo modem/wireless router supplied by the company or do you have your own separate modem and wireless router?. If you have a combo unit and a "wired" connection to a pc works, then I would say that the combo unit has a problem with it's wireless section. I'm not sure if a combo unit will have a recessed reset button like a traditional separate router that you could try.


Posts: 8   +0
Hey, thanks for all the replies guys. I fixed the problem. I put in the command "ipconfig" and saw "media disconnected" all over the place, so I searched for that. I found an article that had me put in some commands and the problem was solved. I still don't know what the problem was exactly but its gone lol
Might be helpful to at least include the link that solved your issue, as this might be of help to others who encounter the same or similar problem and find this thread.
It may be your WPS, on alot of routers there is a WPS button if you go into your devises wifi settings you (depending on the device) there will be a WPS scan button click it then click the button on router.