1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Ion LP2 flash record player - no sound

By NCISabbyfan · 37 replies
Feb 5, 2011
Post New Reply
  1. I have an ION IO2 LP2 Flash Record Player, which enables customers to play records at 33 and 45 rpm via a hi-fi or a computer and transfer the records to a USB stick among other options.

    I wish to play records via my computer, but I have a dilemma:

    Although my records spin fine on the turntable, when I connect the USB lead to the back of my computer (I currently have Windows Vista if relevant), there is no sound.

    What is preventing the sound?, and how do I achieve sound?

    I'd thought that sound would be instant, once the lead was connected, but I am very keen to find a solution so I can make the most of my record deck and recording options.

    Also, is Audacity easy to set up?
    (there are 2 options - the eZ Player, which is good but has least Scratch Filter options, and Audacity)

    I look forward to your feedback.
  2. NCISabbyfan

    NCISabbyfan TS Rookie Topic Starter Posts: 95

    Seeking help

    Can anyone assist me?

    Thinking further, as I'm not a technical expert, is the cause of No Sound due to a setting in my Computer?

    I imagine it's not a fault in the record player, but either way, I can't get any sound out of the record player.

    If whatever's blocking the sound is in the computer, which settings do I need to look for to achieve sound?, and/or

    Is it because I don't yet have Audacity set up that I'm getting no sound?

    I'm very keen to use my record player. :)

    Although record players will vary and I'm not sure if any of you have an ION record player, perhaps there are other record players where Sound has to be activated a specific way where some of you have had the same muted sound on your record players of a different brand or different model or ION.

    Please help asap.
  3. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    When you plug in / unplug the USB cable are you hearing the Windows device connect/disconnect ding dong each time?

    I assume your player has its own AC adapter? It's plugged in and turned on?

    Open device manager and look (in general but especially under the USB category) as you plug/unplug the cable. Does a device appear/disappear?
  4. NCISabbyfan

    NCISabbyfan TS Rookie Topic Starter Posts: 95

    Record Player - Update on results of checks


    I'm not sure. How do I find this out?

    The record player has two sets of leads, one for use plugging into a hi-fi, and the other, a USB lead (the one I've been using to try to achieve sound).

    The player itself is working, as I've tested a record on the turntable, which spins and I can hear the sound of the record playing from the record deck surface, but sadly not through my computer loudspeakers.

    I've visited Youtube and other web sites which have sound, which have played fine through my speakers, which rules out the speakers being faulty, but it's a complete mystery as to why I can't get any sound from my player, unless I need to set up Audacity first, which I'll look into shortly.

    I don't know if it's relevant that I have Windows Vista, or if there are any other technical details I need to quote or look for on my computer to try to trace the source of the lack of sound, but I checked the Device Manager and noticed the following differences between plugging and unplugging the cable.

    Still no sound, but this is what I found:

    "Human Interface Devices" -
    (Unplugged): 1 HID-compliant consumer control device
    (Plugged): 2 HID-compliant consumer control devices

    "Human Interface Devices" -
    (Unplugged): 2 USB Human Interface Devices
    (Plugged): 3 USB Human Interface Devices

    "Sound, Video and Game Controllers" -
    (Unplugged): 1 High Definition Audio Device
    (Plugged): 1 High Definition Audio Device and 1 USB Audio CODEC

    "Universal Serial Bus controllers" -
    (Unplugged): 1 USB Composite Device
    (Plugged): 2 USB Composite Devices
  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    just based on quick skim, your info above appears OK. One quick thought:

    Open Ctl Pnl->Sound->Audio tab. Click the pull down menu for the default recording device. Do you have more then one choice?? You may just need to change the default input/recording device

    /* edit */
    yea, i think your default device selections may well be your problem <fingers crossed> as i also just googled ion usb player default device and found THIS. So make sure BOTH the default Playback and Recording devices are set correctly
  6. NCISabbyfan

    NCISabbyfan TS Rookie Topic Starter Posts: 95

    Update - Still no sound

    Many thanks for your help, but unfortunately, as the ION link doesn't give details for Windows Vista, I sadly can't find the options you've quoted, unless it's these, listed differently, as there's no Audio tab in the options, which are also found via the Volume Mixer:

    "Volume Mixer" -
    Device - Speakers - In optimum volume level position
    Applications - Windows Sounds - Also in optimum volume level position
    "Name not available" - This one's intriguing me. It was on "Mute", which I've unmuted and the bar was in Middle position, then upon checking today, no sign of the “Name not available” program in the Mixer and still no sound

    "Playback" -
    Speakers - High Definition Audio Device - Working (this is ticked)
    Headphones - High Definition Audio Device - Not plugged in
    Digital Output Device (SPDIF) - High Definition Audio Device - Working

    "Recording" -
    Microphone - High Definition Audio Device - Not plugged in
    Microphone - High Definition Audio Device - Not plugged in (there must be 2 Microphone jacks, as this is listed twice)
    LIne In - High Definition Audio Advice - Not plugged in

    "Sounds" -
    No Sounds
    Windows Default
    Windows Default (modified) (modified) - This option is activated
    Windows Default (modified)

    Is there a fault with my record player or my computer?
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    Thanks for taking the time to post all the info in your last post.. I think you're running with the Windows generic audio driver. You need to install the hardware specific driver first. And then go check your default devices.

    Go to the vendor site for computer. Look for their Support or Download link. They'll tell you the audio driver for your specific model. Download and install.

    if you need help finding it you'll need to indicate your computer vendor make/model
  8. NCISabbyfan

    NCISabbyfan TS Rookie Topic Starter Posts: 95

    Latest Update - Still no sound; No drivers on ION site

    Thanks again for your efforts. :)

    Unfortunately, once again, I'm getting nowhere, as there are yet more obstacles beyond your control and mine. :(

    I've gone to the ION web site, which lists a section "Documents and Downloads", but there are no Downloads or details of the audio driver I'll need for the ION "LP2 Flash" model, so it doesn't look very promising that I'm ever going to get any sound from this machine. I'd assumed ION had made a machine that is plug and play, which would have enabled instant sound. I imagine I'm not the only owner of this record player to have experienced this dilemma, but it's a shame, as I would looking forward to transferring my records.


    In one part of the instructions it says "WARNING: Do not attempt to connect the LP2FLASH to a phonolevel input.".

    As far as I know, I've not done this, as I have only connected the record player to my computer, but am unsure if the "phonolevel" jack is in a computer or a hi-fi.

    Also, in another part of the document it states "Note: The LP2FLASH does not support USB hubs.".

    This confuses me. The record player has a USB lead to connect to computers, yet the Flash doesn't support USB hubs.

    What does this mean?, and is this the reason why I'm getting no sound?

    Sorry if I sound grumpy, but I'm just frustrated that I still can't get any sound out of my machine. I'm almost sure it's not faulty, as the turntable spins, I can hear sound from the surface of the deck and all the lights are lit up on the front of it, but for some reason, ION have no drivers for this. I have found two other companies which list drivers, but they are also malware. It seems peculiar that ION don't have drivers on their own site, but sadly they don't. :(
  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    Sorry for misunderstanding. I meant you get the audio driver download from your computer vendor (not ION). What is the make (who's the vendor?) and model number of your computer?

    /* EDIT */
    btw... if you aren't certain of the model number, there's usually a tag on the computer with the information (like model number, serial number, etc.). I only need the Model #. If you can't find it, other ways still to figure it out. just let me know :)
  10. NCISabbyfan

    NCISabbyfan TS Rookie Topic Starter Posts: 95

    No worries. I initially misunderstood what you meant, thinking you were referring to drivers from ION, the manufacturer of the record player.

    Looking at my computer, there are different details on the front, top and back. I'm not sure which you mean, but they include details that I have a Windows Vista Home Premium OEM computer, which lists a Product Key.

    On the back of my computer it states "CE", which I presume means certified;

    The computer itself is an Intel Pentium 4 with a Dual Core processor.

    As far as I know, this record player will still be compatible with Windows 7, which I plan to upgrade to at some later date, as Vista is now being gradually phased out.

    Please advise me if one of the above details covers the Model number.

    If not, please bear with me, and I'll check further upon your advice.

    Many thanks for your patience. Hopefully it's just a matter of time before I can hear my record player through my computer's loudspeakers, but I shall persevere and am very grateful to you for your assistance.
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    No worries. I'm sure we'll find the info we need :)

    Do you know who made your computer (e.g. Dell, Sony, Toshiba, HP, etc)

    In any case, try this
    > Click Start (in lower left corner) to open the menu. Type msinfo32 in the search box along the bottom of menu
    > You should see msinfo32.exe appear in Program List towards top of menu
    > Rt click msinfo32.exe, select Run as Admin

    On the System Summary page, it should include System Manufacturer and System Model. What do they say?
  12. NCISabbyfan

    NCISabbyfan TS Rookie Topic Starter Posts: 95

    I'm afraid I'm not that technically minded, so please bear with me.

    I'm not sure who made my computer, unless it's Intel Pentium.

    However, I've found the System Summary information you requested -

    The System Manufacturer is: Foxconn

    The System Model is: G33M03
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    No worries. Take your time. We'll try to work through this together and take it step-by-step. Everyone here is glad to try and help :)

    just fyi.... Vista (and Windows 7) both include "generic" audio drivers. I think your first issue is that you're still running with the generic drivers and need the hardware specific drivers installed on your machine
    > The device names "High Definition Audio Device" I saw in your earlier post HERE make me think you're still using the generic drivers
    > I want you to download and install the Realtek audio drivers for your machine

    1. Download the zip file HERE
    2. Unzip the file and save the contents on your disk (instructions HERE)
    3. Now look for the Setup.exe file, rt click it select Run as Admin
    4. Once the installation completes, you can look at your devices again and now i believe your devices will now be named "Realtek High Definition Audio" (or something similar but with the name Realtek in it)

    Now you can check again the Default Playback and Recording devices are set correctly

    If you still have a problem or you have any question, also generate and attach a DirectX report as well to your next post
    • Click Start->Run, enter dxdiag
    • Notice progress in lower left window corner
    • When done, click Save Information button and save to your Desktop
    • In TechSpot, use the paper clip icon to attach the report. (If you don't see icon you may need to first click Go Advanced)
  14. NCISabbyfan

    NCISabbyfan TS Rookie Topic Starter Posts: 95

    Before I do this, can I check something with you?

    Last night I downloaded, but didn't run, the EXE file, as I was about to finish for the night.

    However, upon checking "Downloads" this morning, where I'm struggling to trace the file, which I could re-download and overwrite "(2)" over the original, I found a folder that I didn't create called "Realtek Audio Drivers". Difficult to tell if it was already there or whether it's appeared since I downloaded the "dl.dropbox.com" file, but when I clicked on this folder I then came across another folder called "HDA".

    What's puzzling is that the only file for 17/02/11 is "Config" but timed at 2.34pm, even though I didn't download this file and I only downloaded the file you recommended late yesterday evening and in the listings there are four other folders:


    Then, following these, there are 16 very technical system files (installed between 2001 and 2008), which I'd prefer not to open, to avoid risking damaging my computer.

    Whatever these various folder and stand alone files are, they must be missing an additional Realtek file, due to there being no sound, despite all the files.

    While looking up further information on Realtek, I found that they have their own web site, which I'd never visited before including these links.


    http://www.realtek.com/downloads/do...=3&GetDown=false#High Definition Audio Codecs

    Before I proceed, are there differences between the dl.dropbox.com EXE file and the Realtek EXE files, directly from the Realtek site?

    Also, how safe are the Dropbox files compared with the ones from Realtek's own site?

    I'm not doubting you in the least, you've been very helpful from the start :), but I'm asking this, as I've read on occasions some horror stories about downloading EXE files from Third Party sites. Not all are unsafe by any means, but I've read some are full of malware, which is why I'm being extra cautious, but this is no reflection on you or anyone else who recommends specific EXE files.

    As both Vista and Windows 7 include generic audio drivers, it looks like, once the sound is made available while I use Vista, I should have no difficulty in re-installing files and hearing sound whenever I switch to Windows 7.
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    Of course, In fact, you are being a wise "cyber" consumer to carefully consider just what it is you are downloading :approve:

    First, some background info. And, btw, you may want to keep this link if you need this info again in the future) for the info about your computer motherboard https://www.techspot.com/vb/post1006819-15.html

    Your computer
    Best I could tell, based on the System info you reported, your system has a Foxconn G33M motherboard
    > Foxconn's link to its G33M product info HERE and Foxconn's link to the G33M drivers drivers HERE
    > If you look at list of drivers, you'll see a selection for "Onboard Audio Drivers". If you click View Detail these are the Realtek drivers

    I would have preferred giving you the direct link to Foxconn's download file but for 2 problems
    Their link was displayed "using Java" - which basically means you can't simply copy it and give to someone else to use. Instead i would have given you the link to the Foxconn G33M product page plus instruction on how to navigate through the product page to find the audio drivers needed. This, in and of itself, wouldn't have been tooo bad except one more thing

    I found the Foxconn servers yesterday were very slowwww and unreliable
    I tried downloading first tried downloading the audio drivers myself yesterday from the foxconn server - and it wasn't a simple task. Their server was having problems making the download very slow, not-dependable, and all-in-all became annoying download process. A process I had to repeat (3 times in my case) before i received a good (i.e. "not corrupt") download file that could be used for an install

    Once i finally downloaded the file successfully, I unzipped it to verify the files within looked correct, then zipped it back up and moved it to my own personal DropBox Account. Then gave you a link to the file in my Dropbox account because I know that downloads from DropBox are always fast and reliable​

    Now that you know the full story, you can can choose to try downloading the file directly from Foxconn (maybe their server issues are fixed today.) Once downloaded, everything else is the same (including the HDA folder and my installation instructions)

    btw... Also feel free to tell your anti-virus software to scan the download as well...

    As to Vista vs Windows 7, if you look at the Foxconn list of driver for your motherboard, look at the Details the provide about the driver. For O/S Support: they don't include Windows 7 in that list! That doesn't mean its not possible to upgrade to Win 7 but it does mean alot of homework needed to determine if the drivers you have (or will have to go looking for) will work on Windows 7. Also would STRONGLY recommend you create a full disk image "backup" of your current system before attempting a Win7 upgrade. Thus, if during the process you find Windows 7 won't work on your machine, you can easily restore the backup image to at least get back to the Vista system you had working in the first place

    /* EDIT */
    Oh. And to clarify the "Realtek Audio Drivers" folder was created when you unzipped the "Realtek Audio Drivers.zip" zip file (it was created using the same file base name). The HDA folder was already in the zip file. As to dates on files/folders extracted from the zip file, they typically reflect the same dates AFTER extraction as the date/times they had when they were zipped.
  16. NCISabbyfan

    NCISabbyfan TS Rookie Topic Starter Posts: 95

    Thanks again for your efforts with links, instructions and advice, which I shall keep a note of. :)

    I've managed to download the Realtek file from Dropbox.com, but I've encountered yet more obstacles while following the How to Unzip a File in Vista.

    I've double-clicked the zipped file "Realtek Audio Drivers", where there is the option to "Extract All", but a window does not open and display all of the files that are stored in the zipped file. Instead, I first see an uncompressed Folder "HDA".

    As HDA is not a zipped folder, when I click on it, while there is a display of all the files stored in it, they are all uncompressed, and there is no setup.EXE file, only other Setup files.

    Due to the above, I frustratingly can't presently proceed with the instructions. :(

    Although I can't see any listing of a Setup.EXE file in the HDA folder of files, is it disguised under one of the following "Setup" files?:

    Name - Type columns

    Setup - Application
    setup - Configuration Settings
    setup.ibt - IBT file
    setup.inx - INX file
    setup.isn - ISN file
    setup.iss - ISS file
    USetup.iss - ISS file
  17. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    Yes! It is disguised!

    I forgot. I'm sure you're running with the Vista default where Vista hides file extensions. I suggest you change the option. I think seeing filenames including their extension make it much more clear to distinguish between files by seeing the name. extension. It also makes it harder for some types of malware to hide when you can see the filename+extension)

    1. fyi. This is setup.exe disguised! when the extension isn't show
    Setup - Application

    2. To change the Vista default to show file extensions see HERE

    /* EDIT */
    Also, you'll find if you ever need help from forums again, people will give you instruction referring to filename+extension.. so you want to be able to see both
  18. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    By the way, as another fyi...

    As to the question of "where should i download my driver from" as in this case there are both Realtek drivers from Foxconn for the G33M as well as Realtek drivers available from the Realtek site itself

    The rule is: You always want to start with the drivers from your system or motherboard supplier first.

    Reason: The driver from the system/motherboard supplier is tested by them and should be the one they say will work. This driver may or may not be identical to what's supplied by the product vendor (e.g. Realtek, in this case) but, in any case, you know is the one that they offer with their hardware so should be working with the system / motherboard you have.
  19. NCISabbyfan

    NCISabbyfan TS Rookie Topic Starter Posts: 95

    New Update

    Thanks for your two replies. :)

    It looks like the instructions relate to the standard view, as there were some differences, but this is immaterial, as I successfully completed each step and have now enabled the file extensions to be displayed.

    Upon your instructions and advice, I've visited

    There are three options listed, but I'm unsure which of the latter two would be what I need:

    ALC5621 (Datasheets)
    High Definition Audio Codecs (Software)
    AC'97 Audio Codecs (Software)

    I've also gone back to the Foxconn links you gave me in an earlier reply. There are drop down menus for Categories, Series and Models. Would these all be the correct ones?: Motherboards, Socket 775 and G33M?

    http://www.foxconnchannel.com/product/motherboards/detail_spec.aspx?ID=en-us0000319 and


    If I've read correctly, even if they're not the exact drivers, they'll still be suitable to enable Sound from my record player?

    You've referred to "G33M", which must be suitable for my record player. It sounds very promising from your description. Although there was already a Realtek folder on my computer, which lists files as far back as 2001, when I had Windows 98 Second Edition, prior to switching to XP around 2003, there was clearly a missing Sound file. It's a pity Windows Vista and 7 don't automatically include it with the Generic sound file, as I imagine I won't be the only person who's had no sound from a presumably working record player. The lights and turntable movement give me the strong impression the machine itself is not faulty.

    When the time comes that I upgrade to Windows 7, fingers crossed that it will be a simple process to resume restoring the sound, but I'll probably stick with Vista until the end of the year or beginning of next year. By those times, hopefully all drivers will have probably been implemented for that operating system.

    Meanwhile, as you've described one of the Setup files ("Application") as being the one that's the EXE file, and I've downloaded it from Dropbox.com, should I now delete it and start from scratch with the Download process? or should I re-download it from Foxconn or Realtek, which I presume would overwrite the Dropbox download?

    You probably don't get many forum members requiring assistance beyond one or two messages, but thanks for persevering with me. :)

    Along the way, not only is your advice invaluable but I'm getting to learn more about the technical side of computing, which I'm not that well up on generally, which will come in very handy for the future. :)
  20. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    Yes. From the info you provided earlier, I believe the Foxconn G33M is the "motherboard" in your computer (see HERE). The audio chips for your sound is on that motherboard so we want to try installing the audio driver that Foxconn provides for their G33M product.

    We're going to first work on installing the motherboard driver from Foxconn. But if it came to it, we'd next try the High Definition Audio from Realtek. (you may also find some of the info provided HERE helpful for future reference)
    If we couldn't find drivers for the motherboard that worked, the drives on the Realtek site would be the next thing to try.
    Having generic drivers in Vista and Win 7 is a "mixed blessing". On the one hand, it allows a user to get "basic" functionality working quickly on their computer but many don't realize when they have generic vs. specific installed until something doesn't work! If only Windows provided a pop-up message to notify/remind users they were still using generic
    The audio driver you downloaded from Dropbox is what i put there myself (its what ii downloaded myself from Foxconn and checked it). So you can run the Setup.exe from the Dropbox download or if you want try downloading direct from Foxconn. In either case, rt click the Setup.exe file, select Run as admin. (sometime after we're done i'll be deleting the download on Dropbox. But you can always get it again from Foxconn if needed now that you know where to find it again

    At least from everything to date, there's nothing to indicate your ION problem isn't anything more then driver and Default Playback installation/config issues. So here's hoping <fingers crossed we'll have good news when we;re all done!> :)
    No problem. We all have to start from the beginning at some time :)
  21. NCISabbyfan

    NCISabbyfan TS Rookie Topic Starter Posts: 95

    I've checked the links and installed the downloaded EXE file, which has added the Realtek HD Audio Manager onto my system with an Orange icon on the bottom right of my computer screen. :)

    However, for some reason, I am still not getting any sound (other than the Surface sound from the turntable itself).

    I am beginning to think there must be something wrong with my record player, or if not, what do I now need to do in order for the sound from my records to play through my computer's loudspeakers?

    I have a pair of Logitech speakers, which work fine with Youtube files, Windows Media Player, Real Player, etc, so the source of the Sound problem can't lie with the Speakers, but I am just totally intrigued as to why I can't get any sound from my record player through these speakers.

    In the Realtek menu, I have 5 sub-menus:

    Sound Manager
    Audio Devices
    System Sound Events
    Windows Media Player
    Volume Control
    Sound Recorder

    I shall eventually get Audacity up and running (the program I've chosen to filter scratches, if or hopefully when I can get sound from my machine), which is hopefully easy to set up, but as far as I know, this is not needed in order to just Play records.

    In "Audio Devices", I have:

    Speakers - Realtek High Definition Audio Working (ticked);
    Realtek Digital Output - Realtek High Definition Audio Working

    Microphone - Realtek High Definition Audio Not plugged in
    Line In - - Realtek High Definition Audio Not plugged in
    CD Audio - Realtek High Definition Audio Disabled
    Stereo Mix - Realtek High Definition Audio Disabled

    No Sounds
    Windows Default
    Windows Default (modified) (modified) (this option is activated)

    Same as "SOUNDS"


    Speakers, Windows Sounds and Plugin Container for Firefox - All working on full level

    Strangely though, a fourth option has appeared then disappeared again "Name not available". I clicked off the Volume Control then back on it, and it's vanished. When it was there, it was muted.

    When playing files on Youtube, only the Speakers menu (first column) is activated.

    When not playing files on Youtube, the Firefox Plug in is not listed in the Volume Mixer menu. Not sure why this disappears when Youtube is not running or especially why the "Name not available" Volume control option has remained vanished.

    If I've understood you correctly, you said I could install the Realtek EXE file from Dropbox.com or Foxconn, but upon checking Foxconn, there are several "G33" drivers and I'm unsure which one I'd need to install.

    For some reason, even the Realtek driver hasn't enabled any sound. Very puzzling.

    Shall I start from scratch by deleting the Realtek program then install the Foxconn driver you think is best?
  22. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    From the data you posted, it would seem you have the Realtek drivers installed now. Let's move to the next step: seeing if the turntable's USB connection is detected.

    (not sure if the turntable as a USB device might be related to "Name not available" or not)

    1. Since you say the turntable spins
    > I assume you have the turntable plugged in with its own AC cord?
    > I assume the turntable is turned on?

    2. Is the turntable's USB cable plugged directly into a USB port on the computer? (or are you also using any external USB hubs?)

    3. Open Device Manager. (Rt click Computer->Manage->Device Manager). With AC connected and turntable powered on, plug into the USB port and unplug it
    > Do you hear the Windows device connect/disconnect sounds as plug/unplug the USB cable?
    > In Device Manager, do you see any new device appear or disappear under either the Sound or Universal Serial Bus Controller categories?

    Click on the thumbnail to see the full view of example of Device Manager and the 2 categories
  23. NCISabbyfan

    NCISabbyfan TS Rookie Topic Starter Posts: 95

    Still persevering, but still no sound

    The Realtek HD Audio Manager is now installed which comprises:

    Sound Manager
    Audio Devices
    System Sound Events
    Windows Media Player
    Volume Control
    Sound Recorder


    I've compared the contents from the above link with the contents in my own Device Manager directory which are virtually identical with a small number of contents not on yours that are on mine and vice versa.

    In the ION "LP2 Flash" record player manual it states "The LP2FLASH does not support USB hubs".

    Is this why I'm getting no sound?

    However, it's very strange it says the LP2Flash does Not support USB hubs, given that it's a USB lead that connects the record player to my computer.

    I've not seen "Name not available" show up since, so I don't know what that is or why it appears then disappears.

    1. Since you say the turntable spins

    > I assume you have the turntable plugged in with its own AC cord? -
    I think so

    > I assume the turntable is turned on? -

    What does the AC cord look like?

    2. Is the turntable's USB cable plugged directly into a USB port on the computer? (or are you also using any external USB hubs?) -
    The USB cable is plugged directly into a USB port at the back of my computer tower with other USB and jack sockets

    When you say “are you also using any external USB hubs”, what are these?

    3. Open Device Manager. (Rt click Computer->Manage->Device Manager). With AC connected and turntable powered on, plug into the USB port and unplug it

    > Do you hear the Windows device connect/disconnect sounds as plug/unplug the USB cable? -
    Yes. It sounded 4 times when plugging the cable in then twice when unplugging the cable (both times with the record player switched on)

    > In Device Manager, do you see any new device appear or disappear under either the Sound or Universal Serial Bus Controller categories? –

    The extra devices are identical in name and number to before I installed the Realtek HD Audio Manager, as follows:

    “Human Interface Devices” - 1 HID-compliant consumer control device; 1 USB Human Interface Device
    “Sound, Video and Game Controllers” - 1 High Definition Audio Device; 1 USB Audio CODEC
    “Universal Serial Bus Controllers” - 1 USB Compositive Device
    NB: Unplugged – 8th USB Root Hub is highlighted blue; Plugged – 1st USB Composite Device is highlighted blue

    Two new sections have appeared since installing the Realtek HD Audio Manager:

    IEEE 1284.4 Compatible Printer
    Imaging Devices


    USB Lead is connected between the record player and the computer, and the record player lead is plugged into a plug socket, but still no sound

    Volume Mixer
    Windows Sounds

    Speakers - Realtek High Definition Audio - Working (ticked)
    Realtek Digital Output - Realtek High Definiition Audio - Working

    Microphone - Working
    Microphone - Realtek High Definition Audio - Not plugged in
    Line In - Realtek High Definition Audio - Not plugged in
    CD Audio- Realtek High Definition Audio - Disabled
    Stereo Mix - Realtek High Definition Audio - Disabled

    Windows Default (modified) (modified) – Selected

    Should I change the setting from the above to “Windows Default (modified)”?
  24. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    General Info
    ION wants you to connect the turntable directly to a USB port on the computer (and not through an external USB hub - if you had bought one). Hubs allow you to expand the number of USB ports on the computer
    The AC cord is the power cord that plugs into your wall outlet

    Next Steps
    As you saw, several USB devices appear when the turntable is connected (which is good)

    Here's some Control Panel->Sound snapshots on a Windows 7 machine with a USB headset (you should be seeing something similar i think).
    => Note the "green tick marks" indicates the default device
    => You can change it by selecting a device then clicking the Set Default button

    Playback Tab
    ==> You want the Realtek speakers to be your Default Device
    /* Start new edit */ From your last post, sounds as tho this is how your Playback device is currently set */ End of edit */

    Recording Tab
    ==> You want the USB Microphone to be your Default Recording Device (it might be listed as your USB Audio Codec Recording device, or similar)

    If still problematic, on Recording tab, select the USB Microphone, then click the Properties button, then the Advanced tab, uncheck "Allow applications to take exclusive control", click OK

    Dxdiag Report
    => Finally, if still a problem, please generate and attach a dxdiag report. Click the Windows Start button on lower screen left corner
    => Type dxdiag into the search box
    => Click on dxdiag that appears at top to run the program (it may ask, we don't care, if it checks digital signatures)
    => Notice the progress bar in lower left of dxdiag window. When done, click Save Information.

    Save it to a text file on your Desktop. Use the TechSpot paperclip icon to attach the file to your next post
  25. NCISabbyfan

    NCISabbyfan TS Rookie Topic Starter Posts: 95

    Update - Still no sound :(

    Thanks again for your efforts.

    I've connected the turntable directly to a USB port on my computer (from your description, I have no hubs) and the AC cord is connected to the socket.

    Observing your Sound snapshots, mine are almost identical on Windows Vista.

    Playback Tab
    There are two options on my computer - "Speakers" and "Realtek Digital Output". I have mine on "Speakers", as in your diagram.

    Recording Tab
    I was unable to change Any setting to Default, so had to right click on USB Microphone, "Properties" and "Advanced" where I unticked "Allow applications to take exclusive control".

    Dxdiag Report
    I wasn't sure whether to tick "No" or "Yes" to the question. I clicked on "Yes", then exited the option, then returned to it, when it prevented me from ticking "No", but either way, I typed in "dxdiag", saved the information to my Desktop and attach the paperclip as requested.

    It's very puzzling how I still can't get any sound beyond the turntable's resonance sound. My loudspeakers will play Youtube, Windows Media Player and anything else fine, but not my records.

    Attached Files:

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...