Jittery Logitech MX700 Mouse

By RealBlackStuff ยท 21 replies
Aug 18, 2003
  1. Regardless of which program I am in, all of a sudden the cursor of my Logitech MX700 wireless mouse starts going all jittery.
    It will move very slowly, almost like trying to pull some squirming jelly-fish across the screen. It is very difficult to control and all
    I can do is reboot the PC, after which it is back to normal.
    The problem comes up anywhere from 5 minutes to 4-5 hours after booting.

    Hardware Environment:
    Home-built, MoBo Asus A7V333, AMD Athlon XP-1900 with Zalman flower, 2x256MB Corsair memory, 2x80GB Seagate Barracuda IV, Matrox G550 32MB AGP-card, Belkin F5D5000 network card, MoBo-integrated sound, Logitech Internet keyboard (without any drivers loaded) and the problem-giving Logitech MX700 wireless mouse, it's base attached to a USB 2.0 port.
    My problem occurs on USB 1.1 and PS/2 ports as well.
    According to Asus-Probe, my MoBo temperature = 30C and the CPU = 27C.

    Software Environment:
    Windows 2000 Pro with SP4, Norton AV 2002, Agnitum Outpost Pro 2.0 Firewall, Diskeeper 7 Workstation (set to "Set it and forget it"). MS Office 2000. CPU-Idle 6. VIA Hyperion 4in1 V4.48 drivers. Opera 7.11 and Avant 8.02 Browsers.
    IE6 is installed, but I never use it, nor do I use Outlook (Pegasus instead).
    Currently using the standard Logitech mouse-driver 9.70 (as built-in from Win2000).
    I have tried all sorts of mouse-drivers from both Logitech and Micro$oft.
    All give me the same grief.

    Before, I had the corded MS Intellimouse Explorer 3, and that one completely froze both my keyboard and the mouse, only a hard reset could remedy it.
    Again, regardless of being connected to USB 1.1 or 2, or PS/2.

    Any help would be greatly appreciated.
  2. young&wild

    young&wild TechSpot Chancellor Posts: 993

    Have you tried using a similar but workable mouse? It could be something wrong with your mouse it self. Before confirming anything make sure you have the latest USB and mouse driver.
  3. RealBlackStuff

    RealBlackStuff TS Rookie Topic Starter Posts: 6,503

    Thanks Young&Wild.
    A corded Logitech Mouseman+ works fine, as do various other
    Both the MX700 and the Explorer work fine on my daughter's PC with Win98SE.
    I dont want to go back to W98 and I will not upgrade to XP.
    From my other trials, I dont think it is a faulty motherboard
    or even a faulty mouse.
    Rather it is a buffer over-run or something fishy with the system-file I8014prt.sys.
    MS has been no help here.
  4. young&wild

    young&wild TechSpot Chancellor Posts: 993

    Perhaps uninstalling all the mouse driver and reinstalling the mouse and also the new drivers may help.
  5. Nic

    Nic TechSpot Paladin Posts: 1,549

    Maybe the batteries need recharging. Does the problem go away if you put the mouse back in its recharging cradle for 15 mins?
  6. RealBlackStuff

    RealBlackStuff TS Rookie Topic Starter Posts: 6,503

    Thanks guys.
    I have DriveImage backups with clean installs of W2K+SP4.
    I have a second instance of W2K on another partition for testing
    purposes. Here I have tried out all different drivers, including
    the latest Logitech 9.76. They still give problems even on a clean
    installation. Looks like it must be Win2K.
  7. RealBlackStuff

    RealBlackStuff TS Rookie Topic Starter Posts: 6,503

    Thanks Nic,
    I'll try out your suggestion next time the mouse goes jittery
    again. The mouse is (charging) in its cradle overnight with the PC switched completely off. The batteries are fully loaded all the time.
  8. MrGaribaldi

    MrGaribaldi TechSpot Ambassador Posts: 2,512

    It works like a charm here with Logitech's 9.76 on w2k (but only sp3)...

    When does it happen? Is it after a given time, or a time of inactivity? Only when the mouse is being placed over a specific surface?

    Does it continue if you put it in the cradle for 30 seconds, and take it out again? (This will cause the sender to stop and start)
    Does it continue with the mouse in the cradle?

    Sorry for all the Q's... Just trying to figure out what could be causing it...
  9. olefarte

    olefarte TechSpot Ambassador Posts: 1,345   +13

    Do you have another cordless mouse on another computer nearby, maybe you are getting interferance from it.
  10. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    It sounds like the mouse is probably bad, although it is difficult to tell for certain.

    Keep in mind wireless mice and suceptible to interference from anything from metal surfaces to microwaves in close proxomity. It may sound silly, but try lending it to a friend and see if they have the same issues.
  11. Mr Random

    Mr Random TS Rookie

    Do you have a cordless phone nearby? That turned out to be the cause of my similar problem with the elite duo. Try doing a reconnect when it bumms up on you. Lastly, try getting a replacment from logitech. Their cust serv is ussually pretty nice whenever I have talked to them.
  12. RealBlackStuff

    RealBlackStuff TS Rookie Topic Starter Posts: 6,503

    Thanks very much for all your reactions, suggestions and questions.
    There are no wireless phones etc. nearby.
    As I said before, the mouse works fine on my daughter's Win98SE pc (Asus P2B mobo, PIII-550, 256MB ram).

    Last night I switched my PC off and moved the mouse to the PS/2 port.
    This morning I switched on, went into Control Panel, System, Hardware Wizard, Uninstall device, clicked on "show hidden devices" and Lo and Behold, there were 5 instances of a HID-compliant mouse (=USB).
    I removed them all.

    On further checking I found 4 instances each of "VIA USB universal host controller" and "USB root hub". Is that normal?
    According to MoBo-spec there are 4 USB 1.1 and 4 USB 2 ports, but do they each need their own controller or hub?

    I will try the mouse on PS/2 with standard W2000 microsoft PS/2 drivers for a day or so. If that remains stable, I'll re-install Logi 9.76.

    Thanks again for all your help, I'll keep you informed of any progress.
  13. RealBlackStuff

    RealBlackStuff TS Rookie Topic Starter Posts: 6,503

    I had the same problem already with W2K-SP3.
    To divert myself, I sometimes play the card-game "Spider", which I copied over from Win98-PLUS.
    More often than not it is in this game that the problem occurs. Could that game or it's DLL's be the cause?

    Since the suggestion came up to place the mouse in its cradle, it has not given me the problem (yet) but then my PC is only switched on for a few hours at the time, not all day.
    So I dont know if that would solve the problem.

    I am independent and work from home, but I do go out regularly, switching the PC off.
  14. Arris

    Arris TS Evangelist Posts: 4,730   +379

    You have used an optical mouse on that worksurface/desk before without problems. My companies off here in Italy has blue desks that both MS Explorer and Logitech mice go funny on. I think its because there is no inconsistency in the desk pattern/colour for the mouse to calculate the distance it has been moved. Just a thought. I did scan through but didn't see anything about this, If this has been cleared up and I missed it sorry :eek:
  15. Nic

    Nic TechSpot Paladin Posts: 1,549

    Does it work without any Logitech drivers installed. I'm not sure about wireless, but I suspect that the drivers only allow you to access extra logitech driver features. If you try with just standard windows driver, if possible, then that would allow you to see if drivers are the issue. If the problem persists, then you may have a defective mouse. Good point Arris, surface colour/texture can also have an effect. My explorer mouse doesn't like woodgrain surfaces.
  16. RealBlackStuff

    RealBlackStuff TS Rookie Topic Starter Posts: 6,503

    Thanks Arris,
    I am using a proper (i.e. cloth on foamrubber) mousemat.

    Thanks Nic,
    PC is up and running since 09.30AM today without any problems,
    mouse in PS/2 port and standard MS-drivers for PS/2 compatible mice.
    I'll keep it going until midnight, and use it every once in a while.
    My PC does not suffer from overheating (is not overclocked either).
  17. RealBlackStuff

    RealBlackStuff TS Rookie Topic Starter Posts: 6,503

    Hello all,
    yesterday I had no problems whatsoever. Used all the programs
    that I normally do (Excel, Word, Avant browser, Pegasus email,
    Spider game, Alcohol CD-burning, Photoimpact, Nikonview etc.)
    and all behaved normally.

    In a few minutes I'll install Logitech 9.76 and see how that goes.

    From what I've gathered from other forums, a mouse on PS/2 is
    better than on USB (MS apparently prefers it for it's Intellimouse
    Explorer 3), especially when USB is governed by VIA-drivers.
    Keep my fingers crossed...

    how is our MX700 connected, USB or PS/2?
  18. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Just for reference, I've went through several cordless mice and I've yet to find a wireless that requires drivers aside from generic Windows drivers.
  19. MrGaribaldi

    MrGaribaldi TechSpot Ambassador Posts: 2,512

    Mine is connected through the USB, but that is mostly because I don't like using adapters...

    As for USB root's, I've currently got 3 USB roots, 1 USB 2.0 root and 3 VIA USB Universal Host Controllers, but only one HID-complaint Cordless Mouse...

    My guess would be that all the extra mice was causing the trouble (perhaps with Spider, though that doesn't sound too likely), but I don't know anything certain...

    Hope it works out with it installed in the PS/2 port, as the mouse is incredible, even for FPS gaming :)
  20. XtR-X

    XtR-X TS Rookie Posts: 863

    How are your first person shooter games? I have a similar problem that I've never had before too.
  21. dazz71

    dazz71 TS Rookie

    Logitech MX700 Problems

    I don't know if this will help anyone but, recently, I started having all kinds of problems with my wireless Logitech MX700 mouse. After trying a bunch of things, I realized that I had recently moved the base to the other side of my desk near my wireless network hub. I unplugged the power to the hub and the mouse immediately started working fine. So I just moved the mouse base back where it was and everything seems to be fine.
  22. Zen_toast

    Zen_toast TS Rookie

    I had multipe HID Mouse devices, deleted them all from Device Manager, shut down, restarted, and plugged the wires back in. I made sure all logitech software was unstalled.
    Works fine...(had jittery mouse too). From what I've learned (for what it's worth), the Logitech software (Setpoint) that allows you to tweak your button configurations is the devil...(though I totall dig having hotkeys...)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...