Laptop to TV no audio with VGA cord and y cable

Hey guys I have been trying to set up my tv so I can watch movies online... to say the least it is not going well.. I have been trying for over 2 hours and 2 trips to Best Buy to figure out why i have no sound on my tv.

My headphone jack does work.
There is a picture due to the vga cable.
I have a Y Cable plugged all in but no sound

Please someone help!!
Hey, I've tried to set this up at one point.. VGA doesn't seem to give sound at least on some T.V's so if you have a sound input you could try:
amazon [dot ]

sor maybe you could get something like:
electgadget [dot]

play [dot] com/Electronics/Electronics/4-/20708900/Trixes-HDMI-Male-To-VGA-Cable-1-8m/Product.html?_%24ja=tsid:11518|cat:20708900|prd:20708900

However I don't with to take the blame if any of these don't work :D
Well i know that vga doesnt help with sound in any way but that is why i have a y cable... i plug it into my headphone jack than the red and white into the tv but it doesnt seem to work.. my sound works fine otherwise :( ugh!
I'm guessing you plugged your VGA into your t.v?
So your T.V isn't looking for sound via the red and white input as the video isn't coming from that input..
Have a look on the back of your tv see if there's a PC sound in socket..
or see if you can change the sound input from you t.v menu
I did try the pc outlet in the back maybe my tv is just to old... :( on my computer I dont have a playback device except for my speakers maybe that is the problem? This really sucks!
Well, if it has an a jack pc input you could just get a double male A jack cable and then use your tv as speakers..
I can't see why that wouldn't work however i may be stood corrected
Just remember VGA and audio are completely separate;

1) If you connect your VGA cable to your TV then your TV will expect audio to appear on that same input group.

2) Connect your Y cable (1/8" stereo jack to 2 RCA plugs) from your headphone jack to the TV's VGA audio input.

3) If you have picture but no sound check your computer's headphone jack with a pair of headphones to be sure audio is coming out. If there is no sound coming from your laptop check your Windows Sound Settings in Control Panel to be sure the headphone output (if it is separate) is set to the Default Playback Device.


Posts: 1,230   +275
Hey guys- I'm having the same issue, have tried all of the above and it doesn't work. thoughts?

can you double check whether you have plugged it into the correct "PC Audio IN" at the rear of the TV? some people mistake that port for another audio input, say Component Audio or even Audio Out. if you're unsure, just take a picture of the back of the TV
I've been working on this problem myself and the reason there is no sound is because there is no input for sound for your PC.. There is a jack near the VGA input but it is for headphones and you don't have an option to change it as an input. Pointless to have vga input IMO without sound... But I didn't design the TV.


Posts: 1,868   +306
It seems unlikely that the TV will take the VGA input and not provide for audio too. I always keep the manufacturers' operating booklets which makes things easier. There's probably a lead that you can buy to do the audio connection. It will have a mini jackplug at one end to plug into the computer's headphone socket (output only) and two RCA connectors for the audio inputs at the back of the TV. My TV also has two RCA audio output sockets presumably to connect to an amplifier. Make a thorough examination of all the TV sockets and post the manufacturer and model details of the TV if you can't progress.


Posts: 2,854   +200
Okay, this is going to be one of those times you need to understand when it comes to VGA port and Stereo Audio output this I what you need to do.

VGA to VGA on VGA port on the back of HDTV
Audio Stereo Headphone Jack 1/8 male adapter Y type audio L and audio R. This is one type of cable but if your HDTV only has 1/8 male lead to lead to inline cable for Stereo Audio you need to purchase that type over the 1/8 with Y adapter stereo audio cable.

On the PC, open the Control Panel

Type in Sound
Right click Manage audio devices
Click on Create Shortcut this will appear as speaker on your desktop
Double Click on Sound icon
Right click anywhere
Click on Show disable devices (check off)
Click on Show disconnected devices (check off)

Sound Playback

Whatever you see listed above to match your connection make sure you set that to default.

Right click on the default
You have a menu of option features.
Configure Speakers
Set as the default device
Set as the default communication device
Show disable devices
Show disconnected devices
Properties (additional settings)

Note: Once you have made the connection from the laptop to HDTV via 1/8 inline cable just run test to make sure you can hear the test code play on HDTV. If you do use 1/8 stereo Y cables instead with RCA Left/Right jack same method would apply to match those input connections on the back of your HDTV.

If you run into sound playback issues the laptop must not be using SPI instead it should be using 24-bit HD Sound it should be 16-bit Stereo sound you find those setting under Properties. The laptop should setup the correct settings. But if it doesn't you have to do it.

I have desktop and two laptops using HDMI to HDMI on HDTV. I had 1/8 incline stereo cable to HDTV via VGA to VGA. That works fine. But when you turn on the laptop and flip the panel up there will be no sound from the laptop speakers. To change those settings you would reverse the settings above to default stereo speakers on laptop. Can't have both on laptop speakers and HDTV Stereo speakers.


Hello, I have Samsung HD TV and I was having the same problem. Bought a VGA adaptor and plugged the double ended HDMI cord into that and my TV and had picture but the sound was only coming out of my computer. I went to Target and bought an audio Y cord (one end is the red and white plugs for the TV and the other is the 3.5 mm headphone jack to plug in the computer). Next I had no sound at all. I read a few threads online and the best thing to do is to go to your computer's preferences or settings. I have a Macbook Air and I selected Sound from the System Preferences. I clicked on the 'Output' and there were two options to select for the output of sound: the one already selected being the headphone port, and the second device that was made available to select, "SAMSUNG" Type: HDMI. I selected that and bam! I got sound. I just wanted to post a follow up response now that I have figured this out and would like to save other people time and frustration.