Laptop won't install new device drivers

By DigiFGC ยท 4 replies
Dec 4, 2013
Post New Reply
  1. Hi everyone,

    I have an hp Pavilion dv6-3250us Entertainment PC that no longer installs device drivers. As a result of this problem I can only use the storage device (flash drive and external hard disk) whose drivers have been installed before the incident started with the laptop.

    I have tried to update the drivers of the connected device but no success. I got error code 28: The EPA software drivers not installed.

    A system reset won't be an option here because the incident started a long time ago and I've been trying to manage the situation by using a vmware to access connected device but I've had enough of that and really determined to solve this problem once and for all.

    I've also gone through similar treads but none of the solutions proffered solved my problem.

    Please help me out here :confused:
  2. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    DigiFGC likes this.
  3. DigiFGC

    DigiFGC TS Rookie Topic Starter

    Hi mailpup, thanks for your help.[​IMG]

    I've carried out the steps in the thread but when I connected my external hard disk to my laptop the drivers were not successfully installed. It says EPA drivers not found.

    To make matter worse, even the storage devices that used to work with the laptop is no longer recognized and their drivers can't be found since I've cleaned up old installed drivers.:'(

    I also observed that after running the drivercleanup.exe program that 1 key wasn't uninstalled from the registry. Kindly, find attached a snapshot of the message.

    I don't know what to do next. It's so frustrating.:confused:

    Attached Files:

  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    What version of Windows are you running?

    Verify if these files exist:

    /* EDIT */
    And one more: C:\Windows\inf\usb.inf
  5. Jumong

    Jumong TS Rookie

    hi lookinaround, hoping you could help me too.. this is what I saw in my problem device area :
    BAPIDRV ROOT\LEGACY_BAPIDRV\0000 This device is not present, is not working properly, or does not have all its drivers installed.
    BlueStacks Hypervisor ROOT\LEGACY_BSTHDDRV\0000 This device is not present, is not working properly, or does not have all its drivers installed.
    Intel(R) Turbo Boost Technology Driver PCI\VEN_8086&DEV_3B32&SUBSYS_04471028&REV_06\3&11583659&0&FE This device is working properly.
    Not Available ROOT\IMAGE\0000 The drivers for this device are not installed.
    Not Available ROOT\IMAGE\0001 The drivers for this device are not installed.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...