1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Lexmark printer not scanning -- driver problem?

By mom26gr8kids ยท 11 replies
Nov 6, 2012
Post New Reply
  1. My husband and I recently purchased a Lexmark Pro 715 All-in-One Printer. We have Windows Vista 32 bit on our computer, but from the moment we installed the printer we have been unable to get it to scan. It will not scan from the menu on the printer, nor will it scan from Windows Photo gallery and in Picasa when I click on the Lexmark 710 series icon it says: "Unable to connect to device, please check the connection."

    We have uninstalled and reinstalled the printer software/drivers numerous times. We have been on the phone with Lexmark who said that our security software must be interfering with the connection and so we uninstalled and reinstalled with our security software off. We even had Lemark remotely access our system and they could not get it to work. It says that this is compatible with Vista, but if that is the case then why can I not get it to work from my computer? We need the scanning function for my husband's business and we are at our wit's end trying to figure this out. Tech support has no further suggestions for us. but thought someone here might have an idea what would help.
  2. jobeard

    jobeard TS Ambassador Posts: 12,491   +1,430

  3. mom26gr8kids

    mom26gr8kids TS Guru Topic Starter Posts: 534

    Yes we have read the user's guide. For some reason no matter how many times I attempt to uninstall and reinstall this software the twain driver is not recognized by my computer. I keep getting a message saying, "Unable to connect to device or Twain driver is not installed" I have even been to Lexmark's website and downloaded a driver specifically for the scanner. Has anyone ever heard of this happening? It is very frustrating and at this point my husband and I are going to have to get rid of this brand new printer we bought because we cannot get it to work. If anyone has any further tips I would appreciate it.
  4. jobeard

    jobeard TS Ambassador Posts: 12,491   +1,430

    Many printers have mutiple drivers and the Twain is problematic. If the computer recognizes the device, try using the
    devicemgr, find the specific device and then allow Microsoft to Update Driver
  5. mom26gr8kids

    mom26gr8kids TS Guru Topic Starter Posts: 534

    When I use my device manager and have to computer search for an updated driver it says that the driver I have already installed is the best driver for my device. If the computer can supposedly locate the device manager then why in the world can I not scan anything and none of my photo programs (Picasa, Windows photo gallery, etc) can find the device either?
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    I also saw a firmware update on the Lexmark support site (for the Pro 700 series). Have you tried that yet?
  7. mom26gr8kids

    mom26gr8kids TS Guru Topic Starter Posts: 534

    I have tried that before, but I tried again and it says my printer's firmware is up to date. Two questions:

    1. At notice at lexmark's webiste they also have a universal printer driver. Do you think it would help to uninstall my driver and then reinstall a universal driver instead?

    2. When we originally talked to tech support at Lexmark they thought the issue was caused by our firewall or security software blocking some components of the installation. However, we have reinstalled the software several times with our anti-virus and firewall disabled. I am wondering though if it might be possible that our router is blocking something. Don't routers sometimes come with firewalls, or act like a firewall? Is it possible I can change something in the router settings to make the printer scan? We have the printer connected to the PC via a USB cable and an ethernet cable. That made me wonder if maybe the wireless router could be causing some of the issues.
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Just a quick response for now.... Sounds like you recently bought this. Is this thing still returnable to where you bought it? If so, probably best to do so within the time window to get past this headache and return it while you can
  9. jobeard

    jobeard TS Ambassador Posts: 12,491   +1,430

    Why both - - usually one is sufficient.
    Are you attempting to get multiple PCs to access it with direct connections to it?
    when a printer is connected via USB, the router has no interaction and neither does any firewall. IMO, your system can't find the device and thus neither can your applications (Picasa, Windows photo gallery, etc).
    sure, can't be any worse can it.
    Also get that new firmware.

    With the USB connection, how does the AIO show up when seen by Control Panel-> Devices & Printers?
    If shown right-click & get the properties to see if the scanner settings are available.
  10. jobeard

    jobeard TS Ambassador Posts: 12,491   +1,430


    I've setup a Lexmark Lazer system before and it was a bear using the network connection.
    Suggest you get the USB working first.

    In addition, there are two ways to scan a document; a} using the button on the printer and b} using the software tools.

    Which one are you attempting?

    The USB / software is the easiest and will prove that the driver is just fine (or not). My AIO scans pages and then I collect them into a PDF for saving. Using the Scan button on the device requires the system to send an event to the software which is more complicated. It also explains why the network attachment is a bear - - you can't do that easily. The Lexmark/Lazer on a network required sending EMAIL to get scans loaded to the PC - - YUCK!

    Recommend that you disable the network connection to the printer and stick with the USB until at least that works.
    LookinAround likes this.
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    I didn't notice before you had both network and USB connected. It should be one or the other but not both. I also agree with jobeard's advice (y) Start with USB connection only. (tho also keep an eye on any time limits you have for returning that device, if need be)
  12. jobeard

    jobeard TS Ambassador Posts: 12,491   +1,430

    Bump- - any progress on your scanner?

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...