Logitech Gaming Headset G330

By plasma dragon00 ยท 7 replies
Dec 26, 2009
  1. Not sure whether this should be here or int he WIndows section as it seems to be linked to my OS.

    Anyway, I just got the Logitech Gaming Headset G330 for Christmas (ps: Merry Christmas, all!). It has two speakers and a boom mic. The mic and speakers connect on separate stereo jacks, which can plug into a regular audio port, but also come with a USB dongle to integrate them into just one connection (mic + headphones = USB). Using the single headphone cable works great from my back panel audio, as well as my iPod. (Didn't try the mic one). However, when using the USB dongle on MY pc, the mic and headphones SUCK!!! But, on the Compaq netbook my little brother just got and my mom's Dell, it works just fine... A half hour on the phone with Logitech has determined that the hardware for the headset is indeed NOT faulty. It is a problem with my OS.

    note - by sucks I mean the audio is low, garbled, staticy, has feedback, etc. Not what you would expect from a 50 dollar headset. I tested the mic with Ventrilo and my Realtek AvRack program to record, played back in Ventrilo and AvRack, also played iTunes music through it, and Windows system sounds sound just as bad.

    The headset does NOT come with its own drivers; it uses generic USB Audio drivers. After some searching... I found a usbaudio.sys on the internet for XP, and replaced mine with that. Still, no improvement :( Does anybody have any ideas on what the problem could be? My mom said that maybe my Xbox 360 wired headset I use with my pc (through the 360 controller) has the same problem now, but it doesn't; I suspect it is because the 360 headset has its own drivers through the controller.

    I think it is a driver issue, or possibly a codec issue of some sorts. So, if anybody has some quick ideas on what to try before, oh I don't know, around 11 am Eastern Time, let me know. I will check back here many times before then. If not, Imma just reinstall Windows lol.
  2. plasma dragon00

    plasma dragon00 TS Rookie Topic Starter Posts: 172

    Nevermind, I am just gonna reinstall now lol.

  3. hellokitty[hk]

    hellokitty[hk] Hello, nice to meet you! Posts: 3,448   +145

    I would think a $50 headset should come with drivers, but I don't know, good luck.
  4. plasma dragon00

    plasma dragon00 TS Rookie Topic Starter Posts: 172

    Reinstalled windows... and the thing still doesn't work right!!!!!! :mad:

    It works fine, however in Ubuntu Linux on the same computer, eliminating my ideas that it could be a hardware failure in my computer...

    This headset uses generic USB Audio drivers that install with Windows. Since my Windows disk is SP2 integrated, should I reinstall again and see if audio plays without installing ANY other drivers? No sound plays from my normal speakers, plugged in through the stereo jacks from the back of my mobo (Asus A8N-E mobo with Realtek AC'97 Audio, integrated). If Windows has USB audio drivers integrated, it SHOULD work... then I will install drivers 1 by 1 and see what breaks it. I have a feeling that for some reason my Realtek sound drivers are molesting the USB Audio drivers.

    If that is the case... then I guess we can work from there...

    Thanks, and ideas would be IMMENSELY appreciated.

    p.s. - A rundown of what I have installed on this copy of windows xp home.
    SP3, and full windows updates
    realtek sound drivers (latest I can find on the realtek and asus websites)
    nvidia vid card drivers (latest)
    nvidia Ethernet drivers (disk...)
    nvidia SM Bus drivers (disk...)

    edit - under the only USB Audio device in device manager, it lists using the following drivers...
  5. plasma dragon00

    plasma dragon00 TS Rookie Topic Starter Posts: 172

    Flashed my mobo BIOS to version 1013, which is from 2006 lol, but it is the most recent version. Booted back into windows... Microsoft WINMM WDM Audio Compatibility Driver has a yellow exclamation point in Device Manager.

    A driver (service) for this device has been disabled.  An alternate driver may be providing this functionality. (Code 32)
    Not sure what to do from here... -_- time to hit up the google! rofl

    EDIT - uninstalled it in Device manager, restarted, scanned for hardware changes, and sound now works, from my normal speakers... *crosses fingers for the headset*


    I'm going to do ANOTHER reinstall of windows... -_-
  6. hellokitty[hk]

    hellokitty[hk] Hello, nice to meet you! Posts: 3,448   +145

    Me neither, good luck now that you know it isn't a hardware problem with the headphones.
  7. plasma dragon00

    plasma dragon00 TS Rookie Topic Starter Posts: 172

    Well... reinstalled and they worked flawlessly from the start. Ran into a problem getting one of my SATA drives to connect, but thats because the cabled popped off of the mobo -_-

    Anyway, installed chipset drivers, vid card drivers, processor drivers, and the newest sound drivers. restarted between each install, and my headphones (havent tested the mic yet) work great! Also made a backup of each driver file that the headset used before i installed any drivers, so I have a fallback XD

    I just hope Windows Update doesnt break anything.

    I want the backlit keyboard from the toshiba ad at the top of the page XD rofl.

    Anyway, hoping it stays working X_X lol

    Go figure, Micro$oft would make the 360 controller drivers break USB Audio. Since I cant seem to find email support, I had to resort to posting on their forums. Hopefully someone here can help too.
  8. hellokitty[hk]

    hellokitty[hk] Hello, nice to meet you! Posts: 3,448   +145

    Haha, good thing you got that working.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...