Keyboard / Mouse Logitech keyboard not functioning after BIOS, out of ideas

Hello all, first time poster here. Having a problem with my USB keyboard. Been looking online all day, found tons of forum topics (here and elsewhere) but none that were effective at solving my issue. Using a Logitec G110. Running win XP pro.

When its plugged into a USB port, it's getting power, but the keys are unresponsive (they keys are back-lit, so I know it's on). A few things:
1- First off, the k/b works outside of windows. I can get into BIOS and navigate without a problem. As soon as windows starts to boot, the k/b flashes off then back on, and it loses functionality.
2- I've tried every USB port on my motherboard NUMEROUS times (my mouse and headphones work as well) so I don't think it's an issue there. I went out and bought a PCI 4-port USB card today in case my ports/motherboard are bad, and still no change in the new ports.
3- I plugged the k/b into my other computer, an acer laptop, functioned immediately, so the k/b isn't broken.
4- I have NOT tried using a PS/2 adapter. I DO have a PS/2 port, but even if it ended up working, it won't fix my problem. I'd rather fix the issue not work around it, if you know what I mean.
5- I went into my registry and checked to see if the upperfilters data was "kbdclass", which it was (I saw this "fix" in another forum, didn't apply)

So I went into my device manager, and there are no keyboard devices, just 10+ entries in "Human Interface Devices". I unplugged my keyboard, then put it back in while watching the device manager. Initially, it comes up under "other devices" with a big yellow questionmark while it's installing the drivers and such. As it's working, the DM updates itself periodically as usual and I see a keyboard entry. After a few seconds it updates itself a few more times, and the keyboard device vanishes and the 10+ HID entries appear. During the time the k/b is filed under a keyboard device, it has full functionality. What I mean is that I opened notepad before I plugged in the k/b. While it's installing itself, I was able to type a bunch of gibberish in notepad, but once it finished installing the drivers for itself, it stopped and I couldn't do anything.

I can't think of anything else I tried to do to fix this. Like I said initially, I spent a few hours searching for possible solutions, but nothing worked. If anyone has the slightest clue what I can do, or if you need me to provide more information before you can diagnose my situation please let me know.

I'm really hoping it doesn't come down to me needing to get a new motherboard, or even reinstalling my OS. Thanks in advance for the assistance!


Posts: 7,593   +716
TS Special Forces
I don't know if I have the solution to your problem but for diagnostic purposes can you try another USB keyboard?