1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Maxtor OneTouch III Mini Problems

By Vigilante ยท 10 replies
Feb 21, 2007
  1. Ok, this is a brand new Maxtor OneTouch III 60GB Mini USB 2.0 external HDD.
    I have XP Pro (yes, admin user).

    When I first plugged the thing in, XP installed it, including the OneTouch software which was on the drive itself (it came with NO CD).

    I played around with the software, it worked, I did a backup, etc... I set the settings the way I wanted. I unplugged it and plugged back in and tried the button on the drive, all was well.

    Then I noticed a new Maxtor process that was taking 50% resources. I looked it up and it was the Sync process which continually checks your selected backup folders for file changes. I looked up the process and it is not needed if you aren't using the Sync feature. I wasn't, I was using the normal backup feature. So I removed the process from startup.

    Well a couple days later I tried to do a backup and it wouldn't do it. Instead of showing files being backed up, it just sat there saying "Backup Process" with no other text. I left it overnight, it was still sitting there saying the same thing.

    Now that is the background. Here is the problem:

    If I hover over the OneTouch icon in the system tray, it says "Backup to OneTouch III Complete!"
    I don't know what "complete" means, it always says like, like it's stuck or something?
    If I go into the software, it shows the drive, and I can run diagnostics on it and everything seems fine. I have a drive letter, I can browse the drive and see files, nothing appears to be wrong.

    But when I click Backup Status, I get two errors, the first one says:
    Title Bar: "Backup Status"
    Message: "Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item."

    Then I click the OK button, and get this one:
    Title Bar: "OneTouch Status Icon"
    Message: "Backup Status cannot be opened, because a system error occurred."

    I click OK again, and that's it.

    I've searched Google, and the Maxtor FAQ and support stuff, with no luck.
    Google turns up ONE result from a forum where a person had the same error messages. They had given two links to Maxtor pages where the OneTouch software could be downloaded, or some other thing. Both links don't work due to the recent buy out from Seagate. Probably most old Maxtor URLs aren't going to work.

    So as I was troubleshooting, I just said screw it and I formatted the drive in case there was a problem. The format worked fine but the software still threw the same errors.
    Now I'm in worse shape because I can't download the software again, it was only on the drive!

    I've been searching all over for where I can download the OneTouch III software but with no luck. I tried to make sure there was no funky permissions problems with the drive, I can't find any.

    So here I am with a brand new external drive and I can't do any backups to it because the software keeps throwing errors.

    I need help doing any one of these:
    1) Find a download for the OneTouch software so I can reload it and see if that helps.
    2) Forget OneTouch and find a better backup program (recommendations?).
    3) Find out what these errors mean and fix them (preferred).

    Sorry for the length, I like to give as many details as possible.

    Here are some links:
    This is all the downloads Seagate gives for OneTouch:

    Knowledge base, couldn't find anything helpful:

    Forum with person who had my problem (post #22):

    This feels stupid, cause it's all brand new and I've only got one or two backups out of it. The process I removed from startup, I read that it was safe to do. And I don't think backups were messed up until sometime after I removed it.
    Also the error logs don't show anything. No new errors appear when I try to check status or use the drive.

    Thanks for ideas.
  2. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    Here is a picture of the OneTouch software, showing the drive.
    I can run the diagnostics with no problems, it just won't backup.

    Attached Files:

  3. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    Takers? .....
  4. mflecker

    mflecker TS Rookie

    Same Issue

    Did you ever get a response on this? I have the exact same issue. I tried re-intalling the software, and that did not seem to help. Let me know if you found the secret. Thanks. Mike
  5. SpaceCowboy5150

    SpaceCowboy5150 TS Rookie

    Had the same issues as you guys.... Sent email to Seagate (formerly Maxtor) customer tech support... this is what I got back:

    The error you are getting when trying to access the back up status is due to explorer 7. You can access the back up log from the following location.

    Location for OneTouch III Drives Using Maxtor Backup - C:\Documents and Settings\All Users\Application Data\Maxtor\ULC\Log

    Note: By default that these are Hidden File/Folder Structures. To unhide these folder structures, do the following:
    1. Open My Computer
    2. Click Tools - Folder Otpions...
    3. Click the View tab
    4. Scroll down and click on the Show hidden files and folders radio button
    5. Click Apply and then click OK

    Hope this Helps!
  6. DadH

    DadH TS Rookie

    I have a similar though different problem with a "maxrestore.dll" error that's crapped out the OneTouch3 Mini (also only 2 months old and used to work). However my Tech support gave me a site to obtain a comple OT3 installation software (which didn't get rid of my error, but that's another story) and so I give it to you. It seemed to do all functions OK except for my .dll error.


    Hope it helps. Adios from sunny Tucson. DadH
  7. timebombtimmy

    timebombtimmy TS Rookie

    one touch 3 and server 2k3

    i just recently have attempted to install two one touch 3's on windows server 2k3 r2 sp2, which seemingly went fine, but i receive the maxrestore.dll error when attempting to use the drive. a manual backup succeeds, but the one touch button does not work, and the maxtor backup status icon says no one touch drive found(even though it states my serial number). anyways, i called seagate support twice today and received the same answer from different techs. SERVER 2003 IS NOT SUPPORTED! And they dont intend to introduce a product that does support it! apparently these guys think that only desktop users want 'one touch' backup abilities. needless to say i am rather surprised.

    off to find another backup solution...
  8. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    Hey guys, sorry to resurrect this thread. I never did fix this, I ended up throwing out all the Maxtor software and using a program called ICE Mirror instead. Works just fine for my needs.
  9. ash1818

    ash1818 TS Rookie


    sorry to disturb but, can anyone post me a link for maxtor onetouch III mini edition software for windows xp platform? coz my external drive cannot be accessed since it is password-protected when i format it.

    i need to fix it or else i'll be dead :(
    please....please post it asap..i really need it.
    any comments will be greatly appreciated..tnx
  10. DadH

    DadH TS Rookie

  11. Torkuemada

    Torkuemada TS Rookie

    Vista Fix

    I recently had the same problem and ended up on this thread during my search for the answers. I am running Vista. I resolved the problem by uninstalling all the Maxtor software. (This requires manually ending certain services through the task manager with the Maxtor disconnected from the computer.) I then downloaded and installed the Onetouch Maxtor III vista software off of the seagate website. Since this is my first post, I can't link the url, but it is pretty easy to find. I hope this helps you unfortunate vista users.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...