1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Mic Problem with Realtek HD Audio Input

By nikm · 108 replies
Nov 30, 2005
  1. euthymius

    euthymius TS Rookie

    I think that the problem is not in REALTEK - they have done a wonderful thing - but in the microphone I use - one of the past century :) Probably applying a microphone dating back to the same computer era as the Realtek sound card should be the proper solution...
  2. lilschnowyguy

    lilschnowyguy TS Rookie

    If this was true, why is half of the recording section grayed out? Opposed to just the micrphone volume. Fact of the matter is, the latest in hardware should support every mic under the sun despite when it was made.

  3. MagNet

    MagNet TS Rookie

    Well I still have the greyed out problem, front mic doesn't work, etc.

    But I can tell you one thing, the hardware isn't the cause for sure, it's actually quite nice tbh. I've tried using it under linux, and guess what, everything worked perfectly - the sound setting is so nice there you can even have the sound running from both outputs and stuff like that, just wonderful... maybe if there was some way to port the linux drivers or something because I'm prolly not going to switch.
  4. wmbenedetto

    wmbenedetto TS Rookie

    Problem solved

    I was having the same problem as everyone else with my Realtec HD microphone. I think I figured out the solution, so I figured I'd share.

    Apparently, Realtek's audio software is in no way based on logic. You'd think, "Hey, I want to record audio, I should be working with the audio INPUT settings, right?"


    As many of you have discovered, going into the audio input settings either through Windows or Realtek's app will result in grayed out mic controls. That's because Realtek's mic real mic controls are located in the audio OUTPUT settings.

    First, open your volume control. The easiest way is to doubleclick the sound icon in the system tray. You can also go to Start > Control Panel > Sound And Audio Devices then click Advanced under Device Volume.

    In the Master Volume window, click Options > Properties. In the properties dialog, you'll see a dropdown for Mixer Device. If you're like me, you changed this to Realtek HD Audio Input, then selected Mic Volume.


    Instead, select Realtek HD Audio Output. In the box below labeled "Show the following volume controls", scroll down to either Rear Pink In or Front Pink In. These sound pornographic, but they actually refer to the mic input jacks for your Realtek card. Mine are plugged into the rear jack, so I checked Rear Pink In. Then click OK.

    This adds a new volume control to your Master Volume. And, sure enough, you will probably see that it is muted and the volume is at 0%. Unmute and jack up the volume. There is also an Advanced button. Click that and you'll get an option to check off Microphone Boost. Check that and click Close.

    If it works for you like it did for me, you now have working a working microphone input.

    Hope this helps somebody.
  5. lilschnowyguy

    lilschnowyguy TS Rookie

    Still doesn't solve the issue.

    This still doesn't solve the issue.
    The issue for me wasn't the microphone, it's the fact there is no STEREO MIX option and I'm pretty sure what you said is what i said about 4 posts up.
    The lack of control within all of the other recording options is the issue.
  6. kikebabe

    kikebabe TS Rookie

    I have fix for all of your mic input problems.

    i was working on this problem 1 month till now. i was trying all Windows ver. In all of them was the same problem when i was speaking on skype the second person was hearing me partialy. the first 15 sec ok than the sound was received chopy. The same was when i was using Gtalk. But now the problem is solved :). So if some one donate some bucks at least 1€ to my account to cover the cigarete costs :) i will be glad to share the solution.
    This covers Windows Vista/Vista x64/Home /Pro /Media Centar Edition.
    This problem was with input on my Realtek HD sound card.

    pm me
    email: krisbliz2000@yahoo.com
  7. lilschnowyguy

    lilschnowyguy TS Rookie


    Information should be free *******. You know where you can shove ya solution?
  8. kikebabe

    kikebabe TS Rookie

    Hey lilshowyguy at first the microphone and the line in and the stereo mix are grayed out because u can select one of them and then with the master control in the recording volume selection you can set them at any level u want. Example if u select mic with the master slider u can set any lvl for your mic.
    2. turn of immediatly stereomix (in vista go control panel/sound/recording right click and select show disabled devices if u dont see)

    But for windows xp the realtec hd audio codec driver is making always the sliders greyed out, this is not a bug.
    i hope i helped.
    But for the mic input solution is another thing. ;)
  9. asimons999

    asimons999 TS Rookie

    same problem

    Yep I am having the same problem..

    no sound at all, and the mic sliders are grayed out.. tried turning up the mic thats in the Output settings for some reason.. but still doesn't work..

    downloading the latest drivers now.. dought it will do much
  10. Bruno.H.

    Bruno.H. TS Rookie

    Gigabyte GA-965P-DQ6 MBO and Realtek ALC888 DD Microphone Volume problem


    Gigabyte GA-965P-DQ6 (Rev. 1.0, BIOS Vers. F5) MBO and
    Realtek ALC888 DD Microphone Volume problem

    It is a simple than this - "Volume Properties" for "Microphone" and some other "Volumes" are simply as disconnected in a "Realtek Tray / system Notification Area Icon", and / or in "Volume Properties" also located in the Tray / System Notification Area...
    I cannot engage the "Advanced settings" for "Volume Properties" at all and permanently!!!

    Main problem: Any Microphone recordings of mine are recorded with much decreased volume – the scream into Microphone is recorded as a low voice,
    even like / most like just a whisper???!!!
    Because of that, Microphone is practically unusable at all!!!

    Eventual, "20db Boost" for Microphone I cannot engage because, again, I cannot engage the "Advanced settings" for "Volume Properties"
    at all and permanently, as like they are not existing at all – there are unavailable - they are gray-ed out...

    In the meantime, I try to use some (for second time actually), older and small HDD for this testing purposes only.

    Here, on this small test HDD, I install first MSWinXPSP2 (full clean install from the scratch), than install Intel INF Update (+ PC restart),
    and than Realtek newest HD Audio Driver R1.66 (+ PC restart).

    After that, my Microphone problem reviled instantly!!!

    I installed after that my Marwell LAN Driver 8.612.3.3 (+ PC restart), than newest NVidia Driver for my VGA Card and that’s it.

    After that I install every available Microsoft Windows Update from the "Windows Update" Service, than MSOF2K7 + all available Updates for it,
    and I install RARlab WinRAR 3.62.

    The Microsoft Update KB925902, KB928843, KB935448 are also instaled...

    The KB935448 is the last Win Update that corrects any errors reviled in the previous and simillar Win Updates: KB925902 & KB928843!!!

    But all this 3 just mentioned Win Updates does not have any thing with my Microphone low recording voice problem...

    Never the less, Microphone problem reviled as soon I install MSWinXPSP2 and Intel INF Update, and than Realtek HD Audio Driver.

    That means that no other Software or it's Update didn't produce this problem with my Microphone not available "Volume Properties" settings (increase or decrease Mic volume possibility) or it "Advanced settings" (20db Boost or similar), because all that I mentioned that I install, I install after the problem reviled in the first place!!!

    P.S.: Any DTS, Dolby or similar are disconnected as my knowledge.
    Regarding that, again, problem reviled instantly after Realtek Driver R1.53 or newest R1.66 is installed (I tested both mentioned Driver versions on two different and my old HDDs…), and in that time I did not change any settings in it, than default one RealTek put it there him self, and in the first place…

    Our 20DB "Boost Option" is integrated on our input port, so you need to enable your "Boost'' function on Playback panel of Sound Control
    (Please refer to screen-shot / picture bellow).

    By the way, Gigabyte's board supports MIC function on "Rear Pink in" and "Front Pink in" port, so you need to enable "Boost" separately if you also need to use "Font pink port" as Microphone function.

    In your case, you set "Rear Panel Pink port" as "Microphone", so' you need to follow below screen-shot and set "Boost".
    If any problem, please let us know; REALTEK.



    Here is just some Forum referrings to this particular problem (I'll hope that will helps also…):

    a) https://www.techspot.com/vb/topic38366.html

    b) http://forums.techguy.org/hardware/5...input-mic.html

    c) http://www.bihforum.com/showthread.php?p=247063#post247063


    Bruno.H. via Italy
  11. vwgtipowr

    vwgtipowr TS Rookie

    This thread has a lot of great suggestions that I will try today.
    If none of them work for me, I may have to use the second sound card for input method.

    I have a gigabyte 965p DS3, and I have the same problem with grayed out mic controls.

    In teamspeak everyone complains they can barely hear me, and they get tons of feedback/echos from me. I tried testing in the teamspeak loopback mode and I can hear all the feedback, it is unbearable. Sometimes the mic doesn't even work.

    All of the audio out sounds seem to be working fine.
    Damn those realtek drivers!
  12. Ruben

    Ruben TS Rookie Posts: 100

    I used built-in realtek sound card but I could never get input settings right, not even for skype, forget recording. And when I finally figured out I had weird echo.
    I bought sound card (X-Fi) over a year ago and had no problems since. I am planning to get a USB or PCI express sound card for my laptop now.
  13. vwgtipowr

    vwgtipowr TS Rookie

    Yeah, I think it might be doable.
    I'm gonna test teamspeak again tonight with some friends. I fixed the real quiet mic problem. Mic volume seems to be normal now.
    When I put TS into loop back test mode, I get crazy feedback!

    The odd thing is anytime I talk into the mic it comes over my headset/speakers. Seems the mic is always on. I mean always, even when teamspeak is not running. Makes it easy to talk to myself though. :)

    So if tonight's tests fail, I will probably find myself buying a $20 soundcard (or USB headset depending which is cheaper) to by pass the issue.
  14. kikebabe

    kikebabe TS Rookie

    and if u dont want to buy new sound card or new head phones just donate me only 1€ i will send u my patched realtek HD drivers on your email. I know that this is patetic :) but i need 7€ more on my paypal account to continue my web page agreement.

    They work on Windows Xp/PRO/HOME/MCE Windows Vista all ver.
    Skype will be cristal clear, TeamSpeak also. Fix for everyting

  15. aaathreat

    aaathreat TS Rookie

    THANK YOU SIR! I joined the forums just to say thank you very much after having my new mobo and PC since last year ive never gotten the mic working properly and now it does! :) Thanx everyone in the thread.

  16. MagNet

    MagNet TS Rookie


    I think I should remind you guys that the Microphone sliders in the output section are really for output, except for the boost, if you unmute them and put the volume up you should hear your mic input in your audio output device so stop that bs, we need a new driver.
  17. canuckteach

    canuckteach TS Rookie

    read thru the threads on RealTek problems- tnx to all. it seems to me that my Athlon-based PC was fine a few months ago - I could record from the stereo-mix channel of my wave-recording software (Magic Audio), and I mixed a few mic based waves for my jazz webcast at live365.com. I'd always used Sound-Blaster cards in the past, and was pleased that Realtek offered the same versatility.

    suddenly, the 'mix' channel picks up nothing, and the mic volume is so low that, although I ran MicCal, and Volume Boost, etc etc, when I record a wave via the 'mic' channel, even if I amplify it 1000% in Magic Audio, there is no sound.

    I can live without mic recording - what I can't get is that the 'wave' channel of Realtek HD audio output does NOT have a corresponding channel on the 'recording' side (Realtek HD audio input). there is a 'stereo mix', but it ain't picking up the 'wave' channel. I removed/re-installed to the latest Realtek software (May/07). I can only assume that with the daily rigours of living in a Win-XP system, Realtek drivers begin to deteriorate.

    unless someone has a quick answer, I may just scrap Realtek and go back to SoundBlaster. (in these newer PC's, the sound is hard-wired to the motherboard. upgrades can be messy.) did anyone experience/overcome this problem?
  18. lilschnowyguy

    lilschnowyguy TS Rookie

    Stereo Mix

    My problem was never the mic, the mic was the easiest part to fix. Even without the 20 people explaining it over n over in this thread.
    The main problem is stereo mix, it seems it doesnt like stereo mix in XP anymore, I installed my other board with soundmax chipset audio and I had no stereo mix on that either, I also tried an old creative soundblaster live and also no stereo mix. It seems to be the same thing amongst all the big names.

  19. canuckteach

    canuckteach TS Rookie

    ilschnowyguy - tnx..! I think yer bang-on. Btw: with XP, have you experienced 'stereo mix' for awhile - then, suddenly, it just drops? my old XP PC did that (a SB card then) - finally, I had to do a clean re-install of WIN-XP anyway.. and the stereo mix ('what you hear') channel came to life, my wave recorder was back in business, and I was very careful about what programs I installed after that. 'Stereo mix' still works on that (not very busy) PC. So, this is the 2nd time with XP I've lost the feature. if anyone with Realtek and this symptom also re-installs XP, and also resolves the problem, please post it so that we know there is no other workaround, huh? save some grief all-around. A couple of techs I talked to opined that it's really a complex XP 'registry' problem -- and that a re-install/clean registry is the only way.
  20. canuckteach

    canuckteach TS Rookie

    13-Jun-07 - happy to report that my wave recorder via stereo mix has come back to life.. I changed nothin' - same board, drivers.. (well, I actually have an Audigy card from eBay sitting in a box beside PC ready to be installed... maybe the RealTek software caught sight and decided to behave?)... there have been some auto Win updates from MSN (Win-XP Home) installed, but I have no idea what impact that might have had... hmm .. wonder if the mic works now, too?
  21. JimmyBob

    JimmyBob TS Rookie


    I'm having the same problem as most of you. My mic whilst talking on teamspeak is really quiet, and people get a huge amount of very loud feedback from me. I've tried most of the stuff people have said on this forum and I can't say any of it has worked for me.

    Sometimes I get unusual noises coming from my mic aswell, such as when I'm testing it on Teamspeak or Sound Recorder. Loads of my settings are greyed off so I'm unable to change them. I rememeber somebody saying that plug the jack in the back of the computer and a balloon will come up saying a jack has been plugged in, so click the balloon and let it recognise the mic... when I tried this nothing would come up when I clicked the balloon. Thats been the most hopeful way around it for me.

    I'm currently on a Realtek ALC660 (Onboard), and I'm starting to get a little impatient as many people have been spending months trying to find a resolution, and I'm not the smartest when it comes to computers. Because of this, I'm thinking of buying an external sound card for my USB, so I can use it just for the mic (as the sound of the is fine, its just the mic). I've looked on Ebay for these and they are going for like 99p, would these be very reliable and any good? I use my mic a lot whilst talking to friends over Teamspeak.

    If you know how to get round this... please help!!! otherwise, could anybody give me some advice on what or what not to buy for an external sound card. I'm willing to spend only up to about £15 on it.

    Any help or support would be great!!!
  22. reknaps

    reknaps TS Rookie

    I fixed my mic!!!!!

    ITS FIXED!!!!!!!! Yahoooo!!!!

    I had the exact same problem as the original poster here with my mic recording at super soft levels. I toyed around with the sliders, putting them down then back up and oddly enough that worked a few times, but as soon as I'd reset the computer it would go back to being quiet. After doing that a few times it stopped fixing the problem... I dunno how.

    But anyways... I emailed Realtek and got back a picture of how the sound manger is supposed to look like. The essence of the reply I got was that I needed to enable the mic boost.

    I almost replied back stating that I couldn't even access the mic boost since the 'advanced controls' option was grayed out.

    I decided to dig around before sending back hate mail and I discovered that you can get the 'advanced controls' (and therefore the Mic Boost) to show up. And its easy.

    In my master volume window I only had "Master Volume", "Wave", "SW Synth", and "CD Volume" with their sliders showing. For those 4 sound sources there are no advanced controls, which is why it was always grayed out for me.

    I clicked on 'Options' then 'properties'. While viewing the "Realtek HD Audio output' mixer device, make sure to check the box to wherever you have your mic plugged in. For me it was "Rear Pink In". (I had looked through the list before, but was always looking for "Mic In", not this pink crap).

    After checking "Rear Pink In" and hitting OK, go back to the Master Volume window and hit Options. You should now be able to select "Advanced Controls". The "Advanced" button should then appear below your mic input ("Rear Pink In" for me). Hit that and enable the Microphone Boost in the next screen.

    That has completely solved the quite microphone problem I was having.
  23. iriss

    iriss TS Rookie

    i have tried every ways which mentioned in this thread. my mic was all silent still.
    i installed Realtek Driver R1.50, pulling "Front Pink In" and "Rear Pink In" up, ticking "mic boost" and blah blah blah

    BUT i can use "mic" to record now!!! Indeed my "mic" is not really a mic... it is an earphone!! LOL! it sounds odd and stupid but it does work!!
    so far i had tested on a JVC HAF120P ear bud headphone and a Sony's earphone (dunno its model), they both work well =)! i think it may related to the "stereo microphone" in which kikebabe had talked about before...
  24. Zimmer89

    Zimmer89 TS Rookie

    I'm having a similar problem to a lot of people in this thread. Although, I can alter the microphone recording volume and I can select 'Microphone Boost', the recording is still pathetic. Even with Microphone Boost on, the microphone has to be pretty much IN my mouth in order to record anything at all. I know it's not the microphone as it has worked on other systems, and I don't need to actually eat the microphone in order to record anything XD

    Just for reference, I'm using Realtek AC'97 onboard sound. I have a Gigabyte nVIDIA GA-K8NSC-939 motherboard.
  25. sigpop

    sigpop TS Rookie


    why are my mic boost settings in the output settings? like most others in this thread my mic was literally useless. i have a gigabyte ds3 mobo and windows xp pro installed. my mic is plugged into the rear pink input. i had to go to the output settings, unmute the rear pink input, then i was able to enable the boost when the advanced button was enabled.


    now when i talk into my mic it spits it out of my speakers. i want to disable that "feature". i want my mic to be used for input for skype, chat, etc... w/o that loopback.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...