Mic Problem with Realtek HD Audio Input

By nikm · 108 replies
Nov 30, 2005
  1. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    It's not exactly Hardware any more!

    I have seen this issue before as well, where the Windows IRQ assignments are not stabalized unless you restart. The fault seems to be the actual Sound card (onboard) that is just not real compatible with this.

    Sometimes the fix is to do a BIOS update (although you really need to know what you're doing here -> ie Not even the Motherboard manufacture guarantees BIOS updates won't stop your computer working all together !!!)

    Another option would be to purchase another PCI Sound card, and then plug the front Mic Snd into that (instead of the Motherboard) But actually this is a bit extreme too (ie Sound and Mic actually work!)

    You could uninstall sound Driver fully (from Add/Remove Programs) Then download the most up to date driver from the web.
    Yep, Start with that one :)
  2. Sun Guru

    Sun Guru TS Rookie

    OK...I've tried to install the drivers again and installed a newer version of it but still the problem persist.

    Now it tells me that "You;ve just plugged a device into the audio jack!" This message pops up when I try to insert the mic into the pink port and also when I insert the audio plug into the green port.


    What I've noticed is that I don't keep getting the pop up message anymore every 3 minutes. But still the mic won't function if only the mic in inserted. Both mic and audio need to be inserted for the mic to work.
  3. matthew.pait

    matthew.pait TS Rookie

    Ok, so I had the same problems with my new realtek onboard. I have, however, unlocked the secret of the realtek engineer's real genius. I now have everything working beautifully, and I am now going to blow everyone's mind away with the answer to all of your problems...or, most of your problems, I bet:

    In the audio mixer in realtek's crappy little soundboard, do the unthinkable: mute your mic. Or mute whatever input you're using.

    Done? Good. Now try it out. I bet you'll be very pleasantly surprised. For some reason Realtek seems to think that muting the mic equates to turning it on. Must be all that outsourcing screwing with the language...Or some disgruntled software engineer's last "f you" to realtek.

    Hope this helps someone. It made me a lot happier when I finally connected the dots.
  4. radekk

    radekk TS Rookie

    Had the same problem as everyone here, and this procedure helped! (strange as it seems). Thanks anyway and good luck you guys ;-)
  5. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Start->Run-> %windir%\MicCal.exe
  6. king21092

    king21092 TS Rookie Posts: 130

    I had the EXACT same problem on my computer.
    I remembering someone telling me to type something into Start > Run
    Then after that it opened some configuration window for my mic settings.
    I changed it from what ever it was on before to some "digital output" or something like that.
    If I remember what I had to type into run I'll make another post with some updates.
  7. Kebyn

    Kebyn TS Rookie

    I fixed mine.

    First I went to sound and audio devices in the control panel, clicked the audio tab, then the volume button under 'sound playback.' Click options > properties and tick all the boxes. I maxed the volume for every slider.

    Then I clicked the volume button under 'sound recording.' The recording slider was down near the bottom, so I put the slider up to the top.
  8. callumd

    callumd TS Rookie

    Here's how I got it working on my computer.

    First, make sure your microphone is plugged in to the *rear* pink jack.

    Bring up your Realtek HD Audio Manager (either double clicking it in the taskbar, or it will be in Start->Settings->Control Panel).

    Under the "Mixer" tab, find the < and > arrows near the right of the screen. Keep clicking the > button until you see an option for "Rear Pink In". Underneath it, you should see a button with two dots on it like this -> ..

    Click it!

    Now tick the box that says "Microphone boost" and click OK.
  9. Gotooh

    Gotooh TS Rookie

    Ok, so I got a problem with my mic. When ever I am using ventrilo and when ever someone talks at the same time as I do it creates massive feedback. I have a MSI k9N SLI V2 motherboard that has built in Realtek. I have tried to upgrade all the sound drivers and nothing helps still. I would prefer to not have to buy a sound card, but if no one can help that may be what I have to do
  10. tiddlydum

    tiddlydum TS Rookie

    Still Problems

    Yes, I already worked out that the Pink in was what I wanted, but, even with gain, it was a whisper. Also, CounterStrike:Source and other games failed to pick up the Microphone, as my microphone was not on the Microphone In. Any help?
  11. whoisrich

    whoisrich TS Rookie

    Abit IP35Pro XE Motherboard, headset, re-installed Windows XP with drivers from the abit website.
    Where my mic worked before, now had to shout to hear my voice, sliders maxed and boost enabled.
    Tried the latest drivers from the realtek site, but it was still the same.

    Solved the problem by going back to the version on a cd with the motherboard, which worked without needing the boost option, just the mic slider maxing.

    Abit Site Version: R1.90
    Realtek Site Version: R2.14
    Included CD Version: R1.79

    I have uploaded it incase anyone else wants to try this version, but as my account is new it wont let me make links, so you will have to copy and paste:

  12. invertedmark

    invertedmark TS Rookie

    I'm not a techie by any means. Just been bought a new Philips webcam with mic and installed on an XP system with realtek 97 (soundcard?). The mic just won't work. I've been through all the formulas in the previous posts; downloaded the latest driver, searched through advanced volume settings etc to make sure things aren't muted, and done a hardware check on the audio driver - all fine.
    Curious thing is, in the volume control - options- properties - recording, there is no check box for pink, green or brown. Instead all I've got is mic in, line in, phone in etc.
    I've been into the sound manager and checked that it's 2 way speakered, hence the pink in is definitely still mic in.
    Like I say, old system, tecnophobe me - but do I just need a new sound card, new mic on USB or is it cheaper than all that. Thanks ever so much in advance....

    oops, should have said. Webcam itself works fine with Philips supplied driver...
  13. cartes

    cartes TS Rookie


    This took me a while but here is the solution. You may want to try jumping straight to Step 3 as steps 1 and 2 were only to make sure I had the latest Realtek driver.

    Step 1: Control Panel > System > Hardware > Device Manager > Sound, video and game controllers > Realtek High Definition Audio (right click) > Uninstall. Restart.

    Step 2: Get the latest XP executable from realtek dot com dot tw (there was a quick link to HD Audio Codec Driver when I visited). Run the exe to install the latest drivers. Restart. Then follow the menus in Step 1. and re-enable the Realtek device.

    Step 3: This is actually really simple - Realtek/windows has the controls we need under the Master Volume mixer rather than in the Recording Control mixer, you just need to add the items to the panel. (If this doesn't work then maybe you'll need to follow steps 1 & 2 above afterall.)
    Control Panel > Sound and Audio Devices > Audio
    Now click on the top two volume buttons and you'll have the two mixers open.
    Master Volume: Options > Properties
    Scroll down the list and you'll see entries like 'Rear Blue In' and 'Rear Pink In' (blue is regular line in, pink is microphone). Check the ones you want and click OK
    Now the items you've just checked will show in the Master Volume mixer. All you need to do now is lift the sliders so they aren't set to xero.

    One thing to note: the main volume slider on the Recording mixer is still needs adjusting for recording. The step above just allows you to hear what you are recording.

    That's it, hope this works for you.
  14. corman

    corman TS Rookie

    I have not read any one using a USB mic and how to solve things...

    I have a Dell laptop, XP with the RealTek v 5.10, ALC268 that is acting all weird with my MicFlex USB mic.

    If I go and set the USB mic as input and the RealTek as output, then record some screen shots via Hyper Cam2, I can't hear the audio. If I go back into the sound control prefs I see the USB mic has been switched back to output instead of input. If I restart the computer and pull out the USB mic, then the audio will play back so it was recorded, but it won't play back if the mic is plugged in?

    Where is the issue here, I am lost trying to solve this.


  15. ncbrchary

    ncbrchary TS Rookie

    Mic problem with RealTek Audi Input

    Even I have almost similar problem.

    My comp is a Intel 945 GCE mother board, Intel C2D 1.6 GHz processor, 2Gb RAM, and on board RealTek hardware.

    I installed the RealTek Audio drivers. But when I try to speak on the mike from my microhones on Skype, Windows Live, Yahoo or Google Talk, it just refuses to work. And also, when I start my comp, the first thing comes up is and error message which reads "This version of RealTek Audio software is not supported on your desktop board". I am wondering if this message has something to do with my non-working of mike. I can always hear what the other perty is talking. But whatever I talk they cannot hear.

    Can anyone came across this situation? Please let me know if you have any solution. I do not use the mike to record voices. It is purely for Voice Talk purpose.


  16. catleugh

    catleugh TS Rookie

    I tried allsorts to get my mic working with Realtek HD, and Gigabyte Motherboard. It was finding the mic OK when I plugged it in, but the mic I was using had a mono jack plug, and when I changed it for one with a stereo jack everything worked perfectly. Also, I have just bought a mono to stereo jack adaptor plug off eBay for £1.99 inc. postage. Just type mono stereo adaptor into eBays search engine.
  17. prasannashetty

    prasannashetty TS Rookie

    hi Was Frustrated,
    Thanks a lot for solving my problem... i did exactly what you suggested, works fine with Skype

    thanks again

  18. rastamanx

    rastamanx TS Rookie

    I was able to solve the Realtek low mic input volume problem on my system by enabling the microphone boost advanced setting under the realtek audio manager.

    Below are the detailed steps:
    1. Open up the Realtek Audio Manager.
    2. Go to the MIXER tab
    3. Under the Playback section (with Realtek HD Audio output selected in drop down menu), click on the Mixer Toolbox icon (looks like an open crescent wrench)--see attached pic "mixer toolbox access".
    4. The mixer toolbox window should open. Make sure there is a checkmark next to the "advanced controls" option. (See attached pic - Mixer toolbox)
    5. Click OK
    6. Go back to the MIXER tab window...under the Playback section (with Realtek HD Audio output selected in drop down menu). Click on the "<" and/or ">" buttons (at bottom right side of Playback section, to scroll thru the playback auctions until MIC VOLUME is displayed. (See attached pic - Mic Volume Advanced control access).
    7. Click on the ".." button under the MIC VOLUME slider to access the advanced setting options window.(See attached pic - Mic Volume Advanced control access).
    8. Check the MICROPHONE BOOST box in the advanced setting window. Click OK.
    9. Then click OK to exit the Realtek Audio Manager.

    Your implement volume should now be boosted significantly.

    Details of my system:

    Cyperpower PC
    Windows XP 32-bit
    EVGA x58 motherboard (audio onboard)

    Realtek HD Audio Manager Info:
    Realtek audio driver version
    Direct X 9.0
    Audio Controller: HD Audio
    Audio Codec ALC889

    Good luck!


    Attached Files:

  19. Gizmoholm

    Gizmoholm TS Rookie

    what u mean by " While viewing the "Realtek HD Audio output' mixer device, make sure to check the box to wherever you have your mic plugged in. For me it was "Rear Pink In". (I had looked through the list before, but was always looking for "Mic In", not this pink crap)." ... where is that "rear pink in " or where should mine be ?

  20. iflyaround

    iflyaround TS Rookie

    realtek mic problem

    After tearing my hair out and trying many of the above suggestions to no avail, I went off on my own,
    I went into the bios and looked around, low and behold, under advanced;front panel support; I saw the HD audio option was selected. I changed that to the only other option I had, and walla! now the mic and headphone icons on the realtek audio manager are no longer grayed out, and my mic works fine.
    To those of you who, like me are computer illiterate, a word of caution: keep careful records on paper of every change you make in bios so you can return back to the settings that existed before you entered or ooohh, big problems can occur!
  21. pandaman

    pandaman TS Rookie

    dosent register on computer

    my microphone dosent work period it was workin yesterday and all of a sudden the computer no longer picks it up its a realtek audio device im not sre of the exact model and i have windows vista if anyone can help id apreciate it
  22. cfsimmons

    cfsimmons TS Rookie

    realtek audio driver download

    I had a problem, with my audio, on my mic on my laptop, did not work, so i downloaded the realtek.
    so I downloaded the drivers from Download dot com - (and it worked) !!! and virus free !!

    so goto download dot com

    and put realtek audio hd in, and you will get the codec for windows xp
  23. Keglimp

    Keglimp TS Rookie

    i have exact same problem. i noticed if you arent using the front panel you should change it to just ac97 in the bios. i am currently fiddling with a few things will post up if i fiX anything.
  24. cpyou

    cpyou TS Rookie

    microphone blues

    Hi all,
    This is a very interesting forum and thank you for having me.
    I just bought a new MSI U210.
    My issue is with the internal mic, (and the sunken power button, and sticky keys).
    The audio is very low.
    Thank you all for being here,
  25. rcubed

    rcubed TS Rookie

    I had the problem where the mic would not record.

    I've worked out the problem. The miccal progam trick worked once but then it happened again and I worked out what really goes on.

    For some reason the (Horizontal) balance control on the *record* control panel gets moved to the right hand side which effectively mutes the mono microphone. From that point on the record level and record mute has no effect. (As a side note, and as expected the, mic level on the Master Volume control panel always work independently from the record setting/problem - that just sets how much mic level goes directly to the speakers.)

    To fix the record balance control:
    - Start -> Control Panel -> Sounds And Audio Devices.
    - Click Audio Tab
    - Under Sound Recording click Select "Realtek HD Audio input"
    - Click Volume Button
    - Under Recording move the Balance control to the left (or centre)

    (As already mentioned, for most mics you need to enable the mic boost.)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...