1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Mic Problem with Realtek HD Audio Input

By nikm · 108 replies
Nov 30, 2005
  1. Hi

    I just got a GIGABYTE GA-8I955X motherboard which has the Realtek HD Audio on board. The system its running on is:

    P4D 3.0Ghz
    2GB DDR2
    256MB ASUS X800
    2 x 250GB Seagate SATA
    Win XP Pro SP2

    The problem is, the mic input for some reason records softly. Ive plugged it in the rear and front jacks and it picks up a scream and records it as a whisper. In the Volume Control the Mic input sliders are greyed out so I cant adjust it in there. The mic works fine on any other PC.

    Ive installed all the latest M/B drivers, BIOS, Realtek Drivers, etc from the respective websites to no avail. Another thing that happens is loading premiere pro causes the system to reboot you guessed it.. when it gets to loading the WAVE input DLL.

    When I disable the audio, it loads fine.

    The HD Audio input is selected in the media settings and the Hardware Test comes up ok. (Go Figure)

    If Anyone has any ideas or has come across this before please let me know. I think the guys at Realtek are at a loss and haven't responded to my last email.

    - N
  2. tecnosky

    tecnosky TS Rookie

    i have the same problem, did you solve it? If so please post it.
  3. seanp789

    seanp789 TS Enthusiast Posts: 110

    I would recommend submitting this problem directly to realtek AND Gigabyte repeatedly. It is more likely they are ignoring you than anything else. Resubmit every couple days until you get a response.

    Its also possible since you are not the only one that this is just a flaw they have not fixed and may never fix. Onboard sound doesnt get the most attention in MoBo design.
  4. Beclour

    Beclour TS Rookie Posts: 23

    Same problem here. Let us know if you hear anything.
  5. JBudOne

    JBudOne TS Rookie

    Hope you all still check this. I had the same problem guys. I searched for a long long time, went to MANY forums, and tried so many approaches. I decided to update my sound driver. I tried add new hardware, but it couldn't find the mic. I'm sure you all tried this too. With RealTek open, the driver updated and all, I took out the mic and plugged it into the back of my computer (the other mic spot) and then a popup came up from RealTek (New jack plugged in) so I clicked it, and it asked for what it was, so I clicked for mic. Then I tested it, and ya it worked you guys =D I was almost jumping up and down with excitement cause I couldn't get it to work since new years =O Anyways, if this works for you guys too PLEASEEEEEEE send this around on any forums you asked for help and found no solution on too. If theres any other problems, feel free to email me or add me --> LourveStruck@hotmail.com I'll be happy to tell you guys in detail everything i've tried before doing this, and ya. Hope it works you guys =))
  6. ncyphe

    ncyphe TS Rookie

    This doesn't solve my problem. Due to the design of my computer case, I have no front ports for my mic and headphones. The port in back recognizes that its a microphone, and I can relay sounds through the mic, but I can't get the recording properties to activate.

    I really need help solving this.
  7. JBudOne

    JBudOne TS Rookie

    Hey, so I have helped a bunch of people so far since then. Another thing you could try is putting the mic in another jack (that isn't supposed to be for the mic), when the message pops up select microphone and it should work. If not, double check that you have the latest version of Realtek. Also try plugging it into different Jacks, otherwise, =( I don't know what to suggest.
  8. Was Frustrated

    Was Frustrated TS Rookie

    My Solution

    My system had the mic grayed out as if my system was incapable of accepting mic input. I couldn't get my mic to respond for recording or any speech application. Here's what I did:

    1. Go to control panel, then sounds etc. button, then sounds and audio devices
    2. on sounds and audio devices properties, select volume tab, and click on 'device volume' 'advanced' button.
    3. on master volume, click options, then properties.
    4. under the 'playback' option, where it says 'show the following volume controls', make sure the box is checked that corresponds to the place you are plugging in your mic.

    Hope this saves somebody from the frustration I was experiencing.

  9. Bill Gable

    Bill Gable TS Rookie

    I finally got a response from MSI hope this will help someone. Here is the Webb site I finaly got a reponse from. Hope the rest of you who have this problem will contact them at: http://support.msi.com.tw/program/mbx/mbxQstAskDetail.php?serials=56876
    Dear Sir,
    The problem I am having with your "Realtek HD Audio input" I can not get the microphone working, it shows it but it is grayed out. I have tried every thing I know to do. According to every thing I have read on the Internet a lot of people are having the same trouble. Can you help???????
    They refuse to answer me. Can you please help me?

    I have Microsoft Windows XP Professional
    Version 2002
    Service Pack 2
    AMD Athlon(tm) 64x2 Dual
    Core Processor 3800+
    2.00 Ghz, 2.00 GB of Ram
    Physical Address Extension

    MSI Mainboard K9VGM-V
    VIA K8M890+VT8237A Chipset Based
    MSI NX6200TC TD64E

    Thanking you in advance for your help,

    Our solution
    Our Answer Hi,

    We have not recieve user feedback before. Would you please refer to the following steps to verify:
    1. Clear CMOS as described in the manual. Then boot system up and load optimized default.
    2. Uninstall the old audio driver clear. Please reinstall it. Download it from the following link:
    3. Make sure you have update BIOS to 1.1 version:

    Best regards,
    MSI Technical Support

    Let me know if this helps anyone,
  10. spakis

    spakis TS Rookie

    Hi all,

    I have the same problem, everything been working fine for 2 weeks then lost mic. all greyed out as described above. mine is a ga965p-ds4. none of the problems i have searched for work either the only thing i came across which i didnt try was muting all the devices in the record conttrol panel (sound properties goto options -> properties -> select realtek HDA primary imput maksure sure all check boxes are ticked click ok to get to next screen) then to the right where you see the greyed out volume controls makesure all are muted except MIC. that didnt work for me but for others it has im still waiting fro realtek to get back to me too. so if anyone does see another solution please post, looks liek we coudl eb waiting abit for a patch.


  11. tiduswavezero

    tiduswavezero TS Rookie

    MIC only plays through left ear

    Hey I have realtek on my computer and i've been having some microphone problems just like everyone else on this thread. But my computer recognizes the microphone without any trouble. The problem is, when I record (or even when i just plug in the mic into the jack), I only hear playback through my left ear!! I've been trying to figure out what's wrong for 5 months now but when I call HP for tech support, they always make me pay and they never fix my problem. Please, if someone knows what's happening, please tell me.

    I also have another computer (a Dell), and I have a similar problem on that one except the playback comes on both ears, but one ear is louder than the other. Im guessing the mixer's settings are screwed up but I dont know how to change that and nothing seems to work.

    If anyone can help me, please do!
  12. afoonamedmario

    afoonamedmario TS Rookie

    im havin mic problem where i can record but mic picks up loud annoying scratchy sounds. this happens with voice applications. in Ventrilo when i talk the mic picks up extremely loud noises. the only thing that works good with mic is windows sound recorder thats about it. if any1 has similar problem plz help =]
  13. Sharkfood

    Sharkfood TS Guru Posts: 1,018

    I had similar problems but turned out to be something totally strange/last place I would have normally looked. Try this on for size to see if it also fixes you:

    1) Download the latest REFERENCE HD Codec's directly from RealTek's website. Install the whole program with the systray audio manager application.
    2) Upon reboot, go into the RealTek Audio Manager.
    3) In the mixer tab of the RealTek HD Sound Manager, scroll with the little arrows on the right all the way until you see a device for "PC BEEP"
    4) Mute this device.

    Your PC beep will no longer be audible through your speaker setup (no biggie if you have a case speaker anyways), but all the bleed-through pop, crackle and hiss I was getting from recording in audio applications aside from Sound Recorder is totally gone.

    Hope this helps!
  14. robscott

    robscott TS Rookie

    My problems are simalar to those of nikm at the top post here.

    I have a new PC with these specs:

    MB Nvida Nforce 680SLI board.

    CPU ntel Core 2 Duo E6600 2.4GHz

    RAM G.Skill 2GB (2x1GB) PC6400 DDR2 Dual Channel

    Video Nvidia 7600GT 256MB PCI-E

    With of course the on board Realtek HD Audio.

    I also had the greyed out sliders on the mike controls. The mike would work in record if I yelled, and it worked in Teamspeak at a low volume but was useless in the games because if a heavy feed back of game sounds.

    I updated all the drivers, including the latest versions published a few days ago on 12/29//06 with no inmprovement.

    At the suggestion of a friend, I installed a second sound card for use as audio input only. Fortunately I had an old creative card in a drawer that had not seen use since Windows 95 or Win 98 about 7 years ago.

    Whn I rebooted it loaded right away. I immedieately disabled the game port, as that is useless now. I then went to the windows sound settings, and setup ythis card as my default input device and left the output on the Realtek.

    Everything is working fine now for me. My Mike is plugged into the creative and My Headphones are plugged into the Realtek. Of course I do not have use of the front mike input, but that is do-able.

    It may not be the fix you want, but it will serve as a workaround until Realtek gets their act together. Even if you don't have an old card laying around, You can pick up a new generic card at Newegg for less than $20. It will serve the Mike problem, and you still have the onbord card to feed your speker system.
  15. johnnygoodface

    johnnygoodface TS Rookie

    You Won't Believe It!!!!

    Hi gang,

    I think I've finally found a way to correct OUR low microphone volume issue (the Front Pink thing of my ALC880) .... it works for me :bounce:

    Install the latest Realtek drivers (v1.54 in my case) and reboot
    Go to C:\Program Files\Realtek\InstallShield
    Locate the program MicCal.exe and execute it
    • 1st window : Click Next
    • 2nd window: Select the recording device (if like mine there's only "Realtek HD Front Pink Jack" available anyway)
    • 3rd window : HERE'S WHERE I THINK EVERYTHING HAPPENDS :rolleyes: ... Try speaking and almost no sound will get thru the VU-Meter. Now MOVE the slider left to 0% THEN BACK TO 100%. Click next.
    • 4th window : It will ask you to read alound a sentence after clicking the "Record" button. Do it.... You might receive an error message. Don't mind it and click the "Cancel" button.
    That procedure seems to have reset my microphone setting back to a decent recording volume on my machine... :haha:
    Doing a simple test with the Windows Sound Recorder with confirm that you've succeeded or not.

    Have fun people!

  16. MagNet

    MagNet TS Rookie

    I got a new laptop (no second soundcard workaround for me) recently and have pretty much the exact same problems.

    Well unfortunately, for me, the MicCal doesn't fix anything.
    I think the problem is somewhere in the multi input source since my input sound seems to be some kind of mix of the mono or stereo mix and microphone, however the microphone is VERY silent, even after using the MicCal, pretty much anything I can hear is when I tap right on the microphone or blow at it.

    And even worse thing happens if I connect an external microphone to the jack then the input is completely silent. I just think the drivers are so unnecessarily complicated, I mean, the jacks worked even when there was no software detection for them, and they worked in an instant, now I gotta wait for a sec before it switches between integrated and external audio devices :p

    Making a support for multiple input sources with no source selection, how fun. I just hope there will be a fix soon, I wanna use some other mike than the one on my VoIP phone that was bundled with the lap :p

    So if I get this right, this problem lasts for over a year, basing that on the first post and yet they still manufacture computers with this kind of sound card and driver onboard, oh darn. Guess there's really not much possibility someone will fix this eh? Dang it.
  17. DerekW

    DerekW TS Rookie

    Good to know I was not the only one with this problem. I had hoped that someone had sorted it but it seems not. Anyway, I trolled through the boards and no luck but I picked up on something some one said regarding the Realtek HD Audio Manager. They had a laptop and mentioned the arrows to the right of the playback mixer and said they had selected the SPDIF slider to get things working. I clicked on the right arrow but my SPDIF (whatever that stands for?) output didn’t have a slider! But on clicking further along, I found I had several other sliders and in particular a Front Pink In and a Rear Pink In, both of which were muted! I un-muted them and also clicked on the little button beside them. This revealed an advanced setting with a tick box labelled Microphone Boost. I happened to have my manual volume control turned up at the time and when I clicked OK after ticking the box in the Rear Pink In (the input my PC camera’s connected to), WHAM! Instant feedback of major proportions! The mic was obviously working.. A quick video test with the camera confirmed that my input volume was okay. This still doesn’t solve the problem of greyed out sliders or no sliders at all in the Realtek record side of the mixer but hey, I can at least record decent sound levels now. Let me know if any of this works for you.
  18. MagNet

    MagNet TS Rookie

    Well I always knew about those arrows thus this is no help. My main problem is that when I connect a mic to mic in it's completely silent so I can either use the ****ty integrated mic or buy a USB one which is kinda inconvenient since I have a lap. And it as you mentioned already doesn't do anything with the locked sliders. I've already contacted realtek telling them I've got the newest drivers and all and they told me to update the drivers. Then contacted Acer and they told me to try formatting and if it won't work contact them... I seriously don't feel like formatting now as I know it won't help anything :p
  19. charliewb

    charliewb TS Rookie

    I've tried every suggestion and tried to get an answer out of realtek, so so far no luck. Hardware tests fine, but not matter what I do I the mic in and line in stays greyed out and they don't work at all.

    I saw a post on another forum that the front panel connections mut be disabled on the mobo in order for the back connections to work. Not sure about that. I have a Fatal1ty board. Anyone know how to confirm teh front panel connections are disabled? The board supports it but I don't have any front panel audio jacks, only a USB/firewire.
  20. kikebabe

    kikebabe TS Rookie

    i think that i know everyones problem here.

    Ive bot laptop with realtek hd audio codec alc883. so every one problem is that we have to buy stereo microphone, because the sound card supports stereo microphone, i have built in two microphones so i think that we all have to find is how to make the input mic mono not stereo. i will search google and i think that ill find a solution. But 100% is the stereo input thats way you all guys here only on one speaker when u speak in the mic. I here in both of them but when i speak in both mics :hotbounce if some one finds solution before me pls send me mail on krisbliz2000@yahoo.com#

    I hope that i helped :rolleyes:
    I know that i helped:giddy:
  21. d4v3

    d4v3 TS Rookie

    THANK YOU!!! this worked for me!! :D
  22. Momodesu

    Momodesu TS Rookie

    Guys I've had the same problems as you guys.

    I unplugged and plugged my mic back in and the Realtek Audio Manager pops up, asking me to choose either Line-In, Mic, or something else. Mic was checked, but I manually checked Line-In instead. This could probably fix some of the problems you guys are experiencing.
  23. euthymius

    euthymius TS Rookie

    The problem is not that the microphone is not recognised, but that there is no such thing as "Advanced" mode in the Realtek panel, where one could activate the "Boost Microphone" option still available in the "AC'97". Is there any OTHER way one could work this around, such as installing software capable of boosting an analogue microphone? Or a like solution?
  24. euthymius

    euthymius TS Rookie

    *SOLVED* - partially

    Actually, what Derek wrote here [https://www.techspot.com/vb/post385910-17.html] solved my "boosting the mic" problem. What remains is that compared to AC'97, the quality of the recording is utterly unbearable: as low as the first records in the 20th century. Can this be solved, too?
  25. lilschnowyguy

    lilschnowyguy TS Rookie

    Still not solved at all really.

    I have this problem too. Not so much the mic isn't picking up sound, just that the slider's are all grayed out, why the heck would this happen?
    Fair enough the mic works, but there is no user control at all!

    The way I made it pick up more sound was to select rear pink in under playback or front pink, dont matter, and in there is mic boost, this actually boosts the mic's input despite it being under playback.

    But still, when you buy the latest in computing, you'd expect at least some microphone volume controls!

Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...