Minidump help please

By stranger7 ยท 16 replies
Apr 15, 2008
  1. Hello,

    My PC has been getting quite a few blue screen errors, the most common one being "PAGE_FAULT_IN_NONPAGED_AREA"
    I have also gotten "IRQL_NOT_LESS_OR_EQUAL" a few times but 9 times out of 10 it is the 'page_fault_in_nonpaged_area' one.

    Sometimes it happens a few times in one day, sometimes it won't happen for a few days (and it will make me think its gone).

    It used to occur while I used to run an old Anti-virus program but ive removed that, and now it occurs either randomly, or when I use a program I have called RegCure (which fixes registry files).

    Attached are the 5 most recent Minidump files I have:

    Any help is greatly appreciated, thankyou.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Inside the 5 MiniDumps:
    I also notice that you have Regcure installed.
    Regcure has this unique way of causing programs to stop working
    And it may be the problem here too.

    If you still have the licence info, I'd suggest going to Add/Remove programs and removing it fully.

    Please reply back after this has been done, with the results

    If you are still receiving errors you may want to try:
    Start->Run-> sfc /scannow
    Which will confirm all Windows files are intact
  3. stranger7

    stranger7 TS Rookie Topic Starter

    Hi there,
    very sorry for the delayed response, ive been away for a while.

    Ok well firstly, I had run MemTest recently and it detected many errors, and suggested I replace the RAM on my PC.
    After only a few minutes of running MemTest, it would already begin detecting errors, so I knew something was wrong.

    So I bought new RAM (better quality and speed), just today.
    I ran MemTest, and after 15-20 minutes it was not detecting any errors, so I was quite sure its fine, which was good.

    I then however ran RegCure, and the PC crashed. So, I think as you suggested, it was probably also the fact that RegCure created problems.

    The thing is though, that I was getting blue screen errors even BEFORE I had installed RegCure. But I'll assume for now that it was because of my apparent dodgy RAM.

    So, I've uninstalled RegCure now, so far everything seems fine but I kind of have to give it time to see if the PC will crash again.

    Thanks kimsland, for your help, hopefully everything is good now, however if problems persist ill post again on here with the MiniDump again.

    OH and I ran sfc /scannow, in Start/Run, and it ran, I walked away from my PC though as it took a while and when I came back it was not running anymore, so I assume it finished and didn't report any errors, and just closed? I expected it to give a message saying that everything is fine if that was the case, does it just close on its own after completion?

    Thanks again,
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Thanks for the update :)
  5. stranger7

    stranger7 TS Rookie Topic Starter

    Ok, so the new RAM didn't completely solve my problems.
    After putting the new RAM everything has been pretty good until recently when the PC started crashing.

    Now I have a problem where the PC, while in Windows, will just freeze (can't move mouse or use keyboard or anything, it just freezes completely).

    Then when I reboot it, it takes a long time to start up. I thought at first it was just stuck in the start up screen but then I realised it just takes a long time to start up, in the DOS/display/startup screen, then when it goes to load windows it just takes a long time too, about 6-8 times longer than usual. Then when it starts, everything seems normal. If I reboot under normal circumstances it won't start up slowly. Only after it has crashed/frozen in windows.

    It has also had a blue screen crash a couple times, not as often, but it just happened now and ive attached the minidump file from the crash.

    I noticed it happens a lot when I am using Internet Explorer, but I think (not 100% sure) that it can also happen when im not using IE, too.

    Any help much appreciated...
  6. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Inside the 1 MiniDump:
    afd.sys: Ancillary Function Driver for WinSock
    Please update your Network drivers
  7. stranger7

    stranger7 TS Rookie Topic Starter

    Sorry if this is a bad question, but how do I update them?

    I went to Network Adapters in Device Manager, and clicked to update the driver of my NVIDIA nForce Network Controller.
    It searched the net but found no new update?

    Also there's another 2 network devices there which have an X on them, not sure if it means anything is wrong, I attached a picture of what im talking about.
  8. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    You can either right click on them and enable them, or remove them
    Restart and test again
  9. stranger7

    stranger7 TS Rookie Topic Starter

    Ok, well, ive enabled them, The "Network Adapter" was disabled, i dont know what that is but its enabled now.

    Tried updating again after rebooting the system as you suggested and it says the same thing though, that the latest hardware drivers are installed for my nvidia network controller.

    And im still getting difficulty start up the system, it will either take a long time to start up or freeze whilst in the Windows loading screen.
  10. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    What Antivirus and Firewall are you running again?

    Also you could run Startup Control Panel, and remove all the not required startups
  11. stranger7

    stranger7 TS Rookie Topic Starter

    The antivurs I have is NOD32,
    I only use the Windows firewall.

    Attached is a screenshot of everything on my startup (using the proggie you suggested), Im not even sure what some of those are, before I remove anything thought ide show you incase you know of anything thats definitely pointless to have there.
    Many thanks,
  12. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Hey that makes it easy

    HKLM Tab


    All the rest can go!

    Users Choice:

    WingMan Profiler: USB Monitor for Logitech Wingman Formula GP Steering Wheel. Turning it off will disable the input device it monitors.

    HKCU Tab



    Users Choice:

  13. stranger7

    stranger7 TS Rookie Topic Starter

    Ok Thanks for that, ive disabled everything apart from nod32k and Wingman Profiler (because I use it frequently with my Logitech Momo racewheel).

    I'll see how I go with that...
  14. stranger7

    stranger7 TS Rookie Topic Starter

    Still no good. It happens so random that sometimes I think its fixed and then it will crap itself again.

    Anyway, it just crashes all of a sudden, freezes. Well I thought it was freezing up to now, but I realised now that it actually just gets, really, really slow. For example ill move the mouse in a direction, and about 10-20 seconds later it will move in that direction.
    Sometimes when I reboot, it takes about 10-20 times longer to start up, too, even while in the DOS display menu at the start before getting into Windows, but also when loading Windows, so I assume its not a Windows fault.

    I just don't understand why it will work fine for a while, then it just haults for no reason all the time. Maybe I need better cooling for the motherboard and RAM?
  15. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Which you did :)

    But was this same problem happening before as well?

    Also have you removed all internal dust (high compressed air)
    Is CMOS set to defaults? Or are you overclocking anything?

    I believe this type of error is pointing to your CPU
    Which can make any test fail (ie memtest)
    You may need to re-seat the CPU (of course cleaning and applying new paste first)
    Here's a good area to start on that: ArcticSilver Instructions
  16. stranger7

    stranger7 TS Rookie Topic Starter

    Ok i still can't figure it out.

    Before I had my previous RAM, I was not getting this extremely slow startup of Windows, no.

    How do I know if CMOS is set to default?
    I am certain I haven't overclocled anything, although I downloaded Nvidia Monitor and it states that the speed of my CPU, Memory, FSB and a couple other things are running too high? I don't know how that can be when its all default.

    I'll look into re-seating the CPU as you stated although I fear I might ruin it altogether so want to take action of every other possibility first..
  17. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    When you first turn on the computer, you will see a prompt like press DEL or F2 (or some other key) to go to CMOS (it may say Setup or Bios or Config) You have about 3 seconds to press this key (after which, your computer continues starting)

    Once your able to get into CMOS
    Using your arrow keys and the Tab key, move around until you see Defaults (or optimized Defaults, or reset defaults)
    Select that one, then Save and exit CMOS (which is F10 on all computers)

    Now you have set defaults in CMOS
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...