Modem Port open

By The_Maestro ยท 6 replies
Oct 10, 2005
  1. I have a internal LUCENT Win Modem, every time I try and run diagnostics on the modem it says port is already open. I have tried uninstalling the modem and re-installing with the latest drivers and seem to get the same error. Any suggestions?
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Some other program is already using the modem? Hang up your dialup connection before trying the diagnostics maybe?
  3. jobeard

    jobeard TS Ambassador Posts: 11,166   +986

    Some good info for LT Win-modems can be found here

    here's a comment to consider
    Also remember that Windows modems use a virtual COM port - so the modem cannot be installed to an enabled physical COM port. (You can disable unused COM ports in your System BIOS which you can access before boot-up at system power-on.) Sometimes, other devices or drivers may be causing conflicts - it's a good idea to periodically check for system BIOS and driver updates for the other components of your system.​
  4. Triton

    Triton TS Enthusiast Posts: 82

    Move the modem to a different PCI slot.
  5. The_Maestro

    The_Maestro TS Rookie Topic Starter Posts: 52

    Still no luck

    I've tried a differant PCI Slot, disabled other com ports in the bios. and the modem is not connected to the net, which is why I originally tried runnning diagnostics. I have tried a differant modem and the other modem works fine. so I would think it would have to be a driver problem, except I'm using the latest drivers off the web. Any other suggestions
  6. Triton

    Triton TS Enthusiast Posts: 82

    The latest generic driver for the winmodem from Lucent/Agere is version 8.30 and it changes the name of the modem to Agere Winmodem.

    This driver self installs and can not be installed using the Hardware Wizard. Cancel the HArdware Wizard when it comes up and run the modem830.exe driver.
    The modem should be uninstalled by running the LTREMOVE.EXE program that is installed to your hard drive when the driver is installed.

    Try running the LTREMOVE program and then shutting down and removing the modem.
    Boot back into windows allowing the BIOS and windows to see the modem is gone.

    You may have to try several PCI slots. I have seen some systems very stubborn about these modems.

    I would leave the serial com ports in the BIOS enabled as disabling them sometimes confuses Windows about numbering them.
    The modem should install to com port 3 by default but if its installing to higher numbered ports with each failed driver install Windows is marking the ports in-use and the next install places the modem on the next higher port number.
    Once this starts happening it can be hard to recover, but you might be able to reclaim the in-use com ports.

    Personaly I think this is a driver problem as the Agere software modem "had" the same problem and the newest driver for it seems to have fixed the problem.
  7. The_Maestro

    The_Maestro TS Rookie Topic Starter Posts: 52


    Thanks for all the help gents, the modem is connecting fine now, I tried the link that you posted and installed that driver and it worked fine I had a slightly older lucent driver. Thanks so much.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...