Multimedia audio controller - not installed?

By garypic ยท 4 replies
Apr 12, 2008
  1. Hi,
    I'm new here so bare with me. my multimedia audio controller is not installed , i'm getting a yellow question mark next to it when i checked it in devices. my motherboard is-asustek p5vd1-xrev1xxx. the bios is an American Megatrends, Inc. I tried installing the ac-97 sound driver , but i got the dreaded blue screen. need help bad. I have no sound and no volume control on the bottom of my screen (tool bar)
    Any help out there?
  2. Matthew

    Matthew TechSpot Staff Posts: 5,333   +101

  3. garypic

    garypic TS Rookie Topic Starter

    Thanks for help

    Hi, Thanks for the help , I will try that today.
    ?- Should I download every new update from the motherboard site you gave me?
  4. Matthew

    Matthew TechSpot Staff Posts: 5,333   +101

    For each individual device, yes, you can. You don't want to download ALL of the files on your motherboard's page though as there are driver files for various operating systems. You only need to download one driver per device that is compatible with your operating system.
  5. X1950XT

    X1950XT TS Rookie Posts: 17

    You could do what i did. In device manager right clcik the one with the yellow sign next to it and click uninstall. It will uninstall and automaticly install itself when you start your computer. I had problems like that and that's all i did and it worked!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...