My Flash Drives pick up as Removeable Disk that are blank

By Cpt. Obvious
Jan 18, 2006
  1. I wonder if someone can help me.

    I have a Albatron KM400T-8x Pro motherboard with the latest bios. It is a replacement board I got for the previous one.

    If I put my USB Flashdrive in the USB port, it picks up as Removeable Disk but the is no DATA on the drive. :knock: If I take it to another PC it picks up perfectly with Volume Label and DATA on it.
    I tried format and re-install windows but no use. I added a add-on USB connection but also no use. Re-installed the Drivers of the board no use. Updated VIA drivers no use.

    I wonder if it might be my Case or PSU that gives the problem.


    Thanks for your time.

    Obvious out
  2. Cartz

    Cartz TS Rookie Posts: 82

    Ummm, You running XP or 98? If its 98, you don't have the properly software to handle USB drives... If its XP, I unno.
  3. Cpt. Obvious

    Cpt. Obvious TS Rookie Topic Starter

    I have Installed Windows XP SP2 and all the newest update of the motherboard installed. But what I still don't understand is why??

    The first board was faulty and did not pick anything up as said above....then i went and got a replacement board.....then fresh installed WinXP worked for like 2 weeks then went back to the usual of not picking up any data on the flashdrive.

    A mouse works on the port. With startup you have to pull out the mouse cable and then reconnect it. A printer picks up and everything...installs drivers...but then does not print.

    So any suggestions will be appreciated because I give up on this. A new board from other make I think will fix it but have to see.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...