Need to delete a corrupted file.

By treeski ยท 9 replies
Feb 21, 2008
  1. Hey all,
    I have a corrupted and unreadable file on my computer that I can't simply delete. Is there any way to force a file deletion or something like that?
    Any help is appreciated,
  2. Matthew

    Matthew TechSpot Staff Posts: 5,332   +101

  3. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

    You're going to have to give more information if you expect help.

    What type of file are you trying to delete?
    Where is the file?
    How did you try to delete it? From where/?
    What happens when you try to delete it? Error message?
    What operating system are you using?
  4. treeski

    treeski TS Evangelist Topic Starter Posts: 990   +233

    Alright, the file is called tos.html.temp and it's in a game (world of warcraft) program that I'm trying to update. I had an error while updating and when I try to re-update I get a message that the update can't make the above file, then I get an error that it is corrupted and unreadable. It's also on an external hard drive, if that makes any difference.

    I tried deleting it by simply clicking on it and hitting delete. I also tried the above user's suggestion but both ways I get the same error: the file is corrupted and unreadable.

    "Cannot delete tos.html: The file or directory is corrupted and unreadable."

    I only get that for that specific file. I'm also running on windows XP.
    I was also unable to uninstall the game.

    Thanks again
  5. jobeard

    jobeard TS Ambassador Posts: 11,131   +982

    which is it?

    look for some server running that has the file open; stop it

    you could boot Safe Mode and delete it from there
  6. mickzer

    mickzer TS Rookie Posts: 101

  7. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

    treeski, the fix and others having the same problem are on this WOW page:

    Page title is: ". "The Update could not be applied."
  8. klan36

    klan36 TS Rookie

    Delete (almost) anything

    There's a little utility called "Unlocker". Try it
  9. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Have you tried re-installing the game over the old one and then uninstalliing?
  10. treeski

    treeski TS Evangelist Topic Starter Posts: 990   +233

    Thanks much everyone. I tried the suggestion about booting in safe mode and for whatever reason i was able to get rid of the file. Thanks for the help I appreciate it!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...