Network cable unplugged error, but it's not unplugged

By slym34
Aug 24, 2009
  1. I am having this issue and have been searching online for days with no solution, so hoping someone here can help..
    I have a dell laptop that suddenly started getting this message about network cable is unplugged, when it in fact isn't.. I cannot run ipconfig, i get an error that says it's not allowed. I have uninstalled and reinstalled the drivers. The light on the network port is on, and I've tried several known working cables with no luck. I even went so far as to buy a dlink ethernet adapter that plugs into the laptop slot (pcm I think it's called) and this network card has the same issue, however works perfectly in another machine. I have tried winsock repairs I found online, but having no luck anywhere.
    Any suggestions? Any further questions? Thanks!

  2. Kcircyrd

    Kcircyrd TS Rookie Posts: 216

    If it is not unplugged, you have a damaged socket, damaged cable, or damaged or defective ethernet card.
    What error flags to you have in the Device Manager?
    What is your Dell model and how old is it?
    Using a strong light and a magnifying glass, look for bent or twisted wire in the ethernet socket., or just plain ol dirt, dust, hair, and fiber.
    Still, a bad cable is most user's most likely problem. Do't forget that the other end of the connection can give you the same error message.
  3. slym34

    slym34 TS Rookie Topic Starter

    I have no errors in device manager
    it's a inspiron 9300 and a little over 2 years old, no longer under warranty so dell won't help.
    the reason i don't think it has anything to do w/ the actual ethernet socket or cable is because not only does the internal one give me that problem, but i bought a new dlink wired adapter to put in the pcm slot and it also had the same issue, however worked perfect in another laptop. so 2 totally different ethernet cards in different ports w/ issues.
    also, have tried several other working cables and still same issue, but cable works fine in another laptop.. not sure if virus is a possibility or something w/ registry? I can't put my finger on it at all..
    I also did a checkdisk w/ no issues just for kicks..
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    If you've ruled out hardware, it has to be software. Perhaps there is some malware that can cause this to happen. Might be worth doing the crap that is stickied in the malware forum...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...