1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Network controller with yellow exclamation mark

By d9aco · 37 replies
Jul 7, 2012
Post New Reply
  1. Hi, I have a I MSI U135DX for some reason it all of a sudden just stopped connection to the internet wirelessly but would connect via and ethernet cable. I have researched this and and struggling to get it sorted. I have managed somehow to connect again via the ethernet cable but still no wireless connection.

    In my device manage it says network controller with a yellow exclamation mark but when I try to re install or update the driver it says the driver was not installed correctly. When I go to my internet connection or to set up a internet connection it does not even show any wirless conections.

    I have made sure that the wireless connection is on and have eventurned it off and on to see if it would connect but I am guessing that it is a problem with this netwprk driver.
    Please could someone help as I am at a complete loss now and have tried to download drivers from the MSI website but still no luck.

    Many thanks
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,546   +429

    The driver from the MSI website should be exactly what you need. Odd it isn't working. Have you tried completely uninstalling the device from 'device manager' and then rebooting? After doing that you should be able to install the MSI one and be set....
  3. d9aco

    d9aco TS Rookie Topic Starter

    Hi, yeah I have tried uninstalling, re installing full recovery of the netbook. I have tried all the drivers from the MSI website but nothing seems to work. It just wont show up as being able to detect a wireless network. I am still researching it though and hopefully I will have it working by the end of the day lol
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    List any Problem devices
    • Make sure devices are connected and powered on
    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
    • On the other hand, if no devices are listed, tell me so
    Generate and attach a DirectX report
    • Click Start->Run, enter dxdiag and click OK
      ===> If you’re running 32 bit Windows, dxdiag will launch on its own
      ===> If you’re running 64 bit Windows, you’ll see 64-bit DxDiag. Click it to launch the 64-bit version of dxdiag
    • Notice progress in lower left window corner
    • When done, click Save Information button and save as a text file to your Desktop
    • You can attach it to your next post by clicking Upload a file to attach it
  5. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,546   +429

    I am not an expert in this area. But in my experience, a good troubleshooting first step here would be to completely disable any encryption (WPA, ect) on your wireless, just broadcast pure unencrypted goodness. See if you can get connected to that.

    <obviously don't stay unencrypted for too long>

    Edit- Wow, good post LookinAround. I'll just turn this thread over to you now, however, it might still be worthwhile to know if he can connect to an unencrypted wireless network.
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Hi SNGX

    I've noticed that even if network hardware (ethernet or wireless) exists and is detected by Windows, it won't appear in Network Connections until its driver is installed correctly. So OP's statement (above) makes me wonder if root cause is still a driver error.

    That problem report and dxdiag report should (hopefully) show us what hardware is being detected, the driver error and hopefully enough to figure out what's going on (hopefully)
  7. Spiv13

    Spiv13 TS Rookie

    I am having a similar problem.
    Just got a new "Accent" I30IL1 laptop, I have no disk or drivers, I cannot find support for it on the Net.

    I installed Win7 Ultimate and the WiFi stopped working.
    Checked in Device Manager and there is an exclamation mark in 'Network Controller', a look at the properties shows:
    --manufacturer is 'Unknown'
    --the driver is not installed
    --Location: PCI bus 3, device 0, function 0

    The Network Adapter is a 'Realtek RTL8102E' supposingly working properly.

    Can someone please help me locate a driver or suggest a workaround?

    Many thanks for sharing your knowledge.
  8. jobeard

    jobeard TS Ambassador Posts: 12,550   +1,440

    The Realtek RTL8102E is your wired LAN adaptor and the chore will be to find the OEM driver from the PC vendor.
    Two questions: What's the brand/make of the PC and how did you install Win/7 Ultimate - - reformat?

    The issue is very likely to be a missing signed driver for that specific device.

    From the PC support site (using your LAN connection), you should be able to get driver for your WiFi device.
  9. Spiv13

    Spiv13 TS Rookie

    Hi Jobeard,
    the Laptop is branded "Accent" at the back, the model No says: I30IL1, no more info unfortunately.

    I am temporarily in Morocco and my laptop died and I just bought the first reasonably priced I found, it had W7 Pro preinstalled, but it was in French and I could not understand a thing......
    So I installed W7 Ultimate using my DVD.
    I tried unistalling the controller and let Windows look for a driver, but it cannot find it.
  10. jobeard

    jobeard TS Ambassador Posts: 12,550   +1,440

    Ok. Use Google to find Belarc Advisor; download, install & run as admin (no need to get updates just now).

    Under System Model you will find details of the PC vender & model.

    Under Communications you will find the LAN and WiFi devices. My Wifi (even though disabled) still shows up as
    Dell Wireless 1502 802.11g/b/n

    HOPEFULLY you can see yours
    Spiv13 likes this.
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Hi Spiv13

    If you're still having a problem locating a driver for your wireless let us know and also run the instructions in post #4 earlier in this thread to provide the two reports listed

    fyi.. Here's a tech tip...
    1. Every Plug and Play device has a device name burned into its firmware. The firmware name is typically something very generic. (Many wireless network controllers have the genric firmware name Network Controller)
    2. When Windows finds the device driver, it starts using and displays the device name if finds defined within the driver
    3. So when no driver found (as in spiv's case with wifi) only the generic firmware wifi name will be displayed (which, of itself, doesn't help in finding the driver)

    In your case, even tho your wifi is disabled, its driver is installed. That's why you have the useful name Dell Wireless 1502 802.11g/b/
  12. Spiv13

    Spiv13 TS Rookie

    OK, the PC is "DBM MAROC ACCENT"

    This is under communications:

    Microsoft ISATAP Adapter
    ↑ Realtek RTL8102E/RTL8103E Family PCI-E Fast Ethernet NIC (NDIS 6.20)
    primary Auto IP Address: / 24
    Dhcp Server:
    Physical Address: 00:03:0D:E8:F1:41
    Connection Speed: 100 Mbps
    Teredo Tunneling Pseudo-Interface

    Networking Dns Server:

    Not sure about the WiFi adapter....

    I found drivers here: http://drp.su/download.htm
    Chrome says they appears to be malicious, do you think I should disregard it and run the installer?
  13. Spiv13

    Spiv13 TS Rookie


    the Problem device report:
    Network ControllerPCI\VEN_10EC&DEV_8172&SUBSYS_818110EC&REV_10\4&1B121E8E&0&00E1The drivers for this device are not installed.
    Attached is the DxDiag report,
    Hopefully it will help.....

    Attached Files:

  14. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Your wireless network controller also uses a Realtek chip so it'll also be a Realtek driver. But I'll have to look for the matching driver later. Will reply again later or tomorrow

    Don't download the drivers on that other website
    Spiv13 likes this.
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Oh. That didn't take long :)

    First, create a System Restore point (is always wise, just in case)

    Here's my best guess. Your wireless is a Realtek RTL8192SE chip. Go to the Realtek download site HERE.
    Check RTL8192SE then click Go. Download the Windows 7 driver version ZIP file. Extract the files to a folder on your Desktop. Then run the Setup.exe file. You may need to reboot to complete the install process.
    troyquintos and Spiv13 like this.
  16. Spiv13

    Spiv13 TS Rookie


    that worked like a charm :), you are a legend mate!
    Thank you!
  17. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    You're most welcome. Glad to hear it worked (y) We're all happy to help :)
    troyquintos likes this.
  18. jobeard

    jobeard TS Ambassador Posts: 12,550   +1,440

    Spiv13 likes this.
  19. williedynamite

    williedynamite TS Rookie

    I seem to be experiencing similar problems concerning wireless connection as those mentioned by Spiv13. So LookinAround I'm looking at you for help on this one. I have an Acer 5560 laptop that is running on Windows 7 ultimate, the wireless capability of this laptop stopped working suddenly yesterday. Now even when I turn on the wireless adapter via the F3 key, the computer still won't recognize any wireless signals and says it is still waiting on an ethernet cord to connect to the internet. Okay, that is a little background for the story; I went ahead and ran the reports you asked the others to run:

    Network Controller PCI\VEN_168C&DEV_002E&SUBSYS_E034105B&REV_01\001517FFFF24141200 The drivers for this device are not installed.

    Attached Files:

  20. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Hi @williedynamite and Welcome to TechSpot

    That looks like an Atheros wireless card. Have you gone to the support site for your motherboard make/model and downloaded/installed the Atheros wireless driver?
  21. williedynamite

    williedynamite TS Rookie

    It's working! I could have sworn I did that previously, but obviously not correctly. Thanks
  22. ina618

    ina618 TS Rookie

    Hi im having the same problem.. my laptop is lenovo G550

    Ethernet Controller PCI\VEN_14E4&DEV_1693&SUBSYS_386017AA&REV_02\4&2BCEBCDB&0&00E5 The drivers for this device are not installed.
    Packet Scheduler Miniport #5 ROOT\MS_PSCHEDMP\0004 This device is not working properly because Windows cannot load the drivers required for this device.

    Attached Files:

  23. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Go to the Lenovo support site for your computer model HERE.

    Install the Broadcom WLAN wireless driver for your version of Windows
  24. Mark west

    Mark west TS Rookie

    Hi, I have got the samsung r530 laptop and connect to a wireless network, it says not connected -no connections are available, I have uninstalled the driver and re-installed it and that hasn't worked, I have clicked on PROBLEM DEVICES and a PNP DEVICE comes up PCI\VEN_168C&DEV_002B&SUBSYS_7167144F&REV_01\4&150BFCAA&0&0&00E0
    Driver is not installed

  25. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...