New battery shows up as not detected, but works

By ericmooney12
Feb 6, 2016
Post New Reply
  1. Ive been trying to figure this out all day, I have an hp 2000 2d60dx notebook with windows 10 64 and I went on customer assistance and replaced it with the battery I was told to use, and the new battery worked fine all day WITHOUT the ac, I just couldnt see the charge level and then it died finally. my old battery before I plugged the new one in you could its charge level, now you cant. can anyone help? this is really frustrating, new battery works fine, just cant see how much percentage is left and I dont know how long I should leave it plugged in for...

    I tried uninstalling and reinstalling acpi compliant battery
    and unplugging ac cord and battery while holding down power button
    and tried uefi to see the battery in boot bios, but nothing showed up just hard drive a memory check
  2. ericmooney12

    ericmooney12 TS Rookie Topic Starter Posts: 21

    Update: my original oem battery still shows the charge level, just not my new replacement

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...