new HD detecting problem

By Tari ยท 7 replies
Jul 7, 2005
  1. hello!

    motheboard: abit kt7a-raid (HPT-370)
    storage: 2 x 40Gb HD set on raid 0
    os: windows xp

    i recently got a new 160Gb Hitachi. i connected it on a free IDE port. bios detects HD normaly and when booting to DOS all kinds of disk tools (partition magic, ghost, etc ...) are capable to detect HD. when booting into windows, HD is not there (disk management doesnt see it). i have set a reg key EnableBigLba, set partitions manualy with partition tool and nothing helps. but when i disabled raid controler and tried to install fresh copy of windows only with new HD, evrything works ok. oh and if i connect HD to a raid controler as JBOD, windows detects it normaly but unfotunally after 20-30 sec after system is up, blue screen appears with some strange msg about "driver stack buffer overflow error"

    any idea?

  2. patio

    patio TS Guru Posts: 482

    Have you formatted the drive after setting the partitions ? ?

    patio. :cool:
  3. Tari

    Tari TS Rookie Topic Starter

    yes i did

    but it does not need to be formated for seeing it in Disk manager as far as i know

    TMSKILZ TS Rookie

    Tari did you change the boot sequence in your Bios? Sometimes with certain Motherboards, you have to set it as "SCSI" in the "1st Boot Seq" option, for your PC & WIN OS to recognize a SATA HD.
  5. Tari

    Tari TS Rookie Topic Starter

    TMSKILZ read my post again and you'll see i am talking about IDE and not SATA. And boot seq has nothing to do with not detecting secondary HD in Windows
  6. sundewzer

    sundewzer TS Rookie

    In windows when you go to the device manager can you see the hard drive (Doubtful but maybe)? If you can't have you tried find new hardware "Scan for hardware changes"? Have you tried hooking it up to a different computer?
  7. Tari

    Tari TS Rookie Topic Starter

    tried on other computer and it works. as i said before if i disable raid and connect only new HD to IDE than i can normaly install windows on it and it works great. and even if i do a fresh windows install on raid disks with new HD on IDE as a secondary disk, its also ok. but this doesn't solve the problem, right :(
  8. Tari

    Tari TS Rookie Topic Starter

    ok i solved the problem :bounce:

    in Device manager i have deleted Primary and Secondary IDE Channel and in Storage volumes all Generic volumes and restart. after restart new disk was detected

    oh and thanx for trying to help :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...