1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

New motherboard got fried?

By Dorial ยท 7 replies
Oct 12, 2009
  1. Hey! I'm new here and I really could use a hand.
    Today I went off and bought myself a new chassi, one more graphic card and a motherboard, all brand new. My old motherboard was okay but a bit outdated. Besides, I've been thinking about doing crossfire with my 4850.

    Took me a couple of hours to set things up. After everything was done I started it up (I was suprised it even started). The only problem that came up was "Unknown CPU Detected. Update BIOs for full power" or something like that. I tried starting it up, got a blue screen. I read up on some forums and people with the same problem said that you'd have to update BIOs. The problem here was that I recieved no CD from my motherboard box. So I went on my brothers computer, which I am at right now, and downloaded the latest bios for my motherboard. Burned it on a CD and then used it to update bios. Everything ran smooth as well. It said that it had to restart, everything was still fine. Then after it resetted, nothing happened. I tried to start up the computer but nothing happens. A blue light starts glowing, along with the gfx card for a mere second. But that's all!

    So here I am tired, frustrated and disappointed. The manuals didn't tell me jack-all about anything of this. Everything I plugged in was correct. My old computer was built from scratch so I did everything on my own and it worked.

    Any ideas? I think I fried the motherboard for some reason, but I can't get to bios and fix it. I read online as well that you could take out the battery and decharge it, but I'm not that skilled to be playing with the chips. ANY suggestion how to fix this is GREATLY appreciated. Thank you!

    (And sorry about the wall of text)

    And yeah, here's my spec:

    Asus ATI Radeon HD 4850 1GB (2 in xfire)
    Asus - Socket 775 - ATX nForce 780i (Striker II Formula)
    Intel Core 2 Duo E8400 3,0GHz / 6MB / 1333MHz Socket 775
    Corsair XMS2 4096MB DDR2 PC2-6400 800MHz
    Seagate Barracuda 7200.12 500GB SATA II
    Windows Vista x64 bit

    Tell me if you need more information.

    Edit: After letting the computer cool for a bit, it starts up, only to be shut down after about 20 seconds.
  2. raybay

    raybay TS Evangelist Posts: 6,908   +10

    CPU's rarely fail... but if it has pins, check the pins to assure none are bent over...
    Did you overclock before you got it running in normal mode?
  3. Dorial

    Dorial TS Rookie Topic Starter

    No. I haven't been doing any overclocking at all before, my old chassi was crap and only had one small fan. And I never really got "my new" (My old parts combined with a new chassi, one more gfx card and a new motherboard) computer to work, only to BIOs and I didn't touch anything except EZFlash to update bios. I'm gonna be doing some trial-and-error later today, switch back to my old motherboard and see if that's the problem. It might be the x2 gfx cards as well...
  4. Dorial

    Dorial TS Rookie Topic Starter

    Okay, a little update...

    I switched out the motherboard with my old one, and it sort of worked. The computer was alive for about 30 seconds with my old motherboard when it was up for about 5 seconds with the new one. I still can't get to windows, it closes before that and I can't sit idle in bios that long either. I tried both gfx cards and the result was still the same.

    So I've ruled out, almost, the motherboard and the graphic card.The only new thing left is the chassi, and I don't think it's the one f'n it all up...
    So, I must've screwed things up quite badly while installing. Something must be broken and I have no idea why.
  5. Great1122

    Great1122 TS Enthusiast Posts: 109

    Did you check the CPU pins? Any bends or breakages? if not check the cpu heatsink, ensure all wires connecting to the heatsink are fine, and not ripped, and the heatsink pins are all good too. Unless you're sure that the heatsink work, but to do that you'll have to keep the case open and power it on, unless you have a see through case.
  6. WinXPert

    WinXPert TS Guru Posts: 397

    Did the 3 LED's (Num, Caps & Scroll Lock) blinked when you power-up your PC?
  7. Dorial

    Dorial TS Rookie Topic Starter

    Okay, I think I've solved it now.

    I check the processor and everything seemed fine, but after running some tests I found out that the heatsink was the problem. The pins holding the heatsink to the processor was broken at it was simply "hanging", thus shooting the temperature up to 90+ degrees.

    I returned the motherboard and got myself a new one. And I think I was lucky to get my money back. After updating the bios, it probably shut down the computer right before it was done and corrupting the whole motherboard. I'm going to buy a new heatsink later today and then run it again and see if there are any other problems.

    I will post an update later today! Thanks!
  8. Dorial

    Dorial TS Rookie Topic Starter

    Solved it. Got a new heatsink now and computer is working a-okay, except that I can't get the crossfire to work but that's another problem. Thanks!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...