Newbie needs help installing a driver

By saiorse44 ยท 6 replies
Nov 22, 2007
  1. Hi everone

    I am a Windows user that is beginning to make the migration to Linux but at the
    moment I have very little knowledge of Linux. :eek:

    I wish to install the your drivers for my Technotrend budget S2-3200 card, I
    have tried but I usually end up with a screen full of errors.

    Could you be so kind as to write me a short beginners guide on how to get this
    card up and running on a clean install of Mythbuntu 7.10.

    The drivers I am trying to install are these:

    I have tried going into the directory of the extracted files and typing "make"
    but to no avail.

    Are there other things I need to be doing like with V4L?

    Many Thanks,


    P.S. I tried posting on the Ubuntu forums and emailing the driver author but to
    no avail.
  2. Exonimus

    Exonimus TS Rookie Posts: 77

    could you tell me exactly what is going wrong? I just downloaded the driver from the website you specified, unzipped it, went into the directory, typed 'make' and it starts making. Is it that it's not doing anything? does it give any output? is the make successful but don't you know where to go from there? it would be easier to help you if you specified the problem more clearly. Also: if it does make, you also need to type sudo make install afterwards.
  3. saiorse44

    saiorse44 TS Rookie Topic Starter Posts: 23

    Hi there. many thanks for your reply. :)

    On a clean install of Mythbuntu I downloaded and unzipped the drivers and got the following when typing make into the terminal in the unzipped directory:

    rob@MythBox:~/Desktop/multiproto$ make
    make -C /home/rob/Desktop/multiproto/v4l 
    make[1]: Entering directory `/home/rob/Desktop/multiproto/v4l'
    No version yet.
    Updating/Creating .config
    Preparing to compile for kernel version 2.6.22
    File not found: /lib/modules/2.6.22-14-generic/build/.config at ./scripts/ line 31, <IN> line 4.
    make[1]: Leaving directory `/home/rob/Desktop/multiproto/v4l'
    make[1]: Entering directory `/home/rob/Desktop/multiproto/v4l'
    Updating/Creating .config
    Preparing to compile for kernel version 2.6.22
    File not found: /lib/modules/2.6.22-14-generic/build/.config at ./scripts/ line 31, <IN> line 4.
    make[1]: *** No rule to make target `.myconfig', needed by `config-compat.h'.  Stop.
    make[1]: Leaving directory `/home/rob/Desktop/multiproto/v4l'
    make: *** [all] Error 2
    Can you see where im going wrong?
  4. Exonimus

    Exonimus TS Rookie Posts: 77

    you're not doing anything wrong =)

    it seems you miss certain files. I did a quick search on google, and it looks like you need the linux-header files. I, myself, am quite new to linux, so I don't know much about most problems, but I think it's worth a try.

    You need to do the following:

    see which version of the kernel you have. Open up a terminal window, and type: uname -a
    for me, it gave this output
    Linux roelof-desktop 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

    now, execute the following command: sudo apt-get install linux-headers
    it will say

    Package linux-headers is a virtual package provided by:
    linux-headers-2.6.22-14-xen 2.6.22-14.46
    linux-headers-2.6.22-14-virtual 2.6.22-14.46
    linux-headers-2.6.22-14-ume 2.6.22-14.46
    linux-headers-2.6.22-14-server 2.6.22-14.46
    linux-headers-2.6.22-14-rt 2.6.22-14.46
    linux-headers-2.6.22-14-generic 2.6.22-14.46
    linux-headers-2.6.22-14-386 2.6.22-14.46
    linux-headers-2.6.22-14 2.6.22-14.46
    You should explicitly select one to install. But which one? well, that's why I told you to execute the uname -a command first! :D in my case, it said
    2.6.22-14-generic. From the stuff you posted, I'm pretty sure you have the same. Now we know which version we have, we type

    sudo apt-get install linux-headers-2.6.22-14-generic 2.6.22-14.46

    now, for me, it said it was already installed, but for you, it could be that it's not installed yet. Hope it solve your problem. Good luck! and if it doesn't work, don't hesitate to report back here =)

    Again, I'm not sure if this is the problem, but I got it by searching google. You can always give it a shot. Also, if it's indeed not installed, you might need to reboot
  5. saiorse44

    saiorse44 TS Rookie Topic Starter Posts: 23

    Hi, many thanks for your reply.
    Sorry for not getting back to you sooner on this one.

    I tried what you said, and the make and make install now seem to work and the stb0899 (what the S2-3200 card is based on) shows up in lsmod along with associated items.

    The problem I have now is that although the /dev/dvb folder has now appeared/ it contains another folder called adapter0 in this folder there are four files called:
    • demux0
    • dvr0
    • fontend0
    • net0
    however all four files are empty.

    MythTV backend setup also hangs whilst tring to add a new capture card.

    Any ideas?
    Rob :)
  6. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    The files are supposed to be empty, because they are devices, not normal files.

    Make sure they have proper permissions for the MythTV user.
  7. saiorse44

    saiorse44 TS Rookie Topic Starter Posts: 23

    I have made my user a member of the mythtv group but mythtv backend setup still hangs add "add new capture card". :confused:

    Thanks I didn't know this, I am still learning my way in linux :rolleyes:
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...