"No audio mixer device" error

By Sui89 ยท 6 replies
Jul 31, 2007
  1. I recently switched drives on my computer to start fresh, since the old drive had been being used for quite a while. Upon completing the installation and starting up (along with all of the Windows updates being downloaded and installed), I noticed that there was no sound. At all. Nothing when Windows booted up or shut down, nothing for Internet streaming or videos, nothing for Windows Media Player or iTunes. Just nothing.

    After some investigation, I noticed the volume control gave the "No audio mixer device installed" error. Long story short, I spent the majority of yesterday and a lot of today searching the Internet for possible solutions to this, and I'm now finding nothing new for suggestions about it. Here's what I've already tried, and didn't work:

    1) Checked all of the drivers in the device manager (I'm using on deck sound). All are functioning properly.
    2) Did the suggested "Add Hardware" option to update to the latest drivers, all of which I already had.
    3) Done Start -> Run -> services.msc -> Windows Audio, and made sure it was started up and set to automatically start on setup.
    4) Made sure that the sound was enabled in the BIOS.
    5) Inserted a modified "machine.inf" file into the Plug and Play Enumerator.
    6) Start -> Run -> msconfig -> Services, and made sure Windows Audio was checked and running.
    7) System Restore (to check if one of the updates might have caused the problem)
    8) Made sure the speakers were still functioning properly

    That's all I can REMEMBER doing, although I researched the whole thing for so long, there might have been something else I also did. Just so I'm clear though, when I go to "Sound and Audio Device Properties", everything is blanked out and I can't do anything there either.

    So I'm honestly stumped as to why the sound is still not working on the computer. I've been to every tech/support site that Google has to offer, and all of those things I've tried already have been from there. I just don't know what more to try from here. So I figured I'd ask personally and see if anyone here could help me out with this. Thanks so much in advance for any advice that anyone here is able to give.
  2. zoril_uk

    zoril_uk TS Rookie

    is your hardware enabled ?
    check it out via control panel -sound,speech and audio - sound and audio devices - hardware.
    highlight your sound device and click on properties.
    at the bottom of the window check that the device is Enabled.
  3. Sui89

    Sui89 TS Rookie Topic Starter

    It doesn't even give me an option to do that. Everything on there is blanked out that I can't pull down the pop down menu to enable or disable the device.
  4. tipstir

    tipstir TS Ambassador Posts: 2,475   +126

    1. did you update/install the chipset drivers - reboot system
    2. did you update/install audio drivers - reboot system

    Make sure you do the main MOBO drivers first before you start loading audio software from third party. You now will have to remove any audio drivers from Windows then reboot system and see if Windows direct it. Sounds like your driver got corrupted..
  5. Sui89

    Sui89 TS Rookie Topic Starter

    Tried both of the above and everything's exactly the same as it was before. Still nothing.
  6. dlt

    dlt TS Rookie

    I have this same problem now -- it started after installing Spore last night. Everything was fine until that point.
  7. CCT

    CCT TS Evangelist Posts: 2,653   +6

    You don't have the 'same' problem since what caused it is not the 'same' - and this is a year old post.

    Delete your post here and start your own thread with ALL pertinent data (specs, etc).

    thanks - :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...