1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

No audio over HDMI to TV

By tm872110 · 6 replies
Jul 18, 2014
Post New Reply
  1. Hi everyone. I have a Gateway DX4885, running Windows 8, and I am trying to connect it to my TV with an HDMI cable. When I do this, I get a picture which looks very good. However, I do not get any sound. When I click "Playback Devices" on the speakers, I see no HDMI option. On "Device Manager," under "Sound, video, and game controllers," I see a "Realtek High Definition Audio," but it appears to be working correctly. Thanks in advance for any help!
     
  2. jobeard

    jobeard TS Ambassador Posts: 10,305   +788

    Shutdown the PC.

    cable the HDMI to the TV and set the tv to view that connection (it will initially say no signal).

    Boot the PC and you should see it install the driver. Select Duplicate outputs and it should display the desktop.

    Now play some video - -
     
  3. brian254

    brian254 TS Rookie

    Sometimes you actually have to right click on the speaker icon at the bottom right hand side, select playback devices, and there should be an option for HDMI AUDIO.
     
    bluto 2050 likes this.
  4. jobeard

    jobeard TS Ambassador Posts: 10,305   +788

    Correct - - once the PC has the HDMI drivers loaded.
     
    bluto 2050 likes this.
  5. bluto 2050

    bluto 2050 TS Addict Posts: 249   +31

    Sometimes the EDID broadcast from your your TV or amplified device > HDMI handshake to PC or source has to re renegotiated and and turning off and turning on the playback device or TV will get it working but usually that's with no video or anthing .

    outside of the above rt click on taskbar or control panel speaker > open playback device tab > Irt click > disable any device at playback devices that you are not using for this HDMI path and rt.Click > enable select the HDMI device ,panel or TV you want to use for the correct audio path > rt click the selected HDMI device > test to confirm your audio data path is correct .

    If not above reconfigure your audio data path in windows and or your HDWE driver GUI's presuming your audio data main board header is routed correctly for your d/GPU HDMI and to pass audio data to HDMI or S/PDIF if you aren't using an IPGU or APU without a PCIe Video card HDMI out or discrete sound card S/PDIF out which is an alternate audio path for external audio decoding in a 5.1/7.1 AVR .

    If you are ultimately using a TV optical out for external decoding make sure digital audio out is [on] in the TV sound settings menu .
     
    Last edited: Jul 18, 2017 at 12:53 PM
  6. bluto 2050

    bluto 2050 TS Addict Posts: 249   +31

    exactly and OP may have to do that each time anything changes of its own accord or by the user or just because anyway ☺
     
  7. jobeard

    jobeard TS Ambassador Posts: 10,305   +788

    Usually, you just set the HDMI as he default :grin:
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...