No beep. No signal. Nothing. HELP

By fobsternd ยท 4 replies
Mar 19, 2007
  1. I have a Nf4 Ultra Infinity mobo that I sent back to the manufacture for an rma. They sent it back to me 2 weeks later. The first time i sent it to them was because when i started the computer, the loading screen would get stuck on the Infinity logo. I took the computer to a computer store, they told me the video card AND my motherboard was broken. I went to buy a new video card and sent the mobo in.

    Now Im having this problem. I cant seem to start my computer up. On the monitor, it saids "no signal". Plus there is no *beep* when i power the computer on. I upgraded from a geforce 6600 to a 7900 now. I also bought a new psu , (500w). I have a AMD 64 3000 venice cpu. WHat could be the problem.

    Today , DFI rep called me and tried to help me out but nothing worked and he suggested my cpu is broken?

    *PS- I disconnected and replugged EVERY wire and pin together from each component at least twice, so dont say "check the wiring or connections".
  2. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    I would start by reading the NO POST guide in the guides forum.

    Then check your PSU.
  3. ryan5262

    ryan5262 TS Rookie

    also remove all compnents see if you can get Beeps with no memory. and slowly rebuild see if its a part causing the no post.
  4. Gavincol78

    Gavincol78 TS Rookie

    Please can you post a link to that guide?
  5. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...