No signal with DP on wake up from sleep

By scubaslim ยท 21 replies
Jan 8, 2018
Post New Reply
  1. I have an XB241H G-Sync monitor. It works perfectly when using HDMI...

    but with Displayport, it works fine when freshly powering up the computer. It works fine when waking up from hibernation....

    but when waking up from sleep, which is my preferred method, the monitor will power up, the splash screen will pop up, then "no signal"... The PC is on, as it can play music and if I plug in a different monitor, it's working...

    I have tried the following:
    lowering the Hz
    swapping DP cables
    using High performance mode
    turning off link state
    making sure connections are tight
    switching to different DP ports on my GTX 970

    any ideas
     
  2. Cycloid Torus

    Cycloid Torus Stone age computing. Posts: 3,398   +861

    I'm no expert on this stuff, and I hope others can offer a better answer...but the problem is "sleep" - the combination of motherboard, RAM, video card and monitor just does not work as it should as it just does not fit precisely into the 'sleep' designed in the OS. Possibilities include too little voltage to RAM when in sleep due to the defined energy cap for this specification. Microsoft offers these ideas about how to fix the issue.
    https://support.microsoft.com/en-us...hoot-problems-waking-computer-from-sleep-mode
     
  3. jobeard

    jobeard TS Ambassador Posts: 11,794   +1,252

    Most interesting - - performs correctly after hibernate but not sleep. Hibernate is the more drastic of the two and shuts off as much power as possible.

    The obvious workaround is to use hibernate :grin:
     
  4. Cycloid Torus

    Cycloid Torus Stone age computing. Posts: 3,398   +861

    The idea here is that the RAM is not viable storage for the machine state - while the HDD, etc is. So what could prevent RAM from keeping its memory. My vote is bad design - I think there is an artificial cap - "one watt" - lurking in the specification for 'sleep' - but I suppose that it could be software/drivers/firmware. Maybe addressed in a BIOS update?
     
  5. jobeard

    jobeard TS Ambassador Posts: 11,794   +1,252

    You gave the video spec --what hardware platform are you using?
     
  6. scubaslim

    scubaslim TS Rookie Topic Starter

    here's what I'm working with....

    Windows 10 Home 64-bit
    AMD Ryzen 1700x
    G.SKILL Ripjaws V Series 16GB
    Acer PRIME X370-A
    NVIDIA GeForce GTX 970
     
  7. Cycloid Torus

    Cycloid Torus Stone age computing. Posts: 3,398   +861

    scubaslim likes this.
  8. scubaslim

    scubaslim TS Rookie Topic Starter

    Yep, ASUS, sorry got Acer on the brain.... I'll check that out tonight
     
  9. scubaslim

    scubaslim TS Rookie Topic Starter

    I updated the BIOS. It SEEMS to have fixed the problem. Only say seems because I thought a few other things had fixed it the past, but its definitely worked longer than any other changes I made. thanks!
     
  10. captaincranky

    captaincranky TechSpot Addict Posts: 13,529   +3,038

    There are known issues with PSUs upon resume from S-6 (?) sleep mode. This is the "Haswell certified" credit you'll often see on new PSUs.

    I still have trouble with my Skylake box, if left on "standby" for too long. It won't resume until I turn it off and on. It reboots, then resumes Windows from where it was.

    I honestly have no idea if this has anything to do with your issue. This is just a generic post about resume issues with very late model Intel based PCs.
     
  11. scubaslim

    scubaslim TS Rookie Topic Starter

    Welp, it stopped working again.... so I guess it wasn't the BIOS

    as for the PSU, I have an Antec a-750 Platinum
     
  12. captaincranky

    captaincranky TechSpot Addict Posts: 13,529   +3,038

    OK, you probably already have, or are aware of, the fact Asus most likely has a custom driver for that specific monitor.

    As for your resume issues, this might sound silly, (in fact it does to me as I type it), but perhaps the video card is "confused" as to what refresh rate it's supposed to resume at,and therefore doesn't. Is it possible you need to opt to variable refresh each time you game, and back to 60 Hz when you power down?

    I would however suggest, at least try to set your PC to "S-3" sleep, instead of the deeper S-6 mode, which is now standard.

    Have you tried Nvidia forums to find out if this is an issue with their current drivers?
     
  13. scubaslim

    scubaslim TS Rookie Topic Starter

    Yep, I have the Asus specific driver.

    How would I switch to S-3? I can't find that in the BIOS
     
  14. jobeard

    jobeard TS Ambassador Posts: 11,794   +1,252

  15. scubaslim

    scubaslim TS Rookie Topic Starter

    Still haven't figured this out, but I heard from Acer support and they suggested to disable monitor auto detect... anybody know how to do that??
     
  16. holdum323

    holdum323 Banned Posts: 1,725   +453

  17. scubaslim

    scubaslim TS Rookie Topic Starter

    DavidBailey likes this.
  18. holdum323

    holdum323 Banned Posts: 1,725   +453

    Hi! I research just like you do. I really have no experience with your issue. I posted two links I found. Let us know how things go.
    ;)
     
    DavidBailey likes this.
  19. Have you tried Google ?
    I answer most questions here by using it.
     
    holdum323 likes this.
  20. Contact the business you are working with.
    Looking for help in this forum is much lessless than contacting the manufacturer.
     
  21. scubaslim

    scubaslim TS Rookie Topic Starter

    yeah.... I've tried google... nothing I've found has worked...
    I haven't heard back from Acer yet and I'm anticipating them not being helpful
     
  22. Cycloid Torus

    Cycloid Torus Stone age computing. Posts: 3,398   +861

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...