No USB2 after XP Pro install on "SiS962 MuTIOL® Media I/O (Southbridge)"

By paulmarshall
Jul 14, 2005
  1. Hi there,

    My first post!

    As the title says, I used my own copy of XP Pro to do a clean install on my Packard Bell laptop. Now my USB2 sockets have been downgraded to USB1.

    The PB site has a patch which apparently should fix this, however it won't run as I have installed service pack1, and the patch says SP1 should fix the problem.

    I Googled "Sis962 drivers" and found what I think I am looking for on another manufacturers website (computer specs look exactly the same as mine).

    Is it possible these drivers will work, they are for the same OS and chipset so I think they might.

    Also, is it possible to uninstall SP1 (perhaps system restore?) and see if I can run the patch?

    Many thanks in advance!

  2. paulmarshall

    paulmarshall TS Rookie Topic Starter

    have solved this.

    for anyone with a similar problem;

    I laid my hands on a cd that came with a pci usb2 card. installed the disc but not the hardware and it worked a treat.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...