NTDLR is missing - drive will not format bad or damaged drive

By michelleans ยท 10 replies
Apr 15, 2006
  1. Hi

    I'm running an old Fujitsu T Bird with an Intel Celeron 433MHz CPU, 64MB RAM, and two HDD both Seagate one 80GB Barracuda, one 8GB and not for sale anymore on Windows 2000 Professional.

    I recently bought the 80GB HDD for this pc but since I first connected the drive to the pc it has always been found only as a slave, never as a master. I have used cable select and placed it on the master cable, I've also tried forcing it to be a master by placing the jumper on the MASTER ON SLAVE OFF, however it has never been detected as a master. I even tried using the auto selection in the CMOS setup does it does not recognise it.

    I then tried to load on windows 2000 onto the drive but it would not format the drive. The error message given was "could not format. drive may be bad or damaged" I then put my old HDD also a seagate onto the pc (that drive is detected fine as a master and is running windows 98 SE) and put the second drive as a slave which it finds. I then formatted the drive through windows 98 SE, shut down the computer and then tried once more to install windows 2000. This time windows 2000 installed fine with no problems.

    The computer started up and was running fine. I copied some files over from my USB flash drive onto the HDD (i have made a partition 40GB and 40GB) I did notice that it was copying over EXTREMELY slowly and while clicking on various folders inside the USB it was extremely slow. on the HDD however it was quick and there seemed to be no problem. I decided to shut down the computer and restart with both drives attached and my new windows 2000 drive as a master so that i could copy my old files from my old drive to my new drive.

    When i restarted the pc the following error came up "NTLDR is missing... press any key to restart" I tried to repair windows 2000 but it would not allow me then I proceeded to try to reload windows but while trying to reload windows the same error is coming up about the drive being bad or damaged and it is not formatting.

    I then replaced my old drive running winsows 98 SE and was going to repeat what i had done earlier to format the new HDD however now my windows 98 SE HDD is now giving the same error message!!! nothing i have found on the internet has worked and now both of my drives are not working..

    I had previously tried to install windows 2000 onto my older drive it's only 8GB and it loaded ok but when it came to finalising and updating the program settings it would stall and stop and then proceed to shut itself down and repeat this procedure. So I just reinstalled the previous windows 98 SE.

    A way of fixing the boot problems and also any suggestions on why the drive is not formatting would be greatly appreciated...
  2. michelleans

    michelleans TS Rookie Topic Starter

    Unfortunately I cannot test that drive in another pc at the moment, though I'll have a look and see if i can find anyone brave enough to let me open up their system. I'm pretty sure it won't come up as a master though, as I've placed other HDD's in that particular pc and they have always come up as masters when I set the jumper to master or cable select. My older HDD can be set to a slave or master also with no problems. When setting my old HDD to a slave both come up as slaves (primary and master) and it finds no operating system on either of them and no cd-rom.. I'll see if I can find any victims that allow me to use their system to test parts of mine...

    I don't think there's a problem with the Windows 2000 CD as ive used it before and it has loaded windows properly with no errors. The CD-ROM seems fine also and I've never experienced a problem with it before. Again, don't have another CD-ROM at my disposal unfortunately..

    I've downloaded Seatools from the website and will try that when I get home. I cannot format my older HDD as i've got very important files on it and do NOT want to lose any of them. The newer HDD has very little on it though but it cannot be formatted in Windows 2000 setup!! I'll defintiely try the Ultimate Boot CD too.

    If I did format that new HDD in a Windows 2000 operating system or above would that help the matter?

    Thanks for all the help and links!
  3. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    I can't say why master isn't working, if the jumper on the drive is set to master, and no other drives are on that cable, and the BIOS is set to autodetect, it should show as master. If not, maybe the drive really is bad and needs replaced. Perhaps try to run it as master in someone else's computer just to see.

    Second, it's also possible you have a problem with the CD itself, or your CD-ROM drive during the setup. If possible, also try a different CD as well as a different CD-ROM if you can.

    Third, download Seatools from Seagate's web site. You can start here: http://download.seagate.com/seatools/registration.nsf/eula/desktop
    Accept the EULA and then fill the details. Download the ISO and burn it to a CD. Then run the tests on it to see if your drive(s) are good.

    You may want to "zero out" the drive before using it again. The seatools may have an option to low level format or zero out the drive, if so you can do that. Of course it erases whatever is on the drive. But removes anything that might be lurking in the FAT or MFT. Otherwise you can find such a tool on the Ultimate Boot CD, http://www.ultimatebootcd.com/

    Do to limitations of the FAT32 OS, and being that you want to use Win2000, it's best to have 2000 format during setup, rather then attempt formatting to FAT32 in 98 and then trying setup. Give 2000 a blank disk to work with so it can start fresh with NTFS.

    Hope that helps any, good luck.
  4. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    lets try from scratch,have all the drives out but the 80 gb drive
    set to master at the end of the cable.
    go to bios set to LBA for drive disable quick boot (except drive errors(some bios's don't have this feature)
    save reboot
    see if it shows the drive on boot if it does continue with the install disc
    at prompt to load the OS there will be instructions to install install somewhere else and delete
    use delete and then it will prompt again to install (enter) and format bla bla bla
    if the bios does not see the drive try to set the drive to none in bios
    you will need to change this lateras this need to be seen for booting
    if the drive has a circuit board that uses contacts the contacts may be dirty and when it gets warm you loose the drive
    if you can I would see if there is a bios update for the machine may help can't hurt

    good Luck
  5. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    His post got above mine? Lol, guess you knew what I was going to say before I said it. ha
  6. texasbuc

    texasbuc TS Rookie

    Just a thought... your BIOS may not be seeing the drive properly because it is so large and your computer is several years old.

    Also, when you get the message that the NT Loader (NTLDR) is missing, it's usually because the boot.ini file is pointing to the wrong disk/partition combination. If you can get the HDD into another computer and modify that file to make it point to the right drive and partition (for YOUR computer), it might just work. That is a problem when you swap drives after loading NT, 2K, or XP.

    Hope that helps.
  7. Fatal Error

    Fatal Error TS Rookie

    I got the same thing before. I rebooted enough and it fixed itself out. Though I do thing that I had to manually boot from the Hard Drive instead of just letting it naturally boot. Can't really say much.
  8. michelleans

    michelleans TS Rookie Topic Starter

    Well I have it partioned 40GB / 40GB hopefully that's small enough to see the drive properly.

    I never thought of the boot.ini file pointing to the wrong disk or partition. Thanks for that suggestion.. I'm really interested as to how it could happen though, as just a moment before everything was working perfectly on both drives then suddenly both are not working and giving exactly the same error.. Could it be because I placed both drives in at the same time and because of the newer one not being recognised as a master, it could not decide which one to boot? Thus causing problems in the boot file...? I might need to fix it now, but I don't want it to occur again..

    About the boot.ini file itself, my drive is being recognised as a primary slave not a master... What drive number would it take on then for booting. It's a C:\ that the operating system is installed to while the partition is D:\ When I place the older drive into the computer it becomes a master and take C:\ while my newer HDD takes D:\ and E:\ Does it always stay a 0 for booting even if it's a slave not a master? Confused... Thought the slave took a HDD 1..

    I don't know how stable your system would be if the problem appeared to be gone due to continuous rebooting.. What a fantastic world we would live in if rebooting fixed all our computers problems... :)
  9. texasbuc

    texasbuc TS Rookie

    If the BIOS has trouble seeing the HDD, partioning it will not help.

    Check this out for a possible fix: http://www.tinyempire.com/shortnotes/files/ntldr_missing.htm

    Not sure exactly how to answer the remainder of your questions except to say that partitions are numbered starting from 1 (not 0), and that the drive number, I believe, is dependent on how Windows sees the drives.
  10. texasbuc

    texasbuc TS Rookie

  11. michelleans

    michelleans TS Rookie Topic Starter

    After all it turned out to be a bad drive and I had it replaced..

    Thanks to all who helped out
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...